summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2008-12-11 16:09:30 +0000
committerChristoph Mende <angelos@gentoo.org>2008-12-11 16:09:30 +0000
commit04653a3045b59a6c8e2fc2851da9ee2086596d99 (patch)
tree02b56115a366ac7f213986ca75c5f629a92667bc /media-sound/gmpc
parentAdding live git ebuild (Bug #250526) (diff)
downloadgentoo-2-04653a3045b59a6c8e2fc2851da9ee2086596d99.tar.gz
gentoo-2-04653a3045b59a6c8e2fc2851da9ee2086596d99.tar.bz2
gentoo-2-04653a3045b59a6c8e2fc2851da9ee2086596d99.zip
Removed usage of internal libsexy
(Portage version: 2.2_rc17/cvs/Linux 2.6.28-rc8 x86_64)
Diffstat (limited to 'media-sound/gmpc')
-rw-r--r--media-sound/gmpc/ChangeLog6
-rw-r--r--media-sound/gmpc/files/gmpc-0.16.1-system-libsexy.patch73
-rw-r--r--media-sound/gmpc/gmpc-0.16.1.ebuild12
3 files changed, 88 insertions, 3 deletions
diff --git a/media-sound/gmpc/ChangeLog b/media-sound/gmpc/ChangeLog
index 77aa5f4b10dc..60554a57b350 100644
--- a/media-sound/gmpc/ChangeLog
+++ b/media-sound/gmpc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/gmpc
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/gmpc/ChangeLog,v 1.44 2008/12/11 12:38:57 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gmpc/ChangeLog,v 1.45 2008/12/11 16:09:30 angelos Exp $
+
+ 11 Dec 2008; Christoph Mende <angelos@gentoo.org>
+ +files/gmpc-0.16.1-system-libsexy.patch, gmpc-0.16.1.ebuild:
+ Removed usage of internal libsexy
11 Dec 2008; Christoph Mende <angelos@gentoo.org> gmpc-0.15.5.0.ebuild,
gmpc-0.16.1.ebuild:
diff --git a/media-sound/gmpc/files/gmpc-0.16.1-system-libsexy.patch b/media-sound/gmpc/files/gmpc-0.16.1-system-libsexy.patch
new file mode 100644
index 000000000000..e07336781b0d
--- /dev/null
+++ b/media-sound/gmpc/files/gmpc-0.16.1-system-libsexy.patch
@@ -0,0 +1,73 @@
+diff -u -Nru a/configure.ac b/configure.ac
+--- a/configure.ac 2008-09-24 21:11:44.000000000 +0200
++++ b/configure.ac 2008-12-11 16:45:44.000000000 +0100
+@@ -130,6 +130,10 @@
+ AC_SUBST(gthread_LIBS)
+ AC_SUBST(gthread_CFLAGS)
+
++# libsexy
++PKG_CHECK_MODULES([libsexy], libsexy)
++AC_SUBST(libsexy_LIBS)
++AC_SUBST(libsexy_CFLAGS)
+
+ # sm
+ if test x${enable_sm} = xyes; then
+diff -u -Nru a/src/browsers/playlist3-current-playlist-browser.c b/src/browsers/playlist3-current-playlist-browser.c
+--- a/src/browsers/playlist3-current-playlist-browser.c 2008-09-24 21:11:43.000000000 +0200
++++ b/src/browsers/playlist3-current-playlist-browser.c 2008-12-11 16:47:14.000000000 +0100
+@@ -37,7 +37,7 @@
+ #include "gmpc-mpddata-model-playlist.h"
+ #include "gmpc-mpddata-treeview.h"
+ #include "eggcolumnchooserdialog.h"
+-#include "sexy-icon-entry.h"
++#include <libsexy/sexy-icon-entry.h>
+ #include "playlist3-messages.h"
+
+ #include "playlist3-playlist-editor.h"
+diff -u -Nru a/src/browsers/playlist3-tag2-browser.c b/src/browsers/playlist3-tag2-browser.c
+--- a/src/browsers/playlist3-tag2-browser.c 2008-09-24 21:11:43.000000000 +0200
++++ b/src/browsers/playlist3-tag2-browser.c 2008-12-11 16:47:34.000000000 +0100
+@@ -17,7 +17,7 @@
+ #include "misc.h"
+ #include "gmpc-mpddata-treeview.h"
+ #include "gmpc-mpddata-model.h"
+-#include "sexy-icon-entry.h"
++#include <libsexy/sexy-icon-entry.h>
+ #include <libmpd/libmpd-internal.h>
+
+ /**
+diff -u -Nru a/src/Makefile.am b/src/Makefile.am
+--- a/src/Makefile.am 2008-09-24 21:11:43.000000000 +0200
++++ b/src/Makefile.am 2008-12-11 16:46:34.000000000 +0100
+@@ -36,7 +36,6 @@
+ egg/eggaccelerators.c\
+ TreeSearchWidget.c\
+ qlib/qasyncqueue.c\
+- sexy-icon-entry.c\
+ edit_markup.c
+
+ gmpc_LDADD=\
+@@ -92,6 +91,7 @@
+ @gmodule_LIBS@\
+ @libglade_LIBS@\
+ @gthread_LIBS@\
++ @libsexy_LIBS@\
+ @sm_LIBS@
+
+
+@@ -111,6 +111,7 @@
+ @gmodule_CFLAGS@\
+ @libglade_CFLAGS@\
+ @gthread_CFLAGS@\
++ @libsexy_CFLAGS@\
+ @sm_CFLAGS@\
+ -DPACKAGE_LIB_DIR=\""$(pkglibdir)"\" \
+ $(MAYBE_CFLAGS)
+@@ -149,7 +150,6 @@
+ egg/eggcolumnmodel.h\
+ revision.h\
+ qlib/qasyncqueue.h\
+- sexy-icon-entry.h\
+ egg/eggcellrendererkeys.h\
+ egg/eggaccelerators.h
+
diff --git a/media-sound/gmpc/gmpc-0.16.1.ebuild b/media-sound/gmpc/gmpc-0.16.1.ebuild
index d6eea270eb70..d5740bbe2381 100644
--- a/media-sound/gmpc/gmpc-0.16.1.ebuild
+++ b/media-sound/gmpc/gmpc-0.16.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/gmpc/gmpc-0.16.1.ebuild,v 1.3 2008/12/11 12:38:57 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gmpc/gmpc-0.16.1.ebuild,v 1.4 2008/12/11 16:09:30 angelos Exp $
EAPI=1
-inherit gnome2-utils
+inherit autotools gnome2-utils
DESCRIPTION="A GTK+2 client for the Music Player Daemon"
HOMEPAGE="http://gmpcwiki.sarine.nl/index.php/GMPC"
@@ -22,10 +22,18 @@ RDEPEND=">=dev-libs/glib-2.10:2
>=media-libs/libmpd-0.16.1
net-misc/curl
>=x11-libs/gtk+-2.12:2
+ x11-libs/libsexy
session? ( x11-libs/libSM )"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-system-libsexy.patch
+ eautoreconf
+}
+
src_compile() {
econf $(use_enable session sm) || die
emake || die