summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-02-08 10:04:55 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-02-08 10:04:55 +0000
commit995f6cf3de80fe9bc110483c061c7040edb272eb (patch)
tree5f4ed416b03f1e242348d5eba163fec307f540e4 /media-sound/gigedit
parentversion bump, by Tim Harder <thorium90@gmail.com>, bug #257870 (diff)
downloadgentoo-2-995f6cf3de80fe9bc110483c061c7040edb272eb.tar.gz
gentoo-2-995f6cf3de80fe9bc110483c061c7040edb272eb.tar.bz2
gentoo-2-995f6cf3de80fe9bc110483c061c7040edb272eb.zip
fix build with gcc 4.3, bug #257516
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/gigedit')
-rw-r--r--media-sound/gigedit/ChangeLog8
-rw-r--r--media-sound/gigedit/files/gigedit-0.1.1-gcc43.patch24
-rw-r--r--media-sound/gigedit/gigedit-0.1.1.ebuild12
3 files changed, 40 insertions, 4 deletions
diff --git a/media-sound/gigedit/ChangeLog b/media-sound/gigedit/ChangeLog
index 9ce80052967c..3eb7e7bbe69b 100644
--- a/media-sound/gigedit/ChangeLog
+++ b/media-sound/gigedit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/gigedit
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/gigedit/ChangeLog,v 1.1 2008/01/27 10:15:26 aballier Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gigedit/ChangeLog,v 1.2 2009/02/08 10:04:55 aballier Exp $
+
+ 08 Feb 2009; Alexis Ballier <aballier@gentoo.org>
+ +files/gigedit-0.1.1-gcc43.patch, gigedit-0.1.1.ebuild:
+ fix build with gcc 4.3, bug #257516
*gigedit-0.1.1 (27 Jan 2008)
diff --git a/media-sound/gigedit/files/gigedit-0.1.1-gcc43.patch b/media-sound/gigedit/files/gigedit-0.1.1-gcc43.patch
new file mode 100644
index 000000000000..d5fbf2c23a1f
--- /dev/null
+++ b/media-sound/gigedit/files/gigedit-0.1.1-gcc43.patch
@@ -0,0 +1,24 @@
+Index: gigedit-0.1.1/src/gigedit/mainwindow.cpp
+===================================================================
+--- gigedit-0.1.1.orig/src/gigedit/mainwindow.cpp
++++ gigedit-0.1.1/src/gigedit/mainwindow.cpp
+@@ -18,6 +18,7 @@
+ */
+
+ #include <iostream>
++#include <cstring>
+
+ #include <gtkmm/filechooserdialog.h>
+ #include <gtkmm/messagedialog.h>
+Index: gigedit-0.1.1/src/gigedit/paramedit.cpp
+===================================================================
+--- gigedit-0.1.1.orig/src/gigedit/paramedit.cpp
++++ gigedit-0.1.1/src/gigedit/paramedit.cpp
+@@ -18,6 +18,7 @@
+ */
+
+ #include "paramedit.h"
++#include <cstring>
+
+ namespace {
+ const char* const controlChangeTexts[] = {
diff --git a/media-sound/gigedit/gigedit-0.1.1.ebuild b/media-sound/gigedit/gigedit-0.1.1.ebuild
index 2bf74bb8f87b..b3cb93a8ea70 100644
--- a/media-sound/gigedit/gigedit-0.1.1.ebuild
+++ b/media-sound/gigedit/gigedit-0.1.1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/gigedit/gigedit-0.1.1.ebuild,v 1.1 2008/01/27 10:15:26 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gigedit/gigedit-0.1.1.ebuild,v 1.2 2009/02/08 10:04:55 aballier Exp $
+
+inherit eutils
DESCRIPTION="An instrument editor for gig files"
HOMEPAGE="http://www.linuxsampler.org/"
@@ -18,6 +20,12 @@ DEPEND=">=media-sound/linuxsampler-0.5
RDEPEND="${DEPEND}"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+}
+
src_compile() {
econf
emake -j1 || die "make failed"