summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-02-12 18:55:38 +0000
committerDan Armak <danarmak@gentoo.org>2002-02-12 18:55:38 +0000
commit27ada4b91c0e6c44cdbc5be6d00f91f309e7c535 (patch)
tree8be6859a351c9c39d088c5cca94145b66dcb8dd2 /media-sound/freeamp
parentNew upstream version, old one disappeared (diff)
downloadgentoo-2-27ada4b91c0e6c44cdbc5be6d00f91f309e7c535.tar.gz
gentoo-2-27ada4b91c0e6c44cdbc5be6d00f91f309e7c535.tar.bz2
gentoo-2-27ada4b91c0e6c44cdbc5be6d00f91f309e7c535.zip
fix to make it compile with use arts on - it didn't fid artsc.h
Diffstat (limited to 'media-sound/freeamp')
-rw-r--r--media-sound/freeamp/freeamp-2.1.1.ebuild19
1 files changed, 17 insertions, 2 deletions
diff --git a/media-sound/freeamp/freeamp-2.1.1.ebuild b/media-sound/freeamp/freeamp-2.1.1.ebuild
index 34ac53e78baf..1bf10001c006 100644
--- a/media-sound/freeamp/freeamp-2.1.1.ebuild
+++ b/media-sound/freeamp/freeamp-2.1.1.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Donny Davies <woodchip@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-sound/freeamp/freeamp-2.1.1.ebuild,v 1.1 2001/12/29 21:45:08 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/freeamp/freeamp-2.1.1.ebuild,v 1.2 2002/02/12 18:55:38 danarmak Exp $
+use arts && . /usr/portage/eclass/inherit.eclass || die
# I highly suggest you read the features section of the freeamp website to
# see all the neat stuff this program can do. Pretty spiffy :)
@@ -21,17 +22,31 @@ RDEPEND="virtual/glibc
vorbis? ( media-libs/libvorbis )"
DEPEND="${RDEPEND} dev-lang/nasm sys-devel/perl"
+use arts && inherit functions && set-kdedir
+
# Unfortunately you can't selectively build a lot of the features. Therefore
# this whole package is essentially a judgement call. However, I've made the
# DEPEND in a strategic manner to ensure that your USE variable is respected
# when the knobs are *set*.
+src_unpack() {
+
+ unpack ${A}
+
+ if [ "`use arts`" ]; then
+ cd ${S}/io/arts/src
+ cp artspmo.cpp 1
+ sed -e 's:artsc/artsc.h:artsc.h:g' 1 > artspmo.cpp
+ fi
+
+}
+
src_compile() {
local myconf
use alsa || myconf="${myconf} --disable-alsa"
use esd || myconf="${myconf} --disable-esd"
- use arts && export KDEDIR=/usr/kde/2
+ use arts && myconf="${myconf} --with-extra-includes=${KDEDIR}/include"
./configure --prefix=/usr --host=${CHOST} ${myconf} || die
make ; assert "compile problem :("