summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-11-14 10:46:34 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-11-14 10:46:34 +0000
commit8387da56d3ef91f046b5ec303b8b74d8bb768506 (patch)
treedfdbc814e645dbcf826fdf00193c3c11878dd2bf /media-sound/fluidsynth
parentCleanup. (diff)
downloadgentoo-2-8387da56d3ef91f046b5ec303b8b74d8bb768506.tar.gz
gentoo-2-8387da56d3ef91f046b5ec303b8b74d8bb768506.tar.bz2
gentoo-2-8387da56d3ef91f046b5ec303b8b74d8bb768506.zip
version bump
(Portage version: 2.2_rc49/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/fluidsynth')
-rw-r--r--media-sound/fluidsynth/ChangeLog8
-rw-r--r--media-sound/fluidsynth/fluidsynth-1.1.0.ebuild75
2 files changed, 82 insertions, 1 deletions
diff --git a/media-sound/fluidsynth/ChangeLog b/media-sound/fluidsynth/ChangeLog
index 4b77d8991134..bffb31c83190 100644
--- a/media-sound/fluidsynth/ChangeLog
+++ b/media-sound/fluidsynth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/fluidsynth
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/ChangeLog,v 1.54 2009/09/02 07:19:04 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/ChangeLog,v 1.55 2009/11/14 10:46:34 aballier Exp $
+
+*fluidsynth-1.1.0 (14 Nov 2009)
+
+ 14 Nov 2009; Alexis Ballier <aballier@gentoo.org>
+ +fluidsynth-1.1.0.ebuild:
+ version bump
02 Sep 2009; Alexis Ballier <aballier@gentoo.org>
-fluidsynth-1.0.8.ebuild:
diff --git a/media-sound/fluidsynth/fluidsynth-1.1.0.ebuild b/media-sound/fluidsynth/fluidsynth-1.1.0.ebuild
new file mode 100644
index 000000000000..eb8bb212609a
--- /dev/null
+++ b/media-sound/fluidsynth/fluidsynth-1.1.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/fluidsynth-1.1.0.ebuild,v 1.1 2009/11/14 10:46:34 aballier Exp $
+
+EAPI=2
+inherit libtool
+
+IUSE="alsa debug jack ladspa lash oss portaudio pulseaudio readline sndfile"
+
+DESCRIPTION="Fluidsynth is a software real-time synthesizer based on the Soundfont 2 specifications."
+HOMEPAGE="http://www.fluidsynth.org/"
+SRC_URI="http://savannah.nongnu.org/download/fluid/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+RDEPEND="
+ >=dev-libs/glib-2.6.5
+ jack? ( media-sound/jack-audio-connection-kit )
+ ladspa? ( >=media-libs/ladspa-sdk-1.12
+ >=media-libs/ladspa-cmt-1.15 )
+ alsa? ( media-libs/alsa-lib
+ lash? ( >=media-sound/lash-0.5 ) )
+ pulseaudio? ( >=media-sound/pulseaudio-0.9.8 )
+ portaudio? ( >=media-libs/portaudio-19_pre )
+ readline? ( sys-libs/readline )
+ sndfile? ( media-libs/libsndfile )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${P/7a/7}
+
+# Alsa is required for lash support in this package.
+pkg_setup() {
+ if use lash && ! use alsa; then
+ ewarn "ALSA support is required for lash support to be enabled."
+ ewarn "Continuing with lash support disabled."
+ fi
+}
+
+src_prepare() {
+ elibtoolize
+}
+
+src_configure() {
+ local myconf
+
+ if use alsa; then
+ myconf="${myconf} $(use_enable lash)"
+ else
+ myconf="--disable-lash"
+ fi
+
+ # ladcca support is deprecated in place of lash
+ econf \
+ --disable-ladcca \
+ --disable-dependency-tracking \
+ $(use_enable ladspa) \
+ $(use_enable jack jack-support) \
+ $(use_enable oss oss-support) \
+ $(use_enable alsa alsa-support) \
+ $(use_enable pulseaudio pulse-support) \
+ $(use_enable portaudio portaudio-support) \
+ $(use_enable sndfile libsndfile-support) \
+ $(use_enable lash) \
+ $(use_enable debug) \
+ $(use_with readline) \
+ ${myconf} || die "./configure failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS NEWS README THANKS TODO
+}