summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-09-04 20:56:52 +0000
committerTim Harder <radhermit@gentoo.org>2011-09-04 20:56:52 +0000
commit758df864489e9f44dbf32299eef3efd994df1dce (patch)
treeddab58f1e962a0134418ebde103bbce37d063b97 /media-sound/fluidsynth
parentBased on 3.0.4 + genpatches-3.0-5 + grsecurity-2.2.2-3.0.4-201109011725 (diff)
downloadgentoo-2-758df864489e9f44dbf32299eef3efd994df1dce.tar.gz
gentoo-2-758df864489e9f44dbf32299eef3efd994df1dce.tar.bz2
gentoo-2-758df864489e9f44dbf32299eef3efd994df1dce.zip
Version bump.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/fluidsynth')
-rw-r--r--media-sound/fluidsynth/ChangeLog7
-rw-r--r--media-sound/fluidsynth/fluidsynth-1.1.5.ebuild66
2 files changed, 72 insertions, 1 deletions
diff --git a/media-sound/fluidsynth/ChangeLog b/media-sound/fluidsynth/ChangeLog
index 9f4310d89991..88e00b24ba5d 100644
--- a/media-sound/fluidsynth/ChangeLog
+++ b/media-sound/fluidsynth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/fluidsynth
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/ChangeLog,v 1.67 2011/08/07 11:48:30 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/ChangeLog,v 1.68 2011/09/04 20:56:52 radhermit Exp $
+
+*fluidsynth-1.1.5 (04 Sep 2011)
+
+ 04 Sep 2011; Tim Harder <radhermit@gentoo.org> +fluidsynth-1.1.5.ebuild:
+ Version bump.
*fluidsynth-1.1.4 (07 Aug 2011)
diff --git a/media-sound/fluidsynth/fluidsynth-1.1.5.ebuild b/media-sound/fluidsynth/fluidsynth-1.1.5.ebuild
new file mode 100644
index 000000000000..cfab2519fcec
--- /dev/null
+++ b/media-sound/fluidsynth/fluidsynth-1.1.5.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/fluidsynth-1.1.5.ebuild,v 1.1 2011/09/04 20:56:52 radhermit Exp $
+
+EAPI=4
+inherit cmake-utils
+
+DESCRIPTION="Fluidsynth is a software real-time synthesizer based on the Soundfont 2 specifications."
+HOMEPAGE="http://www.fluidsynth.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="alsa dbus debug examples jack ladspa lash portaudio pulseaudio readline sndfile"
+
+RDEPEND=">=dev-libs/glib-2.6.5:2
+ alsa? ( media-libs/alsa-lib
+ lash? ( >=media-sound/lash-0.5 ) )
+ dbus? ( >=sys-apps/dbus-1.0.0 )
+ jack? ( media-sound/jack-audio-connection-kit )
+ ladspa? ( >=media-libs/ladspa-sdk-1.12
+ >=media-libs/ladspa-cmt-1.15 )
+ pulseaudio? ( >=media-sound/pulseaudio-0.9.8 )
+ portaudio? ( >=media-libs/portaudio-19_pre )
+ readline? ( sys-libs/readline )
+ sndfile? ( >=media-libs/libsndfile-1.0.18 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use alsa enable-alsa)
+ $(cmake-utils_use dbus enable-dbus)
+ $(cmake-utils_use debug enable-debug)
+ $(cmake-utils_use jack enable-jack)
+ -Denable-ladcca=OFF
+ $(cmake-utils_use ladspa enable-ladspa)
+ $(cmake-utils_use sndfile enable-libsndfile)
+ $(cmake-utils_use portaudio enable-portaudio)
+ $(cmake-utils_use pulseaudio enable-pulseaudio)
+ $(cmake-utils_use readline enable-readline)
+ )
+
+ if use alsa; then
+ mycmakeargs+=( $(cmake-utils_use lash enable-lash) )
+ else
+ mycmakeargs+=( -Denable-lash=OFF )
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ dodoc AUTHORS NEWS README THANKS TODO doc/*.txt
+
+ insinto /usr/share/doc/${PF}/pdf
+ doins doc/*.pdf
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins doc/*.c
+ fi
+}