summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-09-29 05:58:47 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-09-29 05:58:47 +0000
commit220c5028b7f1f2ff680157f417733d6d0e8237e3 (patch)
tree065c05accb6daac8be41ccdb4bc659d1e0ead37f /media-sound/fluidsynth
parentAdd a new revision using EAPI=2 and USE dependencies. (diff)
downloadgentoo-2-220c5028b7f1f2ff680157f417733d6d0e8237e3.tar.gz
gentoo-2-220c5028b7f1f2ff680157f417733d6d0e8237e3.tar.bz2
gentoo-2-220c5028b7f1f2ff680157f417733d6d0e8237e3.zip
Add a new revision using EAPI=2 and USE dependencies.
(Portage version: 2.2_rc11/cvs/Linux 2.6.26-gentoo-r1 x86_64)
Diffstat (limited to 'media-sound/fluidsynth')
-rw-r--r--media-sound/fluidsynth/ChangeLog8
-rw-r--r--media-sound/fluidsynth/fluidsynth-1.0.8-r1.ebuild65
2 files changed, 72 insertions, 1 deletions
diff --git a/media-sound/fluidsynth/ChangeLog b/media-sound/fluidsynth/ChangeLog
index a210f2334dbe..0a49c5a89650 100644
--- a/media-sound/fluidsynth/ChangeLog
+++ b/media-sound/fluidsynth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/fluidsynth
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/ChangeLog,v 1.42 2008/08/17 08:06:22 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/ChangeLog,v 1.43 2008/09/29 05:58:47 flameeyes Exp $
+
+*fluidsynth-1.0.8-r1 (29 Sep 2008)
+
+ 29 Sep 2008; Diego Pettenò <flameeyes@gentoo.org>
+ +fluidsynth-1.0.8-r1.ebuild:
+ Add a new revision using EAPI=2 and USE dependencies.
17 Aug 2008; Alexis Ballier <aballier@gentoo.org>
-fluidsynth-1.0.7a.ebuild:
diff --git a/media-sound/fluidsynth/fluidsynth-1.0.8-r1.ebuild b/media-sound/fluidsynth/fluidsynth-1.0.8-r1.ebuild
new file mode 100644
index 000000000000..5546ae435fac
--- /dev/null
+++ b/media-sound/fluidsynth/fluidsynth-1.0.8-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/fluidsynth-1.0.8-r1.ebuild,v 1.1 2008/09/29 05:58:47 flameeyes Exp $
+
+EAPI=2
+
+inherit flag-o-matic eutils libtool
+
+IUSE="alsa debug jack ladspa lash oss readline"
+
+DESCRIPTION="Fluidsynth is a software real-time synthesizer based on the Soundfont 2 specifications."
+HOMEPAGE="http://www.fluidsynth.org/"
+SRC_URI="http://savannah.nongnu.org/download/fluid/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+DEPEND="jack? ( media-sound/jack-audio-connection-kit )
+ ladspa? ( >=media-libs/ladspa-sdk-1.12
+ >=media-libs/ladspa-cmt-1.15 )
+ alsa? ( media-libs/alsa-lib[midi]
+ lash? ( >=media-sound/lash-0.5 ) )
+ readline? ( sys-libs/readline )"
+
+S="${WORKDIR}/${P/7a/7}"
+
+# Alsa is required for lash support in this package.
+pkg_setup() {
+ if use lash && ! use alsa; then
+ ewarn "ALSA support is required for lash support to be enabled."
+ ewarn "Continuing with lash support disabled."
+ fi
+}
+
+src_compile() {
+ local myconf
+
+ if use alsa; then
+ myconf="${myconf} $(use_enable lash)"
+ else
+ myconf="--disable-lash"
+ fi
+
+ elibtoolize
+ # ladcca support is deprecated in place of lash
+ econf \
+ --disable-ladcca \
+ --disable-dependency-tracking \
+ $(use_enable ladspa) \
+ $(use_enable jack jack-support) \
+ $(use_enable oss oss-support) \
+ $(use_enable alsa alsa-support) \
+ $(use_enable lash) \
+ $(use_enable debug) \
+ $(use_with readline) \
+ ${myconf} || die "./configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS NEWS README THANKS TODO
+}