summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-05-16 23:35:37 +0000
committerSamuli Suominen <drac@gentoo.org>2007-05-16 23:35:37 +0000
commite18ff47a488d5bdd18d2dc7ad2b7e2be5bd0cc1a (patch)
tree5ed2080c3cd9b41720310850ed7381b0d68c3faf /media-sound/exaile
parentRevbump to add hyphenation support via use flag, using hyphenation files from... (diff)
downloadgentoo-2-e18ff47a488d5bdd18d2dc7ad2b7e2be5bd0cc1a.tar.gz
gentoo-2-e18ff47a488d5bdd18d2dc7ad2b7e2be5bd0cc1a.tar.bz2
gentoo-2-e18ff47a488d5bdd18d2dc7ad2b7e2be5bd0cc1a.zip
Apply patch from upstream to fix album cover fetching since Amazon upgraded from ECS 3.0 to 4.0.
(Portage version: 2.1.2.7)
Diffstat (limited to 'media-sound/exaile')
-rw-r--r--media-sound/exaile/ChangeLog10
-rw-r--r--media-sound/exaile/exaile-0.2.9-r2.ebuild (renamed from media-sound/exaile/exaile-0.2.9-r1.ebuild)3
-rw-r--r--media-sound/exaile/files/digest-exaile-0.2.9-r2 (renamed from media-sound/exaile/files/digest-exaile-0.2.9-r1)0
-rw-r--r--media-sound/exaile/files/exaile-0.2.9-amazon.patch14
4 files changed, 25 insertions, 2 deletions
diff --git a/media-sound/exaile/ChangeLog b/media-sound/exaile/ChangeLog
index cd9ef2a39952..7560a55c4530 100644
--- a/media-sound/exaile/ChangeLog
+++ b/media-sound/exaile/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-sound/exaile
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/ChangeLog,v 1.14 2007/04/08 19:03:24 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/ChangeLog,v 1.15 2007/05/16 23:35:37 drac Exp $
+
+*exaile-0.2.9-r2 (16 May 2007)
+
+ 16 May 2007; Samuli Suominen <drac@gentoo.org>
+ +files/exaile-0.2.9-amazon.patch, -exaile-0.2.9-r1.ebuild,
+ +exaile-0.2.9-r2.ebuild:
+ Apply patch from upstream to fix album cover fetching since Amazon upgraded
+ from ECS 3.0 to 4.0.
08 Apr 2007; Bryan Østergaard <kloeri@gentoo.org> exaile-0.2.9-r1.ebuild:
Fix missing dbus-python dependency, thanks to Thomas A. and Oliver Rolland
diff --git a/media-sound/exaile/exaile-0.2.9-r1.ebuild b/media-sound/exaile/exaile-0.2.9-r2.ebuild
index c71cf8b6454e..ab3c73039727 100644
--- a/media-sound/exaile/exaile-0.2.9-r1.ebuild
+++ b/media-sound/exaile/exaile-0.2.9-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/exaile-0.2.9-r1.ebuild,v 1.2 2007/04/08 19:03:24 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/exaile-0.2.9-r2.ebuild,v 1.1 2007/05/16 23:35:37 drac Exp $
inherit eutils python toolchain-funcs
@@ -61,6 +61,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${PN}-0.2.x-strip.patch
+ epatch "${FILESDIR}"/${P}-amazon.patch
python_version
sed -i -e "s:hon2.4:hon${PYVER}:" mmkeys/Makefile
}
diff --git a/media-sound/exaile/files/digest-exaile-0.2.9-r1 b/media-sound/exaile/files/digest-exaile-0.2.9-r2
index 7fa98eb6bbe1..7fa98eb6bbe1 100644
--- a/media-sound/exaile/files/digest-exaile-0.2.9-r1
+++ b/media-sound/exaile/files/digest-exaile-0.2.9-r2
diff --git a/media-sound/exaile/files/exaile-0.2.9-amazon.patch b/media-sound/exaile/files/exaile-0.2.9-amazon.patch
new file mode 100644
index 000000000000..1d6e13eb028f
--- /dev/null
+++ b/media-sound/exaile/files/exaile-0.2.9-amazon.patch
@@ -0,0 +1,14 @@
+Index: xl/covers.py
+===================================================================
+--- xl/covers.py (revision 2372)
++++ xl/covers.py (working copy)
+@@ -42,7 +42,8 @@
+ QUERY = "/onca/xml3?t=webservices-20&dev-t=%s&mode=music&type=lite&" % (KEY) + \
+ "locale={locale}&page=1&f=xml&KeywordSearch="
+ IMAGE_PATTERN = re.compile(
+- r"http://(images(?:-\w\w)?\.amazon\.com)(/images/.*?LZ+\.jpg)")
++ r"<ImageUrlMedium>http://(\w+\.images-amazon\.com)"
++ "(/images/.*?\.jpg)</ImageUrlMedium>", re.DOTALL)
+
+ """
+ Fetches album covers from Amazon.com