summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2007-03-14 17:22:43 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2007-03-14 17:22:43 +0000
commitcb38608d825d375eebb5ae89374939d93bf46201 (patch)
tree975cfac630dd5d9fc393bb5f88f8146661c8f86a /media-sound/esound
parentAdd RDEPEND=>=net-misc/rsync-2.6.4 for the --filter option (#167668). (diff)
downloadgentoo-2-cb38608d825d375eebb5ae89374939d93bf46201.tar.gz
gentoo-2-cb38608d825d375eebb5ae89374939d93bf46201.tar.bz2
gentoo-2-cb38608d825d375eebb5ae89374939d93bf46201.zip
Bump to 0.2.37
* Fix null derefs and leaks reported by Covertiy (kjartan) * Build fixes (David Schleef, Thomas Zajic, Behdad Esfahbod) * Disable autospawning (David Schleef) * Close filedescriptors and sockets (David Schleef) * Don't terminate until the last sample is done (David Schleef) * Add checks for clients disconnecting (Peter Åstrand) * Updated man pages (Christopher Hanna) * Use pkg-config to check for audiofile (Frederic Peters) (Portage version: 2.1.2.2)
Diffstat (limited to 'media-sound/esound')
-rw-r--r--media-sound/esound/ChangeLog15
-rw-r--r--media-sound/esound/esound-0.2.37.ebuild80
-rw-r--r--media-sound/esound/files/digest-esound-0.2.373
3 files changed, 97 insertions, 1 deletions
diff --git a/media-sound/esound/ChangeLog b/media-sound/esound/ChangeLog
index 2f70355ea24b..2d3cddde78cb 100644
--- a/media-sound/esound/ChangeLog
+++ b/media-sound/esound/ChangeLog
@@ -1,6 +1,19 @@
# ChangeLog for media-sound/esound
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/esound/ChangeLog,v 1.91 2007/01/22 09:18:38 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/esound/ChangeLog,v 1.92 2007/03/14 17:22:43 dang Exp $
+
+*esound-0.2.37 (14 Mar 2007)
+
+ 14 Mar 2007; Daniel Gryniewicz <dang@gentoo.org> +esound-0.2.37.ebuild:
+ Bump to 0.2.37
+ * Fix null derefs and leaks reported by Covertiy (kjartan)
+ * Build fixes (David Schleef, Thomas Zajic, Behdad Esfahbod)
+ * Disable autospawning (David Schleef)
+ * Close filedescriptors and sockets (David Schleef)
+ * Don't terminate until the last sample is done (David Schleef)
+ * Add checks for clients disconnecting (Peter Åstrand)
+ * Updated man pages (Christopher Hanna)
+ * Use pkg-config to check for audiofile (Frederic Peters)
22 Jan 2007; Diego Pettenò <flameeyes@gentoo.org> -esound-0.2.34.ebuild:
Remove old version.
diff --git a/media-sound/esound/esound-0.2.37.ebuild b/media-sound/esound/esound-0.2.37.ebuild
new file mode 100644
index 000000000000..1f13d77e1dc8
--- /dev/null
+++ b/media-sound/esound/esound-0.2.37.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/esound/esound-0.2.37.ebuild,v 1.1 2007/03/14 17:22:43 dang Exp $
+
+WANT_AUTOMAKE=1.10
+inherit libtool gnome.org eutils autotools flag-o-matic
+
+DESCRIPTION="The Enlightened Sound Daemon"
+HOMEPAGE="http://www.tux.org/~ricdude/EsounD.html"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc-macos ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="alsa debug ipv6 tcpd"
+
+# esound comes with arts support, but it hasn't been tested yet, feel free to
+# submit patches/improvements
+DEPEND=">=media-libs/audiofile-0.1.5
+ alsa? ( >=media-libs/alsa-lib-0.5.10b )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6-r2 )"
+# arts? ( kde-base/arts )
+
+RDEPEND="${DEPEND}
+ app-admin/eselect-esd"
+
+src_unpack() {
+
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-0.2.32-amd64.patch"
+ # please note, this is a conditional, version specific patch!!!
+ # when bumping avoid bugs like #103969
+ use ppc-macos && epatch "${FILESDIR}/${PN}-0.2.36-ppc-macos.patch"
+
+ epatch "${FILESDIR}/${PN}-0.2.36-mode_t.patch"
+ epatch "${FILESDIR}/${PN}-0.2.36-asneeded.patch"
+
+
+ AT_M4DIR="m4" eautomake
+
+ elibtoolize
+}
+
+src_compile() {
+ # Strict aliasing problem
+ append-flags -fno-strict-aliasing
+
+ econf \
+ --sysconfdir=/etc/esd \
+ $(use_enable ipv6) \
+ $(use_enable debug debugging) \
+ $(use_enable alsa) \
+ $(use_with tcpd libwrap) \
+ --disable-dependency-tracking \
+ || die "Configure failed"
+
+ emake || die "Make failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "Installation failed"
+ mv "${D}/usr/bin/"{esd,esound-esd}
+
+ dodoc AUTHORS ChangeLog MAINTAINERS NEWS README TIPS TODO
+
+ [[ -d "docs/html" ]] && dohtml -r docs/html/*
+
+ newconfd "${FILESDIR}/esound.conf.d" esound
+
+ extradepend=""
+ use tcpd && extradepend=" portmap"
+ use alsa && extradepend="$extradepend alsasound"
+ sed -e "s/@extradepend@/$extradepend/" "${FILESDIR}/esound.init.d.2" >"${T}/esound"
+ doinitd "${T}/esound"
+}
+
+pkg_postinst() {
+ eselect esd update --if-unset
+}
diff --git a/media-sound/esound/files/digest-esound-0.2.37 b/media-sound/esound/files/digest-esound-0.2.37
new file mode 100644
index 000000000000..d3bcabe648f0
--- /dev/null
+++ b/media-sound/esound/files/digest-esound-0.2.37
@@ -0,0 +1,3 @@
+MD5 99cc68770176c8940cf346f60208420e esound-0.2.37.tar.bz2 383831
+RMD160 36f6630df4fa3c611d9b7ff40157504334535abe esound-0.2.37.tar.bz2 383831
+SHA256 3c8525c08cce45557832cb20cc74e7b3d6c9664410f117372391b59fda2d4147 esound-0.2.37.tar.bz2 383831