summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2008-07-16 10:33:51 +0000
committerRémi Cardona <remi@gentoo.org>2008-07-16 10:33:51 +0000
commitab0155013089593417f0acb5e5df719f08518633 (patch)
tree790466a87a27e83fe9e2be6b352cde741c2eee53 /media-sound/esound
parentFixed build problems: 1. when gtk+-1 is not installed AM_PATH_GTK could not b... (diff)
downloadgentoo-2-ab0155013089593417f0acb5e5df719f08518633.tar.gz
gentoo-2-ab0155013089593417f0acb5e5df719f08518633.tar.bz2
gentoo-2-ab0155013089593417f0acb5e5df719f08518633.zip
media-sound/esound: bump to 0.2.39, no more patches needed!
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-gentoo-r6 x86_64)
Diffstat (limited to 'media-sound/esound')
-rw-r--r--media-sound/esound/ChangeLog7
-rw-r--r--media-sound/esound/esound-0.2.39.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/media-sound/esound/ChangeLog b/media-sound/esound/ChangeLog
index 79874fcf869b..263bcca59087 100644
--- a/media-sound/esound/ChangeLog
+++ b/media-sound/esound/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/esound
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/esound/ChangeLog,v 1.115 2008/06/17 13:09:45 remi Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/esound/ChangeLog,v 1.116 2008/07/16 10:33:51 remi Exp $
+
+*esound-0.2.39 (16 Jul 2008)
+
+ 16 Jul 2008; Rémi Cardona <remi@gentoo.org> +esound-0.2.39.ebuild:
+ bump to 0.2.39, no more patches needed!
17 Jun 2008; Rémi Cardona <remi@gentoo.org> esound-0.2.38-r1.ebuild:
add missing pkg-config dep (fixes bug #227589)
diff --git a/media-sound/esound/esound-0.2.39.ebuild b/media-sound/esound/esound-0.2.39.ebuild
new file mode 100644
index 000000000000..b6b4d8e631a6
--- /dev/null
+++ b/media-sound/esound/esound-0.2.39.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/esound/esound-0.2.39.ebuild,v 1.1 2008/07/16 10:33:51 remi Exp $
+
+inherit libtool gnome.org eutils flag-o-matic
+
+DESCRIPTION="The Enlightened Sound Daemon"
+HOMEPAGE="http://www.tux.org/~ricdude/EsounD.html"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="alsa debug doc ipv6 tcpd"
+
+# esound comes with arts support, but it hasn't been tested yet, feel free to
+# submit patches/improvements
+COMMON_DEPEND=">=media-libs/audiofile-0.1.5
+ alsa? ( >=media-libs/alsa-lib-0.5.10b )
+ doc? ( app-text/docbook-sgml-utils )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6-r2 )"
+# arts? ( kde-base/arts )
+
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig"
+
+RDEPEND="${COMMON_DEPEND}
+ app-admin/eselect-esd"
+
+src_compile() {
+ # Strict aliasing problem
+ append-flags -fno-strict-aliasing
+
+ econf \
+ --sysconfdir=/etc/esd \
+ --htmldir=/usr/share/doc/${PF}/html \
+ $(use_enable ipv6) \
+ $(use_enable debug debugging) \
+ $(use_enable alsa) \
+ $(use_with tcpd libwrap) \
+ --disable-dependency-tracking \
+ || die "Configure failed"
+
+ emake || die "Make failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "Installation failed"
+ mv "${D}/usr/bin/"{esd,esound-esd}
+
+ dodoc AUTHORS ChangeLog MAINTAINERS NEWS README TIPS TODO
+
+ newconfd "${FILESDIR}/esound.conf.d" esound
+
+ extradepend=""
+ use tcpd && extradepend=" portmap"
+ use alsa && extradepend="$extradepend alsasound"
+ sed -e "s/@extradepend@/$extradepend/" "${FILESDIR}/esound.init.d.2" >"${T}/esound"
+ doinitd "${T}/esound"
+}
+
+pkg_postinst() {
+ eselect esd update --if-unset \
+ || die "eselect failed, try removing /usr/bin/esd and re-emerging."
+}