summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKito Danya Dietrich <kito@gentoo.org>2004-10-03 05:37:14 +0000
committerKito Danya Dietrich <kito@gentoo.org>2004-10-03 05:37:14 +0000
commit00f5e8b0aa818b64b933613f321b7a3cb1f4f1b9 (patch)
tree80060e10b36be66c58d3fa24aaf893b7f11c044b /media-sound/esound/files
parentmask out mzscheme #65216 (diff)
downloadgentoo-2-00f5e8b0aa818b64b933613f321b7a3cb1f4f1b9.tar.gz
gentoo-2-00f5e8b0aa818b64b933613f321b7a3cb1f4f1b9.tar.bz2
gentoo-2-00f5e8b0aa818b64b933613f321b7a3cb1f4f1b9.zip
~ppc-macos keyword and patch
Diffstat (limited to 'media-sound/esound/files')
-rw-r--r--media-sound/esound/files/esound-0.2.35-ppc-macos.patch129
1 files changed, 129 insertions, 0 deletions
diff --git a/media-sound/esound/files/esound-0.2.35-ppc-macos.patch b/media-sound/esound/files/esound-0.2.35-ppc-macos.patch
new file mode 100644
index 000000000000..249aa78fee72
--- /dev/null
+++ b/media-sound/esound/files/esound-0.2.35-ppc-macos.patch
@@ -0,0 +1,129 @@
+diff -uNr esound-0.2.35/Makefile.in esound-0.2.35-new/Makefile.in
+--- esound-0.2.35/Makefile.in Thu Aug 12 09:23:07 2004
++++ esound-0.2.35-new/Makefile.in Sat Oct 2 16:14:52 2004
+@@ -281,7 +281,7 @@
+
+ LDADD = libesd.la $(AUDIOFILE_LIBS)
+
+-esd_LDADD = $(WRAP_LIB) $(LDADD)
++esd_LDADD = $(WRAP_LIB) $(LDADD) $(SOUND_LIBS)
+
+ m4datadir = $(datadir)/aclocal
+ m4data_DATA = esd.m4
+@@ -347,44 +347,44 @@
+ esd_LDFLAGS =
+ am_esdcat_OBJECTS = esdcat.$(OBJEXT)
+ esdcat_OBJECTS = $(am_esdcat_OBJECTS)
+-esdcat_LDADD = $(LDADD)
++esdcat_LDADD = $(LDADD) $(SOUND_LIBS)
+ esdcat_DEPENDENCIES = libesd.la
+ esdcat_LDFLAGS =
+ am__esdctl_SOURCES_DIST = getopt.c getopt1.c esdctl.c
+ am_esdctl_OBJECTS = $(am__objects_2) esdctl.$(OBJEXT)
+ esdctl_OBJECTS = $(am_esdctl_OBJECTS)
+-esdctl_LDADD = $(LDADD)
++esdctl_LDADD = $(LDADD) $(SOUND_LIBS)
+ esdctl_DEPENDENCIES = libesd.la
+ esdctl_LDFLAGS =
+ am_esdfilt_OBJECTS = esdfilt.$(OBJEXT)
+ esdfilt_OBJECTS = $(am_esdfilt_OBJECTS)
+-esdfilt_LDADD = $(LDADD)
++esdfilt_LDADD = $(LDADD) $(SOUND_LIBS)
+ esdfilt_DEPENDENCIES = libesd.la
+ esdfilt_LDFLAGS =
+ am_esdloop_OBJECTS = esdloop.$(OBJEXT)
+ esdloop_OBJECTS = $(am_esdloop_OBJECTS)
+-esdloop_LDADD = $(LDADD)
++esdloop_LDADD = $(LDADD) $(SOUND_LIBS)
+ esdloop_DEPENDENCIES = libesd.la
+ esdloop_LDFLAGS =
+ am_esdmon_OBJECTS = esdmon.$(OBJEXT)
+ esdmon_OBJECTS = $(am_esdmon_OBJECTS)
+-esdmon_LDADD = $(LDADD)
++esdmon_LDADD = $(LDADD) $(SOUND_LIBS)
+ esdmon_DEPENDENCIES = libesd.la
+ esdmon_LDFLAGS =
+ am__esdplay_SOURCES_DIST = getopt.c getopt1.c esdplay.c
+ am_esdplay_OBJECTS = $(am__objects_2) esdplay.$(OBJEXT)
+ esdplay_OBJECTS = $(am_esdplay_OBJECTS)
+-esdplay_LDADD = $(LDADD)
++esdplay_LDADD = $(LDADD) $(SOUND_LIBS)
+ esdplay_DEPENDENCIES = libesd.la
+ esdplay_LDFLAGS =
+ am_esdrec_OBJECTS = esdrec.$(OBJEXT)
+ esdrec_OBJECTS = $(am_esdrec_OBJECTS)
+-esdrec_LDADD = $(LDADD)
++esdrec_LDADD = $(LDADD) $(SOUND_LIBS)
+ esdrec_DEPENDENCIES = libesd.la
+ esdrec_LDFLAGS =
+ am_esdsample_OBJECTS = esdsample.$(OBJEXT)
+ esdsample_OBJECTS = $(am_esdsample_OBJECTS)
+-esdsample_LDADD = $(LDADD)
++esdsample_LDADD = $(LDADD) $(SOUND_LIBS)
+ esdsample_DEPENDENCIES = libesd.la
+ esdsample_LDFLAGS =
+ SCRIPTS = $(bin_SCRIPTS)
+diff -uNr esound-0.2.35/configure esound-0.2.35-new/configure
+--- esound-0.2.35/configure Thu Aug 12 09:23:05 2004
++++ esound-0.2.35-new/configure Sat Oct 2 16:14:52 2004
+@@ -5916,7 +5916,7 @@
+ allow_undefined_flag='-undefined suppress'
+ ;;
+ *) # Darwin 1.3 on
+- allow_undefined_flag='-flat_namespace -undefined suppress'
++ test -z "$LD_TWOLEVEL_NAMESPACE" && allow_undefined_flag='-flat_namespace -undefined suppress'
+ ;;
+ esac
+ # FIXME: Relying on posixy $() will cause problems for
+diff -uNr esound-0.2.35/esd.c esound-0.2.35-new/esd.c
+--- esound-0.2.35/esd.c Thu Aug 12 08:09:34 2004
++++ esound-0.2.35-new/esd.c Sat Oct 2 16:14:52 2004
+@@ -8,6 +8,10 @@
+ #include <errno.h>
+ #include <signal.h>
+ #include <time.h>
++#include <mach/mach.h>
++#include <mach/thread_policy.h>
++#include <sys/param.h>
++#include <sys/sysctl.h>
+
+ #ifndef HAVE_NANOSLEEP
+ #include <sys/time.h>
+@@ -607,6 +611,25 @@
+
+ int default_format = ESD_BITS16 | ESD_STEREO;
+ /* end test scaffolding parameters */
++
++ {
++ struct thread_time_constraint_policy ttcpolicy;
++ int bus_speed, mib [2] = { CTL_HW, HW_BUS_FREQ };
++ size_t len;
++
++ len = sizeof (bus_speed);
++ sysctl (mib, 2, &bus_speed, &len, NULL, 0);
++
++ ttcpolicy.period = bus_speed / 120;
++ ttcpolicy.computation = bus_speed / 2400;
++ ttcpolicy.constraint = bus_speed /1200;
++ ttcpolicy.preemptible = 1;
++
++ thread_policy_set (mach_thread_self (),
++ THREAD_TIME_CONSTRAINT_POLICY,
++ (int*)&ttcpolicy,
++ THREAD_TIME_CONSTRAINT_POLICY_COUNT);
++ }
+
+ programname = *argv;
+
+diff -uNr esound-0.2.35/esd_config.c esound-0.2.35-new/esd_config.c
+--- esound-0.2.35/esd_config.c Thu Aug 12 04:14:54 2004
++++ esound-0.2.35-new/esd_config.c Sat Oct 2 16:14:52 2004
+@@ -9,7 +9,7 @@
+ int esd_no_spawn=1; /* If we can't even find the system config file,
+ things are screwed up - don't try to make things
+ worse. */
+-int esd_spawn_wait_ms=100; /* Time to wait trying to connect to an
++int esd_spawn_wait_ms=999; /* Time to wait trying to connect to an
+ autospawned ESD, in milliseconds. */
+ char esd_spawn_options[LINEBUF_SIZE] = "-terminate -nobeeps -as 2";
+