summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2010-11-21 13:40:34 +0000
committerTony Vroon <chainsaw@gentoo.org>2010-11-21 13:40:34 +0000
commit3ef6b4cd5cc0d96b4ee3e1d5a11b64deb66a2b02 (patch)
tree5630ef18a0cb6543b618d0baeff1d87aa639249d /media-sound/codecgraph
parentStable on amd64 wrt bug #346097 (diff)
downloadgentoo-2-3ef6b4cd5cc0d96b4ee3e1d5a11b64deb66a2b02.tar.gz
gentoo-2-3ef6b4cd5cc0d96b4ee3e1d5a11b64deb66a2b02.tar.bz2
gentoo-2-3ef6b4cd5cc0d96b4ee3e1d5a11b64deb66a2b02.zip
Version bump. Install manpages to correct location as /usr/man is deprecated.
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/codecgraph')
-rw-r--r--media-sound/codecgraph/ChangeLog10
-rw-r--r--media-sound/codecgraph/codecgraph-20090522.ebuild34
-rw-r--r--media-sound/codecgraph/files/20090522-makefile-prefix.diff18
3 files changed, 60 insertions, 2 deletions
diff --git a/media-sound/codecgraph/ChangeLog b/media-sound/codecgraph/ChangeLog
index fff4f34e5dd2..71c6c01ec079 100644
--- a/media-sound/codecgraph/ChangeLog
+++ b/media-sound/codecgraph/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/codecgraph
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/codecgraph/ChangeLog,v 1.3 2008/05/07 23:44:20 chainsaw Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/codecgraph/ChangeLog,v 1.4 2010/11/21 13:40:34 chainsaw Exp $
+
+*codecgraph-20090522 (21 Nov 2010)
+
+ 21 Nov 2010; <chainsaw@gentoo.org> +files/20090522-makefile-prefix.diff,
+ +codecgraph-20090522.ebuild:
+ Version bump. Install manpages to correct location as /usr/man is deprecated.
*codecgraph-20080507 (07 May 2008)
diff --git a/media-sound/codecgraph/codecgraph-20090522.ebuild b/media-sound/codecgraph/codecgraph-20090522.ebuild
new file mode 100644
index 000000000000..f333371829ab
--- /dev/null
+++ b/media-sound/codecgraph/codecgraph-20090522.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/codecgraph/codecgraph-20090522.ebuild,v 1.1 2010/11/21 13:40:34 chainsaw Exp $
+
+inherit eutils
+
+DESCRIPTION="Generates a graph based on the ALSA description of an HD Audio codec."
+HOMEPAGE="http://helllabs.org/codecgraph/"
+SRC_URI="http://helllabs.org/codecgraph/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-lang/python
+ media-gfx/graphviz"
+
+DEPEND="${RDEPEND}
+ media-gfx/imagemagick"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}-makefile-prefix.diff"
+}
+
+src_compile() {
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc codecs.txt README BUGS IDEAS
+}
diff --git a/media-sound/codecgraph/files/20090522-makefile-prefix.diff b/media-sound/codecgraph/files/20090522-makefile-prefix.diff
new file mode 100644
index 000000000000..b771225b061f
--- /dev/null
+++ b/media-sound/codecgraph/files/20090522-makefile-prefix.diff
@@ -0,0 +1,18 @@
+diff -uNr codecgraph-20090522.ORIG//Makefile codecgraph-20090522/Makefile
+--- codecgraph-20090522.ORIG//Makefile 2010-11-21 13:34:06.000000000 +0000
++++ codecgraph-20090522/Makefile 2010-11-21 13:34:25.000000000 +0000
+@@ -1,4 +1,4 @@
+-PREFIX = /usr/local
++PREFIX = /usr
+ DOTTY = dot
+
+ samples = \
+@@ -62,7 +62,7 @@
+ install:
+ install -m755 -D codecgraph $(DESTDIR)$(PREFIX)/bin/codecgraph
+ install -m755 -D codecgraph.py $(DESTDIR)$(PREFIX)/bin/codecgraph.py
+- install -m644 -D codecgraph.1 $(DESTDIR)$(PREFIX)/man/man1/codecgraph.1
++ install -m644 -D codecgraph.1 $(DESTDIR)$(PREFIX)/share/man/man1/codecgraph.1
+
+ thumbs: png
+ for p in $(pngfiles);do \