summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2007-02-12 18:54:10 +0000
committerMarijn Schouten <hkbst@gentoo.org>2007-02-12 18:54:10 +0000
commit693e1c3fd26f3c84803073719d0008fdd3b50e18 (patch)
tree3e9ec9069f31228d27658cedcd415ca969bdcce0 /media-sound/cm
parentstable x86; bug 166529 (diff)
downloadgentoo-2-693e1c3fd26f3c84803073719d0008fdd3b50e18.tar.gz
gentoo-2-693e1c3fd26f3c84803073719d0008fdd3b50e18.tar.bz2
gentoo-2-693e1c3fd26f3c84803073719d0008fdd3b50e18.zip
update metadata (take over maintainership; add long desc); add recent version cm-2.10.0
(Portage version: 2.1.2-r9)
Diffstat (limited to 'media-sound/cm')
-rw-r--r--media-sound/cm/ChangeLog9
-rw-r--r--media-sound/cm/cm-2.10.0.ebuild119
-rw-r--r--media-sound/cm/files/digest-cm-2.10.03
-rw-r--r--media-sound/cm/files/digest-cm-2.4.22
-rw-r--r--media-sound/cm/metadata.xml11
5 files changed, 141 insertions, 3 deletions
diff --git a/media-sound/cm/ChangeLog b/media-sound/cm/ChangeLog
index ca04fe83c08e..d768422bf016 100644
--- a/media-sound/cm/ChangeLog
+++ b/media-sound/cm/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/cm
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/cm/ChangeLog,v 1.11 2007/01/10 19:47:14 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/cm/ChangeLog,v 1.12 2007/02/12 18:54:10 hkbst Exp $
+
+*cm-2.10.0 (12 Feb 2007)
+
+ 12 Feb 2007; Marijn Schouten <hkBst@gentoo.org> metadata.xml,
+ +cm-2.10.0.ebuild:
+ update metadata (take over maintainership; add long desc); add recent
+ version cm-2.10.0
10 Jan 2007; Piotr Jaroszyński <peper@gentoo.org> cm-2.4.2.ebuild:
Dependency update: dev-util/guile -> dev-scheme/guile.
diff --git a/media-sound/cm/cm-2.10.0.ebuild b/media-sound/cm/cm-2.10.0.ebuild
new file mode 100644
index 000000000000..5c4262e82351
--- /dev/null
+++ b/media-sound/cm/cm-2.10.0.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/cm/cm-2.10.0.ebuild,v 1.1 2007/02/12 18:54:10 hkbst Exp $
+
+inherit elisp-common
+
+DESCRIPTION="Common Music: An object oriented music composition environment in LISP/scheme"
+HOMEPAGE="http://commonmusic.sourceforge.net"
+SRC_URI="mirror://sourceforge/commonmusic/${P}.tar.gz"
+
+LICENSE="LLGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+COMPILERS="dev-lisp/openmcl
+ dev-lisp/sbcl
+ dev-lisp/cmucl
+ dev-lisp/clisp"
+
+INTERPRETERS="dev-lisp/ecls
+ dev-scheme/guile
+ dev-scheme/gauche"
+
+DEPEND="|| ( ${COMPILERS} ${INTERPRETERS} )
+ emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}"
+
+IUSE="doc emacs"
+
+S="${WORKDIR}/${PN}"
+
+# for easy testing of any implementation
+#FORCEIMPL="guile"
+FORCEIMPL=""
+
+CM="${S}/bin/cm.sh -R . -l \"\${FORCEIMPL}\""
+#echo "${CM}"
+
+implementation() {
+ if [[ ! -z "${FORCEIMPL}" ]]; then
+ echo "${FORCEIMPL}"
+ return
+ fi
+ local impl=$(${PN} -nv | grep Executable)
+ impl=${impl##*bin/}
+ echo ${impl}
+}
+
+lisp?() {
+ local impl="$(implementation)"
+# echo ${impl}
+ if [[ ${impl} == "guile" || ${impl} == "gauche" ]]; then
+ return $(false)
+ fi
+ return $(true)
+}
+
+compiler?() {
+ local impl="$(implementation)"
+# echo ${impl}
+ if [[ -z $(echo ${COMPILERS} | grep -i ${impl}) ]]; then
+ return $(false)
+ fi
+ return $(true)
+}
+
+src_compile() {
+ use emacs && elisp-comp etc/xemacs/*.el
+
+ einfo "Detected $(compiler? && echo "compiler" || echo "interpreter"): $(implementation)"
+
+ if compiler?; then
+ einfo "Byte-compiling code and generating Lisp code"
+ echo '(quit)' | eval ${CM}
+ echo -e "\n"
+ einfo "Byte-compiling generated code"
+ echo '(quit)' | eval ${CM}
+ fi
+}
+
+src_test() {
+# echo "(if '()\
+# (begin (display \"scheme\") (load \"etc/test.cm\") (test-cm))\
+# (progn (format t \"commonlisp\") (load \"etc/test.cm\") (test-cm)))"\
+# | eval ${CM}
+
+ echo '(load "etc/test.cm")(test-cm)' | eval ${CM}
+}
+
+src_install() {
+ insinto /usr/share/${PN}/
+ for dir in "bin etc src"; do
+ doins -r ${dir}
+ done;
+ doins cm.asd
+ chmod +x ${D}/usr/share/${PN}/bin/cm.sh
+ dosym /usr/share/${PN}/bin/cm.sh /usr/bin/${PN}
+
+ mv doc/changelog.text .
+ dodoc readme.text changelog.text
+
+ use doc && dohtml -r doc/*
+
+ if use emacs; then
+ elisp-install ${PN} etc/xemacs/*.el
+ elisp-site-file-install etc/xemacs/cm.el
+ fi
+}
+
+pkg_postinst() {
+ # make compiled lisp code newer than source files to prevent recompilation
+ find ${ROOT}/usr/share/${PN}/bin/ -iname *fasl -exec touch '{}' \;
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
+
diff --git a/media-sound/cm/files/digest-cm-2.10.0 b/media-sound/cm/files/digest-cm-2.10.0
new file mode 100644
index 000000000000..10d58e6f3f86
--- /dev/null
+++ b/media-sound/cm/files/digest-cm-2.10.0
@@ -0,0 +1,3 @@
+MD5 9b674af1786b3f1be594548822c8a226 cm-2.10.0.tar.gz 820936
+RMD160 5c92ad48576c9fa556499908bcafe5f652465d1f cm-2.10.0.tar.gz 820936
+SHA256 e642afd790c936998e48258c0c1a8cd854a5cdabd2ac635e6936dca1cfff741a cm-2.10.0.tar.gz 820936
diff --git a/media-sound/cm/files/digest-cm-2.4.2 b/media-sound/cm/files/digest-cm-2.4.2
index c0a121d004d5..c445fd58783b 100644
--- a/media-sound/cm/files/digest-cm-2.4.2
+++ b/media-sound/cm/files/digest-cm-2.4.2
@@ -1 +1,3 @@
MD5 2f33e9dac1aff473ae1af1ca38d4ec96 cm-2.4.2.tar.gz 463552
+RMD160 d3812c97b5d0a211b903867a04c37281f5e86929 cm-2.4.2.tar.gz 463552
+SHA256 b0c0229b6c7d011eb62bdc6a201ab80518abe0b7fcb8a1901d4f85771ea2d094 cm-2.4.2.tar.gz 463552
diff --git a/media-sound/cm/metadata.xml b/media-sound/cm/metadata.xml
index e1774e3d9ad7..606175ba74c7 100644
--- a/media-sound/cm/metadata.xml
+++ b/media-sound/cm/metadata.xml
@@ -1,5 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sound</herd>
-</pkgmetadata>
+ <herd>scheme</herd>
+ <maintainer>
+ <email>hkBst@gentoo.org</email>
+ <name>Marijn Schouten</name>
+ </maintainer>
+ <longdescription lang="en">
+Common Music (CM) is an object-oriented music composition environment. It produces sound by transforming a high-level representation of musical structure into a variety of control protocols for sound synthesis and display. Common Music defines an extensive library of compositional tools and an API through which the composer can easily modify and extend the system.
+ </longdescription>
+</pkgmetadata> \ No newline at end of file