summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2006-01-27 18:30:33 +0000
committerPatrick McLean <chutzpah@gentoo.org>2006-01-27 18:30:33 +0000
commitd4b798556be6b041dd4f658bd603505a83975fb5 (patch)
tree721b08faa4b114c63bc32b66f08a3e5699b4a579 /media-sound/cdparanoia/cdparanoia-3.9.8-r3.ebuild
parentStable on hppa (bug #119722). (diff)
downloadgentoo-2-d4b798556be6b041dd4f658bd603505a83975fb5.tar.gz
gentoo-2-d4b798556be6b041dd4f658bd603505a83975fb5.tar.bz2
gentoo-2-d4b798556be6b041dd4f658bd603505a83975fb5.zip
New revision, add SG_IO patches for 2.6 kernel mentioned in bug #118189
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'media-sound/cdparanoia/cdparanoia-3.9.8-r3.ebuild')
-rw-r--r--media-sound/cdparanoia/cdparanoia-3.9.8-r3.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/media-sound/cdparanoia/cdparanoia-3.9.8-r3.ebuild b/media-sound/cdparanoia/cdparanoia-3.9.8-r3.ebuild
new file mode 100644
index 000000000000..919f4644cd26
--- /dev/null
+++ b/media-sound/cdparanoia/cdparanoia-3.9.8-r3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/cdparanoia/cdparanoia-3.9.8-r3.ebuild,v 1.1 2006/01/27 18:30:33 chutzpah Exp $
+
+inherit eutils flag-o-matic gnuconfig linux-info
+
+MY_P=${PN}-III-alpha9.8
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="an advanced CDDA reader with error correction"
+HOMEPAGE="http://www.xiph.org/paranoia/"
+SRC_URI="http://www.xiph.org/paranoia/download/${MY_P}.src.tgz
+ mirror://gentoo/${P}-SG_IO-patches.tar.gz"
+
+IUSE=""
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # cdda_paranoia.h should include cdda_interface_h, else most configure
+ # scripts testing for support fails (gnome-vfs, etc).
+ epatch ${FILESDIR}/${P}-include-cdda_interface_h.patch
+ epatch ${FILESDIR}/${P}-toc.patch
+ epatch ${FILESDIR}/${P}-identify_crash.patch
+ epatch ${FILESDIR}/${PV}-gcc34.patch
+
+ # if libdir is specified, cdparanoia causes sandbox violations, and using
+ # einstall doesnt work around it. so lets patch in DESTDIR support
+ epatch ${FILESDIR}/${P}-use-destdir.patch
+
+ # Apply Red Hat's SG_IO patches see bug #118189 for more info
+ kernel_is 2 6 && EPATCH_SOURCE="${WORKDIR}/patches" EPATCH_SUFFIX="patch" epatch
+
+ # Let portage handle the stripping of binaries
+ sed -i -e "/strip cdparanoia/d" Makefile.in
+
+ ln -s configure.guess config.guess
+ ln -s configure.sub config.sub
+ gnuconfig_update
+ rm config.{guess,sub}
+}
+
+src_compile() {
+ append-flags -I${S}/interface
+ econf || die
+ make OPT="${CFLAGS}" || die
+}
+
+src_install() {
+ dodir /usr/{bin,lib,include} /usr/share/man/man1
+ make DESTDIR=${D} install || die
+ dodoc FAQ.txt README
+}