summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Medinas <metalgod@gentoo.org>2007-08-07 03:27:12 +0000
committerLuis Medinas <metalgod@gentoo.org>2007-08-07 03:27:12 +0000
commit10b49e8b316156ab081994a7e564079b3d12e569 (patch)
tree489e4ec37c35660e73b404e32bcf0dd8ef32c998 /media-sound/banshee
parentNew release: 0.9.17 (bug #187918) (diff)
downloadgentoo-2-10b49e8b316156ab081994a7e564079b3d12e569.tar.gz
gentoo-2-10b49e8b316156ab081994a7e564079b3d12e569.tar.bz2
gentoo-2-10b49e8b316156ab081994a7e564079b3d12e569.zip
Version Bump.
(Portage version: 2.1.3.3)
Diffstat (limited to 'media-sound/banshee')
-rw-r--r--media-sound/banshee/ChangeLog7
-rw-r--r--media-sound/banshee/banshee-0.13.0.ebuild101
-rw-r--r--media-sound/banshee/files/digest-banshee-0.13.03
3 files changed, 110 insertions, 1 deletions
diff --git a/media-sound/banshee/ChangeLog b/media-sound/banshee/ChangeLog
index c2ec380e7504..2950e15350fa 100644
--- a/media-sound/banshee/ChangeLog
+++ b/media-sound/banshee/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/banshee
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/banshee/ChangeLog,v 1.47 2007/07/30 08:00:18 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/banshee/ChangeLog,v 1.48 2007/08/07 03:27:12 metalgod Exp $
+
+*banshee-0.13.0 (07 Aug 2007)
+
+ 07 Aug 2007; <metalgod@gentoo.org> +banshee-0.13.0.ebuild:
+ Version Bump.
30 Jul 2007; Christian Faulhammer <opfer@gentoo.org>
banshee-0.12.1.ebuild:
diff --git a/media-sound/banshee/banshee-0.13.0.ebuild b/media-sound/banshee/banshee-0.13.0.ebuild
new file mode 100644
index 000000000000..21e4e6680a1d
--- /dev/null
+++ b/media-sound/banshee/banshee-0.13.0.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/banshee/banshee-0.13.0.ebuild,v 1.1 2007/08/07 03:27:12 metalgod Exp $
+
+inherit autotools eutils gnome2 mono
+
+DESCRIPTION="Banshee allows you to import CDs, sync your music collection, play
+music directly from an iPod, create playlists with songs from your library, and
+create audio and MP3 CDs from subsets of your library."
+HOMEPAGE="http://banshee-project.org"
+SRC_URI="http://banshee-project.org/files/${PN}/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="aac boo doc daap encode ipod flac mad njb vorbis"
+
+RDEPEND=">=dev-lang/mono-1.2.0
+ >=dev-dotnet/gtk-sharp-2.8.0
+ >=dev-dotnet/gnomevfs-sharp-2.8.0
+ >=dev-dotnet/gconf-sharp-2.8.0
+ >=media-libs/gstreamer-0.10.3
+ >=media-libs/gst-plugins-base-0.10.3
+ >=media-libs/gst-plugins-good-0.10.3
+ >=media-libs/gst-plugins-ugly-0.10.3
+ >=media-plugins/gst-plugins-alsa-0.10.3
+ >=media-plugins/gst-plugins-gnomevfs-0.10.3
+ >=media-plugins/gst-plugins-gconf-0.10.3
+ encode? ( >=media-plugins/gst-plugins-lame-0.10.3
+ >=media-plugins/gst-plugins-taglib-0.10.3 )
+ mad? ( >=media-plugins/gst-plugins-mad-0.10.3 )
+ vorbis? ( >=media-plugins/gst-plugins-ogg-0.10.3
+ >=media-plugins/gst-plugins-vorbis-0.10.3 )
+ flac? ( >=media-plugins/gst-plugins-flac-0.10.3 )
+ aac? ( >=media-plugins/gst-plugins-faad-0.10.3
+ >=media-libs/faad2-2.0-r4 )
+ >=media-plugins/gst-plugins-cdparanoia-0.10.3
+ >=media-libs/musicbrainz-2.1.1
+ njb? ( >=dev-dotnet/njb-sharp-0.3.0 )
+ daap? ( >=net-dns/avahi-0.6.9 )
+ >=dev-libs/glib-2.0
+ >=gnome-base/libgnomeui-2.0
+ >=gnome-base/libbonobo-2.0
+ >=gnome-base/gnome-desktop-2.0
+ ipod? ( >=dev-dotnet/ipod-sharp-0.6.3
+ >=media-plugins/gst-plugins-faac-0.10.3 )
+ >=sys-apps/hal-0.5.2
+ boo? ( >=dev-lang/boo-0.7.6 )
+ >=dev-db/sqlite-3
+ >=gnome-extra/nautilus-cd-burner-2.12"
+
+USE_DESTDIR=1
+DOCS="ChangeLog HACKING NEWS README"
+
+pkg_setup() {
+ if use daap && ! built_with_use net-dns/avahi mono ; then
+ echo
+ eerror "In order to compile banshee with daap support"
+ eerror "you need to have net-dns/avahi emerged"
+ eerror "with 'mono' in your USE flags. Please add that flag, re-emerge"
+ eerror "avahi, and then emerge banshee."
+ die "net-dns/avahi is missing the .NET binding."
+ fi
+
+ if use daap; then
+ G2CONF="${G2CONF} --enable-avahi"
+ else
+ G2CONF="${G2CONF} --disable-daap"
+ fi
+
+ if use boo; then
+ G2CONF="${G2CONF} --enable-external-boo"
+ fi
+
+ G2CONF="${G2CONF} --disable-helix \
+ --disable-docs \
+ $( use_enable ipod) \
+ $( use_enable njb)"
+}
+
+src_compile() {
+ addpredict "/root/.gnome2"
+ addpredict "/root/.gconf"
+ addpredict "/root/.gconfd"
+ gnome2_src_configure
+ emake -j1 || "make failed"
+}
+
+src_install() {
+ gnome2_src_install
+ if ! use ipod; then
+ dodir /usr/$(get_libdir)/banshee/Banshee.Dap
+ fi
+}
+pkg_postinst() {
+ gnome2_pkg_postinst
+ elog
+ elog "In case you have an ipod please rebuild this package with USE=ipod"
+ elog "If you have a audio player supported by libnjb please"
+ elog "rebuild this package with USE=njb"
+ elog
+}
diff --git a/media-sound/banshee/files/digest-banshee-0.13.0 b/media-sound/banshee/files/digest-banshee-0.13.0
new file mode 100644
index 000000000000..cb7b86f38db0
--- /dev/null
+++ b/media-sound/banshee/files/digest-banshee-0.13.0
@@ -0,0 +1,3 @@
+MD5 dcb91c8159c50622c8697cc9f5861f9a banshee-0.13.0.tar.gz 2989737
+RMD160 45880d60058927095460accb1f28a24f6f284319 banshee-0.13.0.tar.gz 2989737
+SHA256 6aceeab92297a9ca656798a33bddff0b91b898da9de74f2b0654192b682e356a banshee-0.13.0.tar.gz 2989737