summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-05-20 13:42:37 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-05-20 13:42:37 +0000
commit3112d037748773ebc85bcf3f3639f173b4b10251 (patch)
tree44f5341cdb4e9a9d1da8d04a469d4b7e560ac6e6 /media-sound/awesfx
parentMarking xprop-1.0.4 ~ppc for bug 268581 (diff)
downloadgentoo-2-3112d037748773ebc85bcf3f3639f173b4b10251.tar.gz
gentoo-2-3112d037748773ebc85bcf3f3639f173b4b10251.tar.bz2
gentoo-2-3112d037748773ebc85bcf3f3639f173b4b10251.zip
Patch for getline in setfx.c wrt #270486, thanks to Thomas Lercher.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/awesfx')
-rw-r--r--media-sound/awesfx/ChangeLog8
-rw-r--r--media-sound/awesfx/awesfx-0.5.1c.ebuild24
-rw-r--r--media-sound/awesfx/files/awesfx-0.5.1c-getline.patch53
3 files changed, 75 insertions, 10 deletions
diff --git a/media-sound/awesfx/ChangeLog b/media-sound/awesfx/ChangeLog
index 73c6492c1f41..f9cad1229583 100644
--- a/media-sound/awesfx/ChangeLog
+++ b/media-sound/awesfx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/awesfx
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/awesfx/ChangeLog,v 1.25 2008/01/14 17:40:52 chainsaw Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/awesfx/ChangeLog,v 1.26 2009/05/20 13:42:36 ssuominen Exp $
+
+ 20 May 2009; Samuli Suominen <ssuominen@gentoo.org> awesfx-0.5.1c.ebuild,
+ +files/awesfx-0.5.1c-getline.patch:
+ Patch for getline in setfx.c wrt #270486, thanks to Thomas Lercher.
14 Jan 2008; Tony Vroon <chainsaw@gentoo.org> awesfx-0.5.0d.ebuild,
awesfx-0.5.1.ebuild:
diff --git a/media-sound/awesfx/awesfx-0.5.1c.ebuild b/media-sound/awesfx/awesfx-0.5.1c.ebuild
index 257dfde8e01f..c1c9c2c08859 100644
--- a/media-sound/awesfx/awesfx-0.5.1c.ebuild
+++ b/media-sound/awesfx/awesfx-0.5.1c.ebuild
@@ -1,6 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/awesfx/awesfx-0.5.1c.ebuild,v 1.1 2008/01/14 15:16:23 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/awesfx/awesfx-0.5.1c.ebuild,v 1.2 2009/05/20 13:42:36 ssuominen Exp $
+
+EAPI=2
+inherit eutils
DESCRIPTION="AWE32 Sound Driver Utility Programs"
HOMEPAGE="http://ftp.suse.com/pub/people/tiwai/awesfx"
@@ -11,19 +14,24 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE=""
-DEPEND=">=media-libs/alsa-lib-1"
+RDEPEND="media-libs/alsa-lib"
+DEPEND="${RDEPEND}"
BANK_LOC="/usr/share/sounds/sf2"
-src_compile() {
- econf --with-sfpath=${BANK_LOC}
- emake || die "emake failed."
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-getline.patch
+}
+
+src_configure() {
+ econf \
+ --with-sfpath=${BANK_LOC}
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
+ emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS ChangeLog README SBKtoSF2.txt samples/README-bank
- rm "${D}"/usr/share/sounds/sf2/README-bank
+ rm -f "${D}"/usr/share/sounds/sf2/README-bank
}
pkg_postinst() {
diff --git a/media-sound/awesfx/files/awesfx-0.5.1c-getline.patch b/media-sound/awesfx/files/awesfx-0.5.1c-getline.patch
new file mode 100644
index 000000000000..cdc781b9755f
--- /dev/null
+++ b/media-sound/awesfx/files/awesfx-0.5.1c-getline.patch
@@ -0,0 +1,53 @@
+--- setfx.c 2007-08-29 18:00:23.000000000 +0200
++++ setfx.c 2009-05-19 22:19:56.140092119 +0200
+@@ -37,7 +37,7 @@
+ /*----------------------------------------------------------------*/
+
+ static void usage(void);
+-static int getline(FILE *fp);
++static int awesfx_getline(FILE *fp);
+ static int nextline(FILE *fp);
+ static char *gettok(FILE *fp);
+ static char *divtok(char *src, char *divs, int only_one);
+@@ -126,7 +126,7 @@
+ }
+
+ curline = 0;
+- if (!getline(fp))
++ if (!awesfx_getline(fp))
+ return 0;
+
+ seq_init(seq_devname, seq_devidx);
+@@ -370,7 +370,7 @@
+ * read a line and parse tokens
+ *----------------------------------------------------------------*/
+
+-static int getline(FILE *fp)
++static int awesfx_getline(FILE *fp)
+ {
+ char *p;
+ curline++;
+@@ -393,12 +393,12 @@
+ {
+ if (connected) {
+ do {
+- if (! getline(fp))
++ if (! awesfx_getline(fp))
+ return FALSE;
+ } while (connected);
+ return TRUE;
+ } else {
+- return getline(fp);
++ return awesfx_getline(fp);
+ }
+ }
+
+@@ -415,7 +415,7 @@
+ tok = divtok(NULL, " \t\r\n", FALSE);
+ while (tok == NULL || *tok == 0) {
+ if (! connected) return NULL;
+- if (! getline(fp)) return NULL;
++ if (! awesfx_getline(fp)) return NULL;
+ tok = divtok(line, " \t\r\n", FALSE);
+ }
+ return tok;