summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-07-22 09:05:45 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-07-22 09:05:45 +0000
commit6fce657a90b852065258983debd363f08687ca80 (patch)
tree7e0286c481b40af11ef5b8fe693159407805e57e /media-sound/aumix
parentThis package is not loved by sound herd. It's upstream maintance has somethi... (diff)
downloadgentoo-2-6fce657a90b852065258983debd363f08687ca80.tar.gz
gentoo-2-6fce657a90b852065258983debd363f08687ca80.tar.bz2
gentoo-2-6fce657a90b852065258983debd363f08687ca80.zip
Added aumix-2.8-close-dialogs.patch aumix-2.8-save_load.patch from upstream.
Diffstat (limited to 'media-sound/aumix')
-rw-r--r--media-sound/aumix/ChangeLog6
-rw-r--r--media-sound/aumix/aumix-2.8-r2.ebuild4
-rw-r--r--media-sound/aumix/files/aumix-2.8-close-dialogs.patch18
-rw-r--r--media-sound/aumix/files/aumix-2.8-save_load.patch45
4 files changed, 71 insertions, 2 deletions
diff --git a/media-sound/aumix/ChangeLog b/media-sound/aumix/ChangeLog
index 2c25a2b2a958..9cf09deca2f2 100644
--- a/media-sound/aumix/ChangeLog
+++ b/media-sound/aumix/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/aumix
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/aumix/ChangeLog,v 1.32 2004/07/22 08:31:24 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/aumix/ChangeLog,v 1.33 2004/07/22 09:05:45 eradicator Exp $
+
+ 22 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ +files/aumix-2.8-close-dialogs.patch, +files/aumix-2.8-save_load.patch:
+ Added aumix-2.8-close-dialogs.patch aumix-2.8-save_load.patch from upstream.
*aumix-2.8-r2 (22 Jul 2004)
diff --git a/media-sound/aumix/aumix-2.8-r2.ebuild b/media-sound/aumix/aumix-2.8-r2.ebuild
index 4467d0763ac2..8ddcb2aba170 100644
--- a/media-sound/aumix/aumix-2.8-r2.ebuild
+++ b/media-sound/aumix/aumix-2.8-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/aumix/aumix-2.8-r2.ebuild,v 1.1 2004/07/22 08:31:24 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/aumix/aumix-2.8-r2.ebuild,v 1.2 2004/07/22 09:05:45 eradicator Exp $
IUSE="gtk gtk2 gpm nls"
@@ -27,6 +27,8 @@ src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/${P}-nohome.patch
+ epatch ${FILESDIR}/${P}-close-dialogs.patch
+ epatch ${FILESDIR}/${P}-save_load.patch
}
src_compile() {
diff --git a/media-sound/aumix/files/aumix-2.8-close-dialogs.patch b/media-sound/aumix/files/aumix-2.8-close-dialogs.patch
new file mode 100644
index 000000000000..e2d46cc86cf4
--- /dev/null
+++ b/media-sound/aumix/files/aumix-2.8-close-dialogs.patch
@@ -0,0 +1,18 @@
+--- ./src/gtk.c.tv 2003-09-04 19:18:07.000000000 +0200
++++ ./src/gtk.c 2003-09-04 19:18:41.000000000 +0200
+@@ -425,6 +425,7 @@
+ /* Get the selected filename and copy it into the global save_filename. */
+ {
+ save_filename = g_strdup(gtk_file_selection_get_filename(GTK_FILE_SELECTION(fs)));
++ gtk_widget_destroy(fs);
+ ErrorExitWarn(LoadSettings(), 'w');
+ }
+
+@@ -432,6 +433,7 @@
+ /* Get the selected filename and copy it into the global save_filename. */
+ {
+ save_filename = g_strdup(gtk_file_selection_get_filename(GTK_FILE_SELECTION(fs)));
++ gtk_widget_destroy(fs);
+ ErrorExitWarn(SaveSettings(), 'e');
+ }
+
diff --git a/media-sound/aumix/files/aumix-2.8-save_load.patch b/media-sound/aumix/files/aumix-2.8-save_load.patch
new file mode 100644
index 000000000000..cf3c409eb015
--- /dev/null
+++ b/media-sound/aumix/files/aumix-2.8-save_load.patch
@@ -0,0 +1,45 @@
+--- ./src/common.c.load 2002-11-28 14:22:00.000000000 +0100
++++ ./src/common.c 2002-11-28 14:23:11.000000000 +0100
+@@ -116,6 +116,7 @@
+ int main(int argc, char *argv[])
+ {
+ int optn, ii;
++ int save = 0, load = 0;
+ #ifdef HAVE_CURSES
+ int setcolors = FALSE;
+ #endif /* HAVE_CURSES */
+@@ -171,14 +172,10 @@
+ break;
+ #endif /* HAVE_CURSES */
+ case 'S': /* Save to file. */
+- if (mixer_fd == -1)
+- ErrorExitWarn(InitializeMixer(device_filename), 'e');
+- ErrorExitWarn(SaveSettings(), 'e');
++ save = 1;
+ break;
+ case 'L': /* Load from file. */
+- if (mixer_fd == -1)
+- ErrorExitWarn(InitializeMixer(device_filename), 'e');
+- ErrorExitWarn(LoadSettings(), 'e');
++ load = 1;
+ break;
+ #if defined (HAVE_CURSES) || defined (HAVE_GTK) || defined (HAVE_GTK1)
+ case 'I': /* User asked for interactive mode. */
+@@ -194,6 +191,17 @@
+ }
+ }
+ }
++ if (save | load) {
++ if (mixer_fd == -1)
++ ErrorExitWarn(InitializeMixer(device_filename), 'e');
++ if (save)
++ ErrorExitWarn(SaveSettings(), 'e');
++ else
++ ErrorExitWarn(LoadSettings(), 'e');
++ close(mixer_fd);
++ exit(EXIT_SUCCESS);
++ }
++
+ #if defined (HAVE_CURSES) || defined (HAVE_GTK) || defined (HAVE_GTK1)
+ /* Be interactive if no options were given. */
+ if (!interactive && argc <= 1)