summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2007-03-09 04:23:51 +0000
committerSteve Dibb <beandog@gentoo.org>2007-03-09 04:23:51 +0000
commitf56cc93c1aeed9fe0d3650c171b8cf618121fd28 (patch)
tree25874fb118e9a95c2da1c5f83226fb63afec5d15 /media-sound/audiocompress
parentRemove old wv entry; bug #105016 (diff)
downloadgentoo-2-f56cc93c1aeed9fe0d3650c171b8cf618121fd28.tar.gz
gentoo-2-f56cc93c1aeed9fe0d3650c171b8cf618121fd28.tar.bz2
gentoo-2-f56cc93c1aeed9fe0d3650c171b8cf618121fd28.zip
patch for optional esd support, bug 145146
(Portage version: 2.1.2.2)
Diffstat (limited to 'media-sound/audiocompress')
-rw-r--r--media-sound/audiocompress/ChangeLog8
-rw-r--r--media-sound/audiocompress/audiocompress-1.5.2-r1.ebuild38
-rw-r--r--media-sound/audiocompress/files/audiocompress-1.5.2-esd.patch13
-rw-r--r--media-sound/audiocompress/files/digest-audiocompress-1.5.2-r13
4 files changed, 61 insertions, 1 deletions
diff --git a/media-sound/audiocompress/ChangeLog b/media-sound/audiocompress/ChangeLog
index 58dafe1741d9..53c59b140f38 100644
--- a/media-sound/audiocompress/ChangeLog
+++ b/media-sound/audiocompress/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/audiocompress
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audiocompress/ChangeLog,v 1.18 2007/02/22 00:48:58 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audiocompress/ChangeLog,v 1.19 2007/03/09 04:23:51 beandog Exp $
+
+*audiocompress-1.5.2-r1 (09 Mar 2007)
+
+ 09 Mar 2007; Steve Dibb <beandog@gentoo.org>
+ +files/audiocompress-1.5.2-esd.patch, +audiocompress-1.5.2-r1.ebuild:
+ patch for optional esd support, bug 145146
22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/media-sound/audiocompress/audiocompress-1.5.2-r1.ebuild b/media-sound/audiocompress/audiocompress-1.5.2-r1.ebuild
new file mode 100644
index 000000000000..87a22ae94d08
--- /dev/null
+++ b/media-sound/audiocompress/audiocompress-1.5.2-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audiocompress/audiocompress-1.5.2-r1.ebuild,v 1.1 2007/03/09 04:23:51 beandog Exp $
+
+inherit eutils
+
+MY_P="AudioCompress-${PV}"
+IUSE="esd"
+DESCRIPTION="Very gentle 1-band dynamic range compressor"
+HOMEPAGE="http://beesbuzz.biz/code/"
+SRC_URI="http://beesbuzz.biz/code/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+#-sparc: 1.5.5 - Gdk-ERROR **: BadValue (integer parameter out of range for operation) serial 7 error_code 2 request_code 1 minor_code 0
+KEYWORDS="~amd64 ~ppc -sparc x86"
+
+DEPEND="esd? ( media-sound/esound )"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ make clean
+
+ epatch ${FILESDIR}/${P}-gentoo.patch
+ use esd || epatch ${FILESDIR}/${P}-esd.patch
+}
+
+src_compile() {
+ emake AudioCompress || die
+}
+
+src_install() {
+ dobin AudioCompress || die
+ dodoc ChangeLog README TODO
+}
diff --git a/media-sound/audiocompress/files/audiocompress-1.5.2-esd.patch b/media-sound/audiocompress/files/audiocompress-1.5.2-esd.patch
new file mode 100644
index 000000000000..e67241282780
--- /dev/null
+++ b/media-sound/audiocompress/files/audiocompress-1.5.2-esd.patch
@@ -0,0 +1,13 @@
+--- Makefile.orig 2006-08-26 01:02:22.000000000 -0500
++++ Makefile 2006-08-26 01:03:09.000000000 -0500
+@@ -27,8 +27,8 @@
+
+ ### Comment out these lines if you don't want to include EsounD functionality
+ ### (or don't have the EsounD development headers installed)
+-CFLAGS += -DUSE_ESD `esd-config --cflags`
+-LDFLAGS += `esd-config --libs`
++#CFLAGS += -DUSE_ESD `esd-config --cflags`
++#LDFLAGS += `esd-config --libs`
+
+ all: $(TARGETS)
+
diff --git a/media-sound/audiocompress/files/digest-audiocompress-1.5.2-r1 b/media-sound/audiocompress/files/digest-audiocompress-1.5.2-r1
new file mode 100644
index 000000000000..d68b6ec50442
--- /dev/null
+++ b/media-sound/audiocompress/files/digest-audiocompress-1.5.2-r1
@@ -0,0 +1,3 @@
+MD5 29ee0d58fac8752e793fdc778dcff8f3 AudioCompress-1.5.2.tar.gz 25061
+RMD160 e47093f2dbebd197b24d3cb592b9a9865c9c2d5a AudioCompress-1.5.2.tar.gz 25061
+SHA256 52928e226968f45dc6f36bedaa34708835a8b0ba653335a3058be71cc8137191 AudioCompress-1.5.2.tar.gz 25061