summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-06-01 18:18:04 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-06-01 18:18:04 +0000
commit66a756988bf6cd4fdd5d40c53211f1d755786a27 (patch)
tree263ddb7fb32ee70bb42aba21d9693f6f8ee79287 /media-sound/audiocompress
parentFix repoman warnings (diff)
downloadgentoo-2-66a756988bf6cd4fdd5d40c53211f1d755786a27.tar.gz
gentoo-2-66a756988bf6cd4fdd5d40c53211f1d755786a27.tar.bz2
gentoo-2-66a756988bf6cd4fdd5d40c53211f1d755786a27.zip
Fix repoman issues, fix latest ebuild etc
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/audiocompress')
-rw-r--r--media-sound/audiocompress/audiocompress-1.5.1.ebuild40
-rw-r--r--media-sound/audiocompress/audiocompress-1.5.2-r1.ebuild22
-rw-r--r--media-sound/audiocompress/audiocompress-1.5.2.ebuild40
-rw-r--r--media-sound/audiocompress/audiocompress-2.0.ebuild27
-rw-r--r--media-sound/audiocompress/files/audiocompress-1.5.1-gentoo.patch29
5 files changed, 26 insertions, 132 deletions
diff --git a/media-sound/audiocompress/audiocompress-1.5.1.ebuild b/media-sound/audiocompress/audiocompress-1.5.1.ebuild
deleted file mode 100644
index 8e844b4baca2..000000000000
--- a/media-sound/audiocompress/audiocompress-1.5.1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audiocompress/audiocompress-1.5.1.ebuild,v 1.9 2006/11/13 15:20:28 flameeyes Exp $
-
-IUSE=""
-
-inherit eutils
-
-MY_P="AudioCompress-${PV}"
-
-DESCRIPTION="Very gentle 1-band dynamic range compressor"
-HOMEPAGE="http://beesbuzz.biz/code/"
-SRC_URI="http://beesbuzz.biz/code/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-#-sparc: 1.5.5 - Gdk-ERROR **: BadValue (integer parameter out of range for operation) serial 7 error_code 2 request_code 1 minor_code 0
-KEYWORDS="~ppc -sparc x86"
-
-DEPEND="media-sound/esound"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
- make clean
-
- epatch ${FILESDIR}/${P}-gentoo.patch
-}
-
-src_compile() {
- emake AudioCompress || die
-}
-
-src_install() {
- dobin AudioCompress || die
- dodoc ChangeLog README TODO
-}
diff --git a/media-sound/audiocompress/audiocompress-1.5.2-r1.ebuild b/media-sound/audiocompress/audiocompress-1.5.2-r1.ebuild
index 87a22ae94d08..d5e654e78e5c 100644
--- a/media-sound/audiocompress/audiocompress-1.5.2-r1.ebuild
+++ b/media-sound/audiocompress/audiocompress-1.5.2-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audiocompress/audiocompress-1.5.2-r1.ebuild,v 1.1 2007/03/09 04:23:51 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audiocompress/audiocompress-1.5.2-r1.ebuild,v 1.2 2009/06/01 18:18:03 ssuominen Exp $
inherit eutils
@@ -11,28 +11,28 @@ HOMEPAGE="http://beesbuzz.biz/code/"
SRC_URI="http://beesbuzz.biz/code/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-#-sparc: 1.5.5 - Gdk-ERROR **: BadValue (integer parameter out of range for operation) serial 7 error_code 2 request_code 1 minor_code 0
-KEYWORDS="~amd64 ~ppc -sparc x86"
+KEYWORDS="~amd64 ~ppc x86"
-DEPEND="esd? ( media-sound/esound )"
+RDEPEND=""
+DEPEND=""
S=${WORKDIR}/${MY_P}
src_unpack() {
unpack ${A}
+ cd "${S}"
- cd ${S}
- make clean
+ emake clean
- epatch ${FILESDIR}/${P}-gentoo.patch
- use esd || epatch ${FILESDIR}/${P}-esd.patch
+ epatch "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-esd.patch
}
src_compile() {
- emake AudioCompress || die
+ emake AudioCompress || die "emake AudioCompress failed"
}
src_install() {
- dobin AudioCompress || die
+ dobin AudioCompress || die "dobin failed"
dodoc ChangeLog README TODO
}
diff --git a/media-sound/audiocompress/audiocompress-1.5.2.ebuild b/media-sound/audiocompress/audiocompress-1.5.2.ebuild
deleted file mode 100644
index fdb911db6fe6..000000000000
--- a/media-sound/audiocompress/audiocompress-1.5.2.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audiocompress/audiocompress-1.5.2.ebuild,v 1.3 2006/11/20 20:40:00 blubb Exp $
-
-IUSE=""
-
-inherit eutils
-
-MY_P="AudioCompress-${PV}"
-
-DESCRIPTION="Very gentle 1-band dynamic range compressor"
-HOMEPAGE="http://beesbuzz.biz/code/"
-SRC_URI="http://beesbuzz.biz/code/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-#-sparc: 1.5.5 - Gdk-ERROR **: BadValue (integer parameter out of range for operation) serial 7 error_code 2 request_code 1 minor_code 0
-KEYWORDS="~amd64 ~ppc -sparc x86"
-
-DEPEND="media-sound/esound"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
- make clean
-
- epatch ${FILESDIR}/${P}-gentoo.patch
-}
-
-src_compile() {
- emake AudioCompress || die
-}
-
-src_install() {
- dobin AudioCompress || die
- dodoc ChangeLog README TODO
-}
diff --git a/media-sound/audiocompress/audiocompress-2.0.ebuild b/media-sound/audiocompress/audiocompress-2.0.ebuild
index b8483bd454b1..07c44f8fb96b 100644
--- a/media-sound/audiocompress/audiocompress-2.0.ebuild
+++ b/media-sound/audiocompress/audiocompress-2.0.ebuild
@@ -1,31 +1,34 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audiocompress/audiocompress-2.0.ebuild,v 1.1 2008/12/19 15:15:33 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audiocompress/audiocompress-2.0.ebuild,v 1.2 2009/06/01 18:18:03 ssuominen Exp $
-inherit toolchain-funcs flag-o-matic
+inherit toolchain-funcs
+
+MY_P=AudioCompress-${PV}
-MY_P="AudioCompress-${PV}"
DESCRIPTION="Very gentle 1-band dynamic range compressor"
HOMEPAGE="http://beesbuzz.biz/code/"
SRC_URI="http://beesbuzz.biz/code/audiocompress/${MY_P}.tar.gz"
+
LICENSE="LGPL-2.1"
SLOT="0"
-#-sparc: 1.5.5 - Gdk-ERROR **: BadValue (integer parameter out of range for operation) serial 7 error_code 2 request_code 1 minor_code 0
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="esd"
+IUSE=""
-DEPEND="esd? ( media-sound/esound )"
+RDEPEND=""
+DEPEND=""
S=${WORKDIR}/${MY_P}
src_compile() {
- echo "AudioCompress: AudioCompress.o compress.o" > Makefile
- use esd && append-flags "-DUSE_ESD `esd-config --cflags`"
- tc-export CC
- emake LDLIBS="$(use esd && echo `esd-config --libs`)" || die
+ emake \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" || die "emake failed"
}
src_install() {
- dobin AudioCompress || die
+ dobin AudioCompress || die "dobin failed"
dodoc ChangeLog README TODO
}
diff --git a/media-sound/audiocompress/files/audiocompress-1.5.1-gentoo.patch b/media-sound/audiocompress/files/audiocompress-1.5.1-gentoo.patch
deleted file mode 100644
index 24e510246296..000000000000
--- a/media-sound/audiocompress/files/audiocompress-1.5.1-gentoo.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-diff -Naur AudioCompress-1.5.1.orig/Makefile AudioCompress-1.5.1/Makefile
---- AudioCompress-1.5.1.orig/Makefile 2004-03-29 10:04:30.000000000 -0800
-+++ AudioCompress-1.5.1/Makefile 2004-08-02 12:57:48.347510623 -0700
-@@ -6,12 +6,12 @@
-
- ### Different platforms need different options...
- ### Linux
--#DYNAMIC = -shared -Wl,-soname -Wl,$(@)
-+DYNAMIC = -shared -Wl,-soname -Wl,$(@)
-
- ### MacOS X (Jaguar with Fink)
--CFLAGS = -I/sw/include
--LDFLAGS = -L/sw/lib
--DYNAMIC = -dynamiclib
-+#CFLAGS = -I/sw/include
-+#LDFLAGS = -L/sw/lib
-+#DYNAMIC = -dynamiclib
-
- ### Comment out these lines if you don't have X11 installed or
- ### otherwise want to build it without X11
-@@ -22,7 +22,7 @@
- ### (or don't have the XMMS development headers installed)
- TARGETS += libcompress.so
- INSTALL += install-xmms
--CFLAGS += `xmms-config --cflags`
-+CFLAGS += `xmms-config --cflags` -fPIC
- LDFLAGS += `xmms-config --libs`
-
- ### Comment out these lines if you don't want to include EsounD functionality