summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2010-02-09 21:47:20 +0000
committerTony Vroon <chainsaw@gentoo.org>2010-02-09 21:47:20 +0000
commita8c42b3459f5b3c33c43208c7d6a20add9798b70 (patch)
tree27c34864aadd4e3dd5fcfc412a910d83c80264d9 /media-sound/audacious
parentmask kde sc 4.4.0 since neede deps not keyworded (diff)
downloadgentoo-2-a8c42b3459f5b3c33c43208c7d6a20add9798b70.tar.gz
gentoo-2-a8c42b3459f5b3c33c43208c7d6a20add9798b70.tar.bz2
gentoo-2-a8c42b3459f5b3c33c43208c7d6a20add9798b70.zip
New and improved alpha build with debug functionality. Bugs still upstream, thank you.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/audacious')
-rw-r--r--media-sound/audacious/ChangeLog8
-rw-r--r--media-sound/audacious/audacious-2.3_alpha2.ebuild63
2 files changed, 70 insertions, 1 deletions
diff --git a/media-sound/audacious/ChangeLog b/media-sound/audacious/ChangeLog
index 6e17f185d769..212474e6171e 100644
--- a/media-sound/audacious/ChangeLog
+++ b/media-sound/audacious/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/audacious
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.194 2010/02/07 14:54:55 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.195 2010/02/09 21:47:20 chainsaw Exp $
+
+*audacious-2.3_alpha2 (09 Feb 2010)
+
+ 09 Feb 2010; <chainsaw@gentoo.org> +audacious-2.3_alpha2.ebuild:
+ New and improved alpha build with debug functionality. Bugs still
+ upstream, thank you.
07 Feb 2010; Raúl Porcel <armin76@gentoo.org> audacious-2.2.ebuild:
sparc stable wrt #295051
diff --git a/media-sound/audacious/audacious-2.3_alpha2.ebuild b/media-sound/audacious/audacious-2.3_alpha2.ebuild
new file mode 100644
index 000000000000..dc81487f1982
--- /dev/null
+++ b/media-sound/audacious/audacious-2.3_alpha2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/audacious-2.3_alpha2.ebuild,v 1.1 2010/02/09 21:47:20 chainsaw Exp $
+
+MY_P="${P/_/-}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
+HOMEPAGE="http://audacious-media-player.org/"
+SRC_URI="http://distfiles.atheme.org/${MY_P}.tgz
+ mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux"
+IUSE="altivec chardet debug nls libsamplerate session sse2"
+
+RDEPEND=">=dev-libs/dbus-glib-0.60
+ >=dev-libs/glib-2.16
+ >=dev-libs/libmcs-0.7.1-r2
+ >=dev-libs/libmowgli-0.7.0
+ dev-libs/libxml2
+ >=x11-libs/cairo-1.2.6
+ >=x11-libs/gtk+-2.14
+ >=x11-libs/pango-1.8.0
+ libsamplerate? ( media-libs/libsamplerate )
+ session? ( x11-libs/libSM )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9.0
+ nls? ( dev-util/intltool )"
+
+PDEPEND=">=media-plugins/audacious-plugins-2.3_alpha2"
+
+src_compile() {
+ # D-Bus is a mandatory dependency, remote control,
+ # session management and some plugins depend on this.
+ # Building without D-Bus is *unsupported* and a USE-flag
+ # will not be added due to the bug reports that will result.
+ # Bugs #197894, #199069, #207330, #208606
+ econf \
+ --enable-dbus \
+ $(use_enable altivec) \
+ $(use_enable chardet) \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_enable session sm) \
+ $(use_enable sse2) \
+ $(use_enable libsamplerate samplerate) \
+ || die
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README
+
+ # Gentoo_ice skin installation; bug #109772
+ insinto /usr/share/audacious/Skins/gentoo_ice
+ doins "${WORKDIR}"/gentoo_ice/*
+ docinto gentoo_ice
+ dodoc "${WORKDIR}"/README
+}