summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2006-10-24 09:56:53 +0000
committerTony Vroon <chainsaw@gentoo.org>2006-10-24 09:56:53 +0000
commit7c7c6e3b05cc26f5b9dad8df6ba67013e49c470d (patch)
treec0b50fd6c3f4b37c4817dd6d5e02c34d3a6f1c6a /media-sound/audacious
parentDon't assume that freebsd == i386 :) Added ~sparc-fbsd keyword. (diff)
downloadgentoo-2-7c7c6e3b05cc26f5b9dad8df6ba67013e49c470d.tar.gz
gentoo-2-7c7c6e3b05cc26f5b9dad8df6ba67013e49c470d.tar.bz2
gentoo-2-7c7c6e3b05cc26f5b9dad8df6ba67013e49c470d.zip
New upstream release. mips lost their keyword over the pulseaudio dependency in audacious-plugins.
(Portage version: 2.1.2_pre3-r7)
Diffstat (limited to 'media-sound/audacious')
-rw-r--r--media-sound/audacious/ChangeLog9
-rw-r--r--media-sound/audacious/audacious-1.2.0.ebuild54
-rw-r--r--media-sound/audacious/audacious-1.2.0_rc1.ebuild4
-rw-r--r--media-sound/audacious/audacious-1.2.0_rc3.ebuild4
-rw-r--r--media-sound/audacious/files/digest-audacious-1.2.06
5 files changed, 72 insertions, 5 deletions
diff --git a/media-sound/audacious/ChangeLog b/media-sound/audacious/ChangeLog
index 9a3eb69e4986..70cc41fd5486 100644
--- a/media-sound/audacious/ChangeLog
+++ b/media-sound/audacious/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/audacious
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.83 2006/10/21 18:43:02 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.84 2006/10/24 09:56:53 chainsaw Exp $
+
+*audacious-1.2.0 (24 Oct 2006)
+
+ 24 Oct 2006; Tony Vroon <chainsaw@gentoo.org> audacious-1.2.0_rc1.ebuild,
+ audacious-1.2.0_rc3.ebuild, +audacious-1.2.0.ebuild:
+ New upstream release. mips lost their keyword over the pulseaudio dependency
+ in audacious-plugins.
21 Oct 2006; Tobias Scherbaum <dertobi123@gentoo.org>
audacious-1.1.2-r1.ebuild:
diff --git a/media-sound/audacious/audacious-1.2.0.ebuild b/media-sound/audacious/audacious-1.2.0.ebuild
new file mode 100644
index 000000000000..ee6abb959c28
--- /dev/null
+++ b/media-sound/audacious/audacious-1.2.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/audacious-1.2.0.ebuild,v 1.1 2006/10/24 09:56:53 chainsaw Exp $
+
+inherit flag-o-matic
+
+MY_P=${P/_/-}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
+HOMEPAGE="http://audacious-media-player.org/"
+SRC_URI="http://audacious-media-player.org/release/${MY_P}.tgz
+ mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="chardet nls gnome"
+
+RDEPEND=">=x11-libs/gtk+-2.6
+ >=gnome-base/libglade-2.3.1
+ dev-libs/libxml2
+ gnome? ( >=gnome-base/gconf-2.6.0 )"
+
+DEPEND="${RDEPEND}
+ nls? ( dev-util/intltool )
+ >=dev-util/pkgconfig-0.9.0"
+
+PDEPEND=">=media-plugins/audacious-plugins-1.2.2"
+
+src_compile() {
+ # Bug #42893
+ replace-flags "-Os" "-O2"
+ # Bug #86689
+ is-flag "-O*" || append-flags -O
+
+ econf \
+ $(use_enable chardet) \
+ $(use_enable nls) \
+ $(use_enable gnome gconf) \
+ || die
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README
+
+ # Gentoo_ice skin installation; bug #109772
+ insinto /usr/share/audacious/Skins/gentoo_ice
+ doins "${WORKDIR}"/gentoo_ice/*
+ docinto gentoo_ice
+ dodoc "${WORKDIR}"/README
+}
diff --git a/media-sound/audacious/audacious-1.2.0_rc1.ebuild b/media-sound/audacious/audacious-1.2.0_rc1.ebuild
index 7da88a418ecd..f31550ad4674 100644
--- a/media-sound/audacious/audacious-1.2.0_rc1.ebuild
+++ b/media-sound/audacious/audacious-1.2.0_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/audacious-1.2.0_rc1.ebuild,v 1.2 2006/10/11 12:11:04 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/audacious-1.2.0_rc1.ebuild,v 1.3 2006/10/24 09:56:53 chainsaw Exp $
inherit flag-o-matic
@@ -13,7 +13,7 @@ SRC_URI="http://audacious-media-player.org/release/${MY_P}.tgz
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
IUSE="chardet nls gnome"
RDEPEND=">=x11-libs/gtk+-2.6
diff --git a/media-sound/audacious/audacious-1.2.0_rc3.ebuild b/media-sound/audacious/audacious-1.2.0_rc3.ebuild
index 22f100a97f49..c64a30a1611f 100644
--- a/media-sound/audacious/audacious-1.2.0_rc3.ebuild
+++ b/media-sound/audacious/audacious-1.2.0_rc3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/audacious-1.2.0_rc3.ebuild,v 1.1 2006/10/12 15:41:16 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/audacious-1.2.0_rc3.ebuild,v 1.2 2006/10/24 09:56:53 chainsaw Exp $
inherit flag-o-matic
@@ -13,7 +13,7 @@ SRC_URI="http://audacious-media-player.org/release/${MY_P}.tgz
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
IUSE="chardet nls gnome"
RDEPEND=">=x11-libs/gtk+-2.6
diff --git a/media-sound/audacious/files/digest-audacious-1.2.0 b/media-sound/audacious/files/digest-audacious-1.2.0
new file mode 100644
index 000000000000..e84c2f1ccb80
--- /dev/null
+++ b/media-sound/audacious/files/digest-audacious-1.2.0
@@ -0,0 +1,6 @@
+MD5 146c17b6159e4f59b587e8b1107d48e6 audacious-1.2.0.tgz 1844828
+RMD160 55bec68d9e2ae9162aa8c89849098235efd017ed audacious-1.2.0.tgz 1844828
+SHA256 f90b8ea79ad93561eafd7ed0ddfe50c8f3a3cb5389ba9b832c2699f1b47c4664 audacious-1.2.0.tgz 1844828
+MD5 41eababfa8bad11e9e34e467cdfb86be gentoo_ice-xmms-0.2.tar.bz2 51839
+RMD160 11439cbebf8c6dc5745c8593a79e88303d094544 gentoo_ice-xmms-0.2.tar.bz2 51839
+SHA256 d1be63368b76f4a8b1d5b0e955cd7a77177f56a7f0b828c6603d8fd2836422b1 gentoo_ice-xmms-0.2.tar.bz2 51839