summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2010-01-19 21:59:54 +0000
committerTony Vroon <chainsaw@gentoo.org>2010-01-19 21:59:54 +0000
commit59fdcd1834e0d4b269b353d7419c883734a20786 (patch)
tree1ba081c8c55722a8548a1d059867ee33e273692e /media-sound/audacious
parentUpdate Manifest (diff)
downloadgentoo-2-59fdcd1834e0d4b269b353d7419c883734a20786.tar.gz
gentoo-2-59fdcd1834e0d4b269b353d7419c883734a20786.tar.bz2
gentoo-2-59fdcd1834e0d4b269b353d7419c883734a20786.zip
First alpha of the 2.3 release. Bugs go upstream at http://jira.atheme.org, this is masked for your protection.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/audacious')
-rw-r--r--media-sound/audacious/ChangeLog8
-rw-r--r--media-sound/audacious/audacious-2.3_alpha1.ebuild62
2 files changed, 69 insertions, 1 deletions
diff --git a/media-sound/audacious/ChangeLog b/media-sound/audacious/ChangeLog
index 65eea078efe9..8e5f8ebfa355 100644
--- a/media-sound/audacious/ChangeLog
+++ b/media-sound/audacious/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/audacious
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.190 2010/01/16 14:19:42 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.191 2010/01/19 21:59:54 chainsaw Exp $
+
+*audacious-2.3_alpha1 (19 Jan 2010)
+
+ 19 Jan 2010; <chainsaw@gentoo.org> +audacious-2.3_alpha1.ebuild:
+ First alpha of the 2.3 release. Bugs go upstream at
+ http://jira.atheme.org, this is masked for your protection.
16 Jan 2010; Tobias Klausmann <klausman@gentoo.org> audacious-2.2.ebuild:
Stable on alpha, bug #295051
diff --git a/media-sound/audacious/audacious-2.3_alpha1.ebuild b/media-sound/audacious/audacious-2.3_alpha1.ebuild
new file mode 100644
index 000000000000..80fa5c61037a
--- /dev/null
+++ b/media-sound/audacious/audacious-2.3_alpha1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/audacious-2.3_alpha1.ebuild,v 1.1 2010/01/19 21:59:54 chainsaw Exp $
+
+MY_P="${P/_/-}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
+HOMEPAGE="http://audacious-media-player.org/"
+SRC_URI="http://distfiles.atheme.org/${MY_P}.tgz
+ mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux"
+IUSE="altivec chardet nls libsamplerate session sse2"
+
+RDEPEND=">=dev-libs/dbus-glib-0.60
+ >=dev-libs/glib-2.16
+ >=dev-libs/libmcs-0.7.1-r2
+ >=dev-libs/libmowgli-0.7.0
+ dev-libs/libxml2
+ >=x11-libs/cairo-1.2.6
+ >=x11-libs/gtk+-2.14
+ >=x11-libs/pango-1.8.0
+ libsamplerate? ( media-libs/libsamplerate )
+ session? ( x11-libs/libSM )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9.0
+ nls? ( dev-util/intltool )"
+
+PDEPEND=">=media-plugins/audacious-plugins-2.3_alpha1"
+
+src_compile() {
+ # D-Bus is a mandatory dependency, remote control,
+ # session management and some plugins depend on this.
+ # Building without D-Bus is *unsupported* and a USE-flag
+ # will not be added due to the bug reports that will result.
+ # Bugs #197894, #199069, #207330, #208606
+ econf \
+ --enable-dbus \
+ $(use_enable altivec) \
+ $(use_enable chardet) \
+ $(use_enable nls) \
+ $(use_enable session sm) \
+ $(use_enable sse2) \
+ $(use_enable libsamplerate samplerate) \
+ || die
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README
+
+ # Gentoo_ice skin installation; bug #109772
+ insinto /usr/share/audacious/Skins/gentoo_ice
+ doins "${WORKDIR}"/gentoo_ice/*
+ docinto gentoo_ice
+ dodoc "${WORKDIR}"/README
+}