summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2008-03-14 01:23:20 +0000
committerTony Vroon <chainsaw@gentoo.org>2008-03-14 01:23:20 +0000
commit3e75ddf330487240d80f3c72f84c6d08ec0272a6 (patch)
tree7e453e2fb0a888c4ddbe789a74118bd9d63c3ce4 /media-sound/audacious
parentamd64 stable, bug 208147 (diff)
downloadgentoo-2-3e75ddf330487240d80f3c72f84c6d08ec0272a6.tar.gz
gentoo-2-3e75ddf330487240d80f3c72f84c6d08ec0272a6.tar.bz2
gentoo-2-3e75ddf330487240d80f3c72f84c6d08ec0272a6.zip
Version bump. D-Bus is a mandatory dependency. It will stay that way.
(Portage version: 2.1.4.4)
Diffstat (limited to 'media-sound/audacious')
-rw-r--r--media-sound/audacious/ChangeLog7
-rw-r--r--media-sound/audacious/audacious-1.5.0.ebuild67
2 files changed, 73 insertions, 1 deletions
diff --git a/media-sound/audacious/ChangeLog b/media-sound/audacious/ChangeLog
index c44f93287a5a..64a770006d1d 100644
--- a/media-sound/audacious/ChangeLog
+++ b/media-sound/audacious/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/audacious
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.143 2008/02/02 17:56:56 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.144 2008/03/14 01:23:20 chainsaw Exp $
+
+*audacious-1.5.0 (14 Mar 2008)
+
+ 14 Mar 2008; Tony Vroon <chainsaw@gentoo.org> +audacious-1.5.0.ebuild:
+ Version bump. D-Bus is a mandatory dependency. It will stay that way.
*audacious-1.4.6 (02 Feb 2008)
diff --git a/media-sound/audacious/audacious-1.5.0.ebuild b/media-sound/audacious/audacious-1.5.0.ebuild
new file mode 100644
index 000000000000..ef8ec7bc9fe3
--- /dev/null
+++ b/media-sound/audacious/audacious-1.5.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/audacious-1.5.0.ebuild,v 1.1 2008/03/14 01:23:20 chainsaw Exp $
+
+inherit flag-o-matic
+
+MY_P="${P/_/-}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
+HOMEPAGE="http://audacious-media-player.org/"
+SRC_URI="http://distfiles.atheme.org/${MY_P}.tgz
+ mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="altivec chardet nls libsamplerate sse2"
+
+RDEPEND=">=dev-libs/dbus-glib-0.60
+ libsamplerate? ( media-libs/libsamplerate )
+ >=dev-libs/libmcs-0.7.0
+ >=dev-libs/libmowgli-0.6.1
+ dev-libs/libxml2
+ >=gnome-base/libglade-2.3.1
+ >=x11-libs/gtk+-2.10
+ >=dev-libs/glib-2.14"
+
+DEPEND="${RDEPEND}
+ !media-plugins/audacious-plugins-ugly
+ >=dev-util/pkgconfig-0.9.0
+ nls? ( dev-util/intltool )"
+
+PDEPEND=">=media-plugins/audacious-plugins-1.5.0"
+
+src_compile() {
+ # D-Bus is a mandatory dependency, remote control,
+ # session management and some plugins depend on this.
+ # Building without D-Bus is *unsupported* and a USE-flag
+ # will not be added due to the bug reports that will result.
+ # Bugs #197894, #199069, #207330, #208606
+ econf \
+ --enable-dbus \
+ $(use_enable altivec) \
+ $(use_enable chardet) \
+ $(use_enable nls) \
+ $(use_enable sse2) \
+ $(use_enable libsamplerate samplerate) \
+ || die
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README
+
+ # Gentoo_ice skin installation; bug #109772
+ insinto /usr/share/audacious/Skins/gentoo_ice
+ doins "${WORKDIR}"/gentoo_ice/*
+ docinto gentoo_ice
+ dodoc "${WORKDIR}"/README
+}
+
+pkg_postinst() {
+ elog "Note that you need to recompile *all* third-party plugins for Audacious 1.5"
+ elog "Plugins compiled against 1.3 or 1.4 will not be loaded."
+}