summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-09-04 12:30:34 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-09-04 12:30:34 +0000
commit8184e6cb15fbb435d4d33bb2d8ce3fa44e024a3f (patch)
tree99c4c5bd508e953d8f40bb82375e54609b9f548f /media-sound/ardour
parentx86 stable, bug #380983 (diff)
downloadgentoo-2-8184e6cb15fbb435d4d33bb2d8ce3fa44e024a3f.tar.gz
gentoo-2-8184e6cb15fbb435d4d33bb2d8ce3fa44e024a3f.tar.bz2
gentoo-2-8184e6cb15fbb435d4d33bb2d8ce3fa44e024a3f.zip
fix build with latest libsoundtouch
(Portage version: 2.2.0_alpha53/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/ardour')
-rw-r--r--media-sound/ardour/ChangeLog6
-rw-r--r--media-sound/ardour/ardour-2.8.11-r20.ebuild7
-rw-r--r--media-sound/ardour/files/ardour-2.8.11-soundtouch.patch13
3 files changed, 22 insertions, 4 deletions
diff --git a/media-sound/ardour/ChangeLog b/media-sound/ardour/ChangeLog
index f67da903837a..48097e2bf2fe 100644
--- a/media-sound/ardour/ChangeLog
+++ b/media-sound/ardour/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/ardour
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ChangeLog,v 1.95 2011/07/29 07:23:17 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ChangeLog,v 1.96 2011/09/04 12:30:34 aballier Exp $
+
+ 04 Sep 2011; Alexis Ballier <aballier@gentoo.org> ardour-2.8.11-r20.ebuild,
+ +files/ardour-2.8.11-soundtouch.patch:
+ fix build with latest libsoundtouch
*ardour-2.8.11-r20 (29 Jul 2011)
diff --git a/media-sound/ardour/ardour-2.8.11-r20.ebuild b/media-sound/ardour/ardour-2.8.11-r20.ebuild
index 2b9a407eda74..b79c41f70396 100644
--- a/media-sound/ardour/ardour-2.8.11-r20.ebuild
+++ b/media-sound/ardour/ardour-2.8.11-r20.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ardour-2.8.11-r20.ebuild,v 1.1 2011/07/29 07:23:17 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ardour-2.8.11-r20.ebuild,v 1.2 2011/09/04 12:30:34 aballier Exp $
EAPI=4
inherit eutils flag-o-matic toolchain-funcs scons-utils
@@ -26,7 +26,7 @@ RDEPEND="media-libs/aubio
>=media-libs/libsndfile-1.0.18
>=media-libs/libsamplerate-0.1
>=media-libs/rubberband-1.6.0
- media-libs/libsoundtouch
+ >=media-libs/libsoundtouch-1.6.0
media-libs/flac
media-libs/raptor:2
>=media-libs/liblrdf-0.4.0-r20
@@ -54,7 +54,8 @@ src_prepare() {
"${FILESDIR}"/${P}-syslibs.patch \
"${FILESDIR}"/${P}-type.patch \
"${FILESDIR}"/${P}-ldpath.patch \
- "${FILESDIR}"/${P}-raptor2.patch
+ "${FILESDIR}"/${P}-raptor2.patch \
+ "${FILESDIR}"/${P}-soundtouch.patch
if [[ ($(gcc-major-version) -eq 4 && $(gcc-minor-version) -ge 6) ]]; then
epatch "${FILESDIR}"/${P}-gcc46.patch
diff --git a/media-sound/ardour/files/ardour-2.8.11-soundtouch.patch b/media-sound/ardour/files/ardour-2.8.11-soundtouch.patch
new file mode 100644
index 000000000000..88a86e7f4e91
--- /dev/null
+++ b/media-sound/ardour/files/ardour-2.8.11-soundtouch.patch
@@ -0,0 +1,13 @@
+Index: ardour-2.8.11/SConstruct
+===================================================================
+--- ardour-2.8.11.orig/SConstruct
++++ ardour-2.8.11/SConstruct
+@@ -1063,7 +1063,7 @@ if env['SYSLIBS']:
+
+ # libraries['flowcanvas'] = LibraryInfo(LIBS='flowcanvas', LIBPATH='#/libs/flowcanvas', CPPPATH='#libs/flowcanvas')
+ libraries['soundtouch'] = LibraryInfo()
+- libraries['soundtouch'].ParseConfig ('pkg-config --cflags --libs soundtouch-1.0')
++ libraries['soundtouch'].ParseConfig ('pkg-config --cflags --libs soundtouch')
+ # Comment the previous line and uncomment this for old versions of Debian:
+ #libraries['soundtouch'].ParseConfig ('pkg-config --cflags --libs libSoundTouch')
+