summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-05-31 15:13:42 +0000
committerTim Harder <radhermit@gentoo.org>2012-05-31 15:13:42 +0000
commit77e35a4298dbbe3b80ad9be171103059b3d6841f (patch)
treeb6aee216ff8d68b6735d52935486709047bde053 /media-sound/ardour
parentStable for HPPA (bug #418275). (diff)
downloadgentoo-2-77e35a4298dbbe3b80ad9be171103059b3d6841f.tar.gz
gentoo-2-77e35a4298dbbe3b80ad9be171103059b3d6841f.tar.bz2
gentoo-2-77e35a4298dbbe3b80ad9be171103059b3d6841f.zip
Fix build with gcc-4.7 (bug #414145 by David Kredba).
(Portage version: 2.2.0_alpha108/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/ardour')
-rw-r--r--media-sound/ardour/ChangeLog6
-rw-r--r--media-sound/ardour/ardour-2.8.12.ebuild5
-rw-r--r--media-sound/ardour/files/ardour-2.8.12-gcc47.patch10
3 files changed, 18 insertions, 3 deletions
diff --git a/media-sound/ardour/ChangeLog b/media-sound/ardour/ChangeLog
index 91948f500174..e58d26757aca 100644
--- a/media-sound/ardour/ChangeLog
+++ b/media-sound/ardour/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/ardour
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ChangeLog,v 1.101 2012/05/05 08:05:31 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ChangeLog,v 1.102 2012/05/31 15:13:42 radhermit Exp $
+
+ 31 May 2012; Tim Harder <radhermit@gentoo.org> ardour-2.8.12.ebuild,
+ +files/ardour-2.8.12-gcc47.patch:
+ Fix build with gcc-4.7 (bug #414145 by David Kredba).
05 May 2012; Michał Górny <mgorny@gentoo.org> ardour-2.8.12.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/media-sound/ardour/ardour-2.8.12.ebuild b/media-sound/ardour/ardour-2.8.12.ebuild
index d54e974e092d..9eb0543d4ba8 100644
--- a/media-sound/ardour/ardour-2.8.12.ebuild
+++ b/media-sound/ardour/ardour-2.8.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ardour-2.8.12.ebuild,v 1.3 2012/05/05 08:05:31 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ardour-2.8.12.ebuild,v 1.4 2012/05/31 15:13:42 radhermit Exp $
EAPI=4
inherit eutils flag-o-matic toolchain-funcs scons-utils
@@ -52,7 +52,8 @@ src_prepare() {
epatch \
"${FILESDIR}"/${PN}-2.8.11-flags.patch \
"${FILESDIR}"/${P}-syslibs.patch \
- "${FILESDIR}"/${PN}-2.8.11-soundtouch.patch
+ "${FILESDIR}"/${PN}-2.8.11-soundtouch.patch \
+ "${FILESDIR}"/${P}-gcc47.patch
}
src_compile() {
diff --git a/media-sound/ardour/files/ardour-2.8.12-gcc47.patch b/media-sound/ardour/files/ardour-2.8.12-gcc47.patch
new file mode 100644
index 000000000000..3ae54af5597f
--- /dev/null
+++ b/media-sound/ardour/files/ardour-2.8.12-gcc47.patch
@@ -0,0 +1,10 @@
+--- ardour-2.8.12/libs/pbd/path.cc
++++ ardour-2.8.12/libs/pbd/path.cc
+@@ -17,6 +17,7 @@
+ */
+
+ #include <cerrno>
++#include <unistd.h>
+
+ #include <glib.h>
+ #include <glib/gstdio.h>