summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-06-15 11:09:43 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-06-15 11:09:43 +0000
commit29639abe57fbcb2fc35b30766616627143eb6778 (patch)
tree8d3ae2cb6aff271e0e30d47fbdb86b7884a2a5bd /media-sound/apetag
parentrevbump, include fix for security bug #227105 (diff)
downloadgentoo-2-29639abe57fbcb2fc35b30766616627143eb6778.tar.gz
gentoo-2-29639abe57fbcb2fc35b30766616627143eb6778.tar.bz2
gentoo-2-29639abe57fbcb2fc35b30766616627143eb6778.zip
Bump wrt 227109. Fix gcc-4.3 compilation and nitpicks. Use user LDFLAGS. Don't include html and css docs, since they're outdated. Update license, now using GPL-3. Remove old.
(Portage version: 2.1.5.5)
Diffstat (limited to 'media-sound/apetag')
-rw-r--r--media-sound/apetag/ChangeLog12
-rw-r--r--media-sound/apetag/apetag-1.10.ebuild40
-rw-r--r--media-sound/apetag/apetag-1.8.ebuild36
-rw-r--r--media-sound/apetag/files/apetag-1.10-gcc43.patch44
4 files changed, 94 insertions, 38 deletions
diff --git a/media-sound/apetag/ChangeLog b/media-sound/apetag/ChangeLog
index 649d7f36bb99..8a415d24b8b9 100644
--- a/media-sound/apetag/ChangeLog
+++ b/media-sound/apetag/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-sound/apetag
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/apetag/ChangeLog,v 1.4 2007/01/21 21:12:20 flameeyes Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/apetag/ChangeLog,v 1.5 2008/06/15 11:09:43 loki_val Exp $
+
+*apetag-1.10 (15 Jun 2008)
+
+ 15 Jun 2008; Peter Alfredsen <loki_val@gentoo.org>
+ +files/apetag-1.10-gcc43.patch, -apetag-1.8.ebuild, +apetag-1.10.ebuild:
+ Bump wrt 227109. Fix gcc-4.3 compilation and nitpicks. Use user LDFLAGS.
+ Don't include html and css docs, since they're outdated. Update license,
+ now using GPL-3. Remove old.
*apetag-1.8 (21 Jan 2007)
diff --git a/media-sound/apetag/apetag-1.10.ebuild b/media-sound/apetag/apetag-1.10.ebuild
new file mode 100644
index 000000000000..7672ea129f50
--- /dev/null
+++ b/media-sound/apetag/apetag-1.10.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/apetag/apetag-1.10.ebuild,v 1.1 2008/06/15 11:09:43 loki_val Exp $
+
+inherit eutils toolchain-funcs base
+
+DESCRIPTION="Command-line ape 2.0 tagger"
+HOMEPAGE="http://muth.org/Robert/Apetag/"
+SRC_URI="http://muth.org/Robert/Apetag/${PN}.${PV}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+
+IUSE=""
+
+KEYWORDS="-amd64 ~x86"
+
+DEPEND=""
+RDEPEND="dev-lang/python"
+
+S="${WORKDIR}/Apetag"
+
+PATCHES=( "${FILESDIR}/${P}-gcc43.patch" )
+
+src_unpack() {
+ base_src_unpack
+ sed -i \
+ -e 's,CXXDEBUG,LDFLAGS,g' \
+ Apetag/Makefile \
+ || die "404. Makefile not found."
+}
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" LDFLAGS="${LDFLAGS}" CXXOPT="${CXXFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin apetag || die
+ dobin tagdir.py rmid3tag.py cddb.py || die
+ dodoc 00readme || die
+}
diff --git a/media-sound/apetag/apetag-1.8.ebuild b/media-sound/apetag/apetag-1.8.ebuild
deleted file mode 100644
index 30e680872def..000000000000
--- a/media-sound/apetag/apetag-1.8.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/apetag/apetag-1.8.ebuild,v 1.1 2007/01/21 21:12:20 flameeyes Exp $
-
-IUSE=""
-
-inherit eutils toolchain-funcs
-
-S="${WORKDIR}/Apetag"
-
-DESCRIPTION="Command-line ape 2.0 tagger"
-HOMEPAGE="http://muth.org/Robert/Apetag/"
-SRC_URI="http://muth.org/Robert/Apetag/${PN}.${PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-amd64 ~x86"
-
-DEPEND=""
-RDEPEND="dev-lang/python"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- sed -i -e "s:-e Artist= -e:-p Artist= -p:" main.C || die
-}
-
-src_compile() {
- emake CXX="$(tc-getCXX)" CXXDEBUG="" CXXOPT="${CXXFLAGS}" || die "emake failed"
-}
-
-src_install() {
- dobin apetag || die
- dobin tagdir.py || die
- dodoc 00changes 00readme || die
-}
diff --git a/media-sound/apetag/files/apetag-1.10-gcc43.patch b/media-sound/apetag/files/apetag-1.10-gcc43.patch
new file mode 100644
index 000000000000..8e76f30bfb95
--- /dev/null
+++ b/media-sound/apetag/files/apetag-1.10-gcc43.patch
@@ -0,0 +1,44 @@
+diff -NrU5 Apetag.orig/basic.C Apetag/basic.C
+--- Apetag.orig/basic.C 2008-06-15 12:32:43.000000000 +0200
++++ Apetag/basic.C 2008-06-15 12:46:06.000000000 +0200
+@@ -24,10 +24,11 @@
+ /* ================================================================== */
+
+ using namespace std;
+
+ #include <string>
++#include <cstdlib>
+ #include "basic.H"
+
+ /* ================================================================== */
+ // special imports
+ /* ================================================================== */
+@@ -268,11 +269,11 @@
+ {
+ exit(-1);
+ }
+
+ // ========================================================================
+-LOCALFUN VOID DefaultSignalHandler(int arg)
++LOCALFUN VOID DefaultSignalHandler(int __attribute__((unused)) arg)
+ {
+ if( !has_executed_before )
+ {
+ TraceCallBack();
+ TerminateCallBack();
+diff -NrU5 Apetag.orig/switch.H Apetag/switch.H
+--- Apetag.orig/switch.H 2008-06-15 12:32:43.000000000 +0200
++++ Apetag/switch.H 2008-06-15 12:36:59.000000000 +0200
+@@ -17,10 +17,12 @@
+ */
+
+ #ifndef SWITCH_H
+ #define SWITCH_H
+
++#include <cstdlib>
++
+ typedef enum
+ {
+ SWITCH_TYPE_INVALID,
+ SWITCH_TYPE_BOOL,
+ SWITCH_TYPE_INT32,