summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-03-15 02:32:41 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-03-15 02:32:41 +0000
commit91d381d93db9b679f57ef7d39d2146cee752a1ab (patch)
tree70e6c12061848e0bfab7ea63c457ae0ebc4b385b /media-sound/amsynth
parentInitial commit to close #22217. Ebuild by myself and Patrick Kursawe <phospha... (diff)
downloadgentoo-2-91d381d93db9b679f57ef7d39d2146cee752a1ab.tar.gz
gentoo-2-91d381d93db9b679f57ef7d39d2146cee752a1ab.tar.bz2
gentoo-2-91d381d93db9b679f57ef7d39d2146cee752a1ab.zip
Added patch from bug #44696 to fix missing declaration of pthread_kill.
Diffstat (limited to 'media-sound/amsynth')
-rw-r--r--media-sound/amsynth/ChangeLog6
-rw-r--r--media-sound/amsynth/amsynth-1.0.0.ebuild4
-rw-r--r--media-sound/amsynth/amsynth-1.0_rc4.ebuild4
-rw-r--r--media-sound/amsynth/files/amsynth-pthread.patch10
4 files changed, 21 insertions, 3 deletions
diff --git a/media-sound/amsynth/ChangeLog b/media-sound/amsynth/ChangeLog
index d00de711700f..539af4c464d7 100644
--- a/media-sound/amsynth/ChangeLog
+++ b/media-sound/amsynth/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/amsynth
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amsynth/ChangeLog,v 1.6 2004/03/03 23:12:57 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amsynth/ChangeLog,v 1.7 2004/03/15 02:32:41 eradicator Exp $
+
+ 14 Mar 2004; Jeremy Huddleston <eradicator@gentoo.org> amsynth-1.0.0.ebuild,
+ amsynth-1.0_rc4.ebuild, files/amsynth-pthread.patch:
+ Added patch from bug #44696 to fix missing declaration of pthread_kill.
04 Mar 2004; David Holm <dholm@gentoo.org> amsynth-1.0.0.ebuild:
Added to ~ppc.
diff --git a/media-sound/amsynth/amsynth-1.0.0.ebuild b/media-sound/amsynth/amsynth-1.0.0.ebuild
index 6b036823afda..d02978361ad7 100644
--- a/media-sound/amsynth/amsynth-1.0.0.ebuild
+++ b/media-sound/amsynth/amsynth-1.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amsynth/amsynth-1.0.0.ebuild,v 1.2 2004/03/03 23:12:57 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amsynth/amsynth-1.0.0.ebuild,v 1.3 2004/03/15 02:32:41 eradicator Exp $
MY_P=${P/_rc/-rc}
MY_P=${MY_P/amsynth/amSynth}
@@ -31,6 +31,8 @@ src_unpack() {
sed -i "/#include <alsa\\/asoundlib.h>/i\\#define ALSA_PCM_OLD_HW_PARAMS_API 1\\" src/drivers/ALSAmmapAudioDriver.h
sed -i "/#include <alsa\\/asoundlib.h>/i\\#define ALSA_PCM_OLD_HW_PARAMS_API 1\\" src/drivers/ALSAAudioDriver.h
+
+ epatch ${FILESDIR}/${PN}-pthread.patch
}
src_compile() {
diff --git a/media-sound/amsynth/amsynth-1.0_rc4.ebuild b/media-sound/amsynth/amsynth-1.0_rc4.ebuild
index f4139973d6c2..f80a394baae6 100644
--- a/media-sound/amsynth/amsynth-1.0_rc4.ebuild
+++ b/media-sound/amsynth/amsynth-1.0_rc4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amsynth/amsynth-1.0_rc4.ebuild,v 1.2 2004/03/03 04:11:26 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amsynth/amsynth-1.0_rc4.ebuild,v 1.3 2004/03/15 02:32:41 eradicator Exp $
MY_P=${P/_rc/-rc}
MY_P=${MY_P/amsynth/amSynth}
@@ -31,6 +31,8 @@ src_unpack() {
sed -i "/#include <alsa\\/asoundlib.h>/i\\#define ALSA_PCM_OLD_HW_PARAMS_API 1\\" src/drivers/ALSAmmapAudioDriver.h
sed -i "/#include <alsa\\/asoundlib.h>/i\\#define ALSA_PCM_OLD_HW_PARAMS_API 1\\" src/drivers/ALSAAudioDriver.h
+
+ epatch ${FILESDIR}/${PN}-pthread.patch
}
src_compile() {
diff --git a/media-sound/amsynth/files/amsynth-pthread.patch b/media-sound/amsynth/files/amsynth-pthread.patch
new file mode 100644
index 000000000000..e0d9d6e20e6f
--- /dev/null
+++ b/media-sound/amsynth/files/amsynth-pthread.patch
@@ -0,0 +1,10 @@
+--- src/main.cc.old 2004-03-14 13:45:10.350579816 -0600
++++ src/main.cc 2004-03-14 13:45:39.107208144 -0600
+@@ -7,6 +7,7 @@
+
+ #include <gtk--/main.h>
+ #include <pthread.h>
++#include <signal.h>
+ #include <iostream>
+ #include <fstream>
+ #include <unistd.h>