summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-06-12 18:40:00 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-06-12 18:40:00 +0000
commit606db5977e9b656ea19e2aefad7ea9d4c5712d46 (patch)
tree297c79e3888f5c74ab1638417a17997b5af3a6fd /media-sound/amsynth
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-606db5977e9b656ea19e2aefad7ea9d4c5712d46.tar.gz
gentoo-2-606db5977e9b656ea19e2aefad7ea9d4c5712d46.tar.bz2
gentoo-2-606db5977e9b656ea19e2aefad7ea9d4c5712d46.zip
version bump, bug #320421
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/amsynth')
-rw-r--r--media-sound/amsynth/ChangeLog9
-rw-r--r--media-sound/amsynth/amsynth-1.2.3.ebuild48
2 files changed, 55 insertions, 2 deletions
diff --git a/media-sound/amsynth/ChangeLog b/media-sound/amsynth/ChangeLog
index 89b8b7a4c784..a05c7126cfcc 100644
--- a/media-sound/amsynth/ChangeLog
+++ b/media-sound/amsynth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/amsynth
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amsynth/ChangeLog,v 1.33 2009/08/28 18:18:30 ssuominen Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amsynth/ChangeLog,v 1.34 2010/06/12 18:40:00 aballier Exp $
+
+*amsynth-1.2.3 (12 Jun 2010)
+
+ 12 Jun 2010; Alexis Ballier <aballier@gentoo.org> +amsynth-1.2.3.ebuild:
+ version bump, bug #320421
*amsynth-1.2.2 (28 Aug 2009)
diff --git a/media-sound/amsynth/amsynth-1.2.3.ebuild b/media-sound/amsynth/amsynth-1.2.3.ebuild
new file mode 100644
index 000000000000..3734e2a5f940
--- /dev/null
+++ b/media-sound/amsynth/amsynth-1.2.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amsynth/amsynth-1.2.3.ebuild,v 1.1 2010/06/12 18:40:00 aballier Exp $
+
+EAPI=2
+MY_P=${P/ams/amS}
+
+DESCRIPTION="Virtual analogue synthesizer."
+HOMEPAGE="http://amsynthe.sourceforge.net/"
+SRC_URI="mirror://sourceforge/amsynthe/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="alsa debug jack oss sndfile"
+
+RDEPEND=">=dev-cpp/gtkmm-2.4
+ sndfile? ( >=media-libs/libsndfile-1 )
+ alsa? ( media-libs/alsa-lib
+ media-sound/alsa-utils )
+ jack? ( media-sound/jack-audio-connection-kit )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ econf \
+ $(use_with oss) \
+ $(use_with alsa) \
+ $(use_with jack) \
+ $(use_with sndfile) \
+ $(use_enable debug)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS README
+}
+
+pkg_postinst() {
+ elog
+ elog "amSynth has been installed normally. If you would like to use"
+ elog "the virtual keyboard option, then do:"
+ elog "# emerge vkeybd"
+ elog "and make sure you emerged amSynth with alsa support (USE=alsa)"
+ elog
+}