summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-03-03 04:11:26 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-03-03 04:11:26 +0000
commitfd2b6fc74418e147b222a038f85c3912c9164c9c (patch)
tree166a3539cbea4f0d6c5accb03b42a63dbd8f88cc /media-sound/amsynth/amsynth-1.0.0.ebuild
parentmetadata.xml (Manifest recommit) (diff)
downloadgentoo-2-fd2b6fc74418e147b222a038f85c3912c9164c9c.tar.gz
gentoo-2-fd2b6fc74418e147b222a038f85c3912c9164c9c.tar.bz2
gentoo-2-fd2b6fc74418e147b222a038f85c3912c9164c9c.zip
Version bump closes bug #43496.
Diffstat (limited to 'media-sound/amsynth/amsynth-1.0.0.ebuild')
-rw-r--r--media-sound/amsynth/amsynth-1.0.0.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/media-sound/amsynth/amsynth-1.0.0.ebuild b/media-sound/amsynth/amsynth-1.0.0.ebuild
new file mode 100644
index 000000000000..b6a81f5e3705
--- /dev/null
+++ b/media-sound/amsynth/amsynth-1.0.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amsynth/amsynth-1.0.0.ebuild,v 1.1 2004/03/03 04:11:26 eradicator Exp $
+
+MY_P=${P/_rc/-rc}
+MY_P=${MY_P/amsynth/amSynth}
+
+DESCRIPTION="A retro analogue - modelling softsynth"
+HOMEPAGE="http://amsynthe.sourceforge.net/"
+SRC_URI="mirror://sourceforge/amsynthe/${MY_P}.tar.gz"
+RESTRICT="nomirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="oss alsa jack"
+
+# libsndfile support is actually optional, but IMHO this package should have it
+DEPEND="=dev-cpp/gtkmm-1.2* \
+ media-libs/libsndfile \
+ alsa? ( media-libs/alsa-lib \
+ media-sound/alsa-utils ) \
+ jack? ( virtual/jack )"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i "/#include <alsa\\/asoundlib.h>/i\\#define ALSA_PCM_OLD_HW_PARAMS_API 1\\" src/drivers/ALSAmmapAudioDriver.h
+ sed -i "/#include <alsa\\/asoundlib.h>/i\\#define ALSA_PCM_OLD_HW_PARAMS_API 1\\" src/drivers/ALSAAudioDriver.h
+}
+
+src_compile() {
+ econf `use_with oss` `use_with alsa` `use_with jack` || die "configure failed"
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "amSynth has been installed normally."
+ einfo "If you would like to use the virtual"
+ einfo "keyboard option, then do"
+ einfo "emerge vkeybd"
+ einfo "and make sure you emerged amSynth"
+ einfo "with alsa support (USE=alsa)"
+ einfo ""
+}