summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-03-20 23:08:25 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-03-20 23:08:25 +0000
commit1fd0161682ab123fbb49bc7e3fd9d06543c53dd4 (patch)
tree5d8c7c1a4201946003c60eddd7c79d00c1c6da96 /media-sound/amarokfs
parentsmall bugfix release (diff)
downloadgentoo-2-1fd0161682ab123fbb49bc7e3fd9d06543c53dd4.tar.gz
gentoo-2-1fd0161682ab123fbb49bc7e3fd9d06543c53dd4.tar.bz2
gentoo-2-1fd0161682ab123fbb49bc7e3fd9d06543c53dd4.zip
version bump thanks to Elias Probst <elias.probst@gmx.de> in bug 171463
(Portage version: 2.1.2.2)
Diffstat (limited to 'media-sound/amarokfs')
-rw-r--r--media-sound/amarokfs/ChangeLog7
-rw-r--r--media-sound/amarokfs/amarokfs-0.5.ebuild49
-rw-r--r--media-sound/amarokfs/files/digest-amarokfs-0.53
3 files changed, 58 insertions, 1 deletions
diff --git a/media-sound/amarokfs/ChangeLog b/media-sound/amarokfs/ChangeLog
index 98c89b2b1e5d..faddd815ee01 100644
--- a/media-sound/amarokfs/ChangeLog
+++ b/media-sound/amarokfs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/amarokfs
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarokfs/ChangeLog,v 1.3 2007/02/21 09:17:20 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarokfs/ChangeLog,v 1.4 2007/03/20 23:08:25 genstef Exp $
+
+*amarokfs-0.5 (20 Mar 2007)
+
+ 20 Mar 2007; <stefan@gentoo.org> +amarokfs-0.5.ebuild:
+ version bump thanks to Elias Probst <elias.probst@gmx.de> in bug 171463
21 Feb 2007; Christian Faulhammer <opfer@gentoo.org>
amarokfs-0.4.2.ebuild:
diff --git a/media-sound/amarokfs/amarokfs-0.5.ebuild b/media-sound/amarokfs/amarokfs-0.5.ebuild
new file mode 100644
index 000000000000..bbcb6f5993c5
--- /dev/null
+++ b/media-sound/amarokfs/amarokfs-0.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarokfs/amarokfs-0.5.ebuild,v 1.1 2007/03/20 23:08:25 genstef Exp $
+
+inherit qt3 kde-functions toolchain-funcs
+
+need-kde 3
+
+MY_PN="${PN/fs/FS}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A full screen frontend for Amarok."
+HOMEPAGE="http://www.kde-apps.org/content/show.php?content=52641"
+SRC_URI="http://www.kde-apps.org/CONTENT/content-files/52641-${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+
+IUSE=""
+
+RDEPEND="media-sound/amarok"
+DEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+
+ sed -i -e 's:/usr/local/:/usr/:' "${S}"/*.{pro,cpp} || die "sed for /usr/local failed."
+ sed -i -e "s:Icon=.*:Icon=${MY_PN}:" "${S}/${MY_PN}.desktop" || die "fix desktop file failed."
+ sed -i -e 's:/usr/share/icons/:\0hicolor/128x128/apps/:' "${S}/${MY_PN}-xml.pro" || die "fix icon installation failed"
+ sed -i -e '/qDebug/s:" + \(func\|query\):%s", \1.data():' "${S}"/*.cpp || die "fix for qDebug() calls failed."
+}
+
+src_compile() {
+ ${QTDIR}/bin/qmake QMAKE="${QTDIR}/bin/qmake" || die "qmake failed"
+ sed -i -e '/strip/d' Makefile || die "fix stripping failed."
+ emake \
+ CC="$(tc-getCC) ${CFLAGS}" \
+ CXX="$(tc-getCXX) ${CXXFLAGS}" \
+ LINK="$(tc-getCXX) ${LDFLAGS}" \
+ || die "emake failed"
+}
+
+src_install() {
+ emake -j1 INSTALL_ROOT="${D}" install || die "emake install failed"
+}
diff --git a/media-sound/amarokfs/files/digest-amarokfs-0.5 b/media-sound/amarokfs/files/digest-amarokfs-0.5
new file mode 100644
index 000000000000..7af299515aa4
--- /dev/null
+++ b/media-sound/amarokfs/files/digest-amarokfs-0.5
@@ -0,0 +1,3 @@
+MD5 28b7432fa9abfb0a2211940990b3945a 52641-amarokFS-0.5.tar.gz 373310
+RMD160 ea2052c4114c1db21e5f727bd9d3c96caddd97d4 52641-amarokFS-0.5.tar.gz 373310
+SHA256 52ee9b21d18b7d76999b25c1de3077d3f2ae774b18b8eca3d9605ceaf340cafc 52641-amarokFS-0.5.tar.gz 373310