summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2009-10-02 01:11:48 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2009-10-02 01:11:48 +0000
commit604ab932e9f8a5cf459db279d22846bbb15a117c (patch)
tree1a59ee4602a606e1415f13707b70c464d301264d /media-sound/amarok
parentSet SUPPORT_PYTHON_ABIS. (diff)
downloadgentoo-2-604ab932e9f8a5cf459db279d22846bbb15a117c.tar.gz
gentoo-2-604ab932e9f8a5cf459db279d22846bbb15a117c.tar.bz2
gentoo-2-604ab932e9f8a5cf459db279d22846bbb15a117c.zip
Bumped amarok to version 2.2.0.
(Portage version: 2.2_rc42/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/amarok')
-rw-r--r--media-sound/amarok/ChangeLog8
-rw-r--r--media-sound/amarok/amarok-2.2.0.ebuild101
-rw-r--r--media-sound/amarok/metadata.xml16
3 files changed, 117 insertions, 8 deletions
diff --git a/media-sound/amarok/ChangeLog b/media-sound/amarok/ChangeLog
index 2a752df03ba5..2c2794ac1bd2 100644
--- a/media-sound/amarok/ChangeLog
+++ b/media-sound/amarok/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/amarok
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.339 2009/09/27 15:29:40 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.340 2009/10/02 01:11:48 jmbsvicetto Exp $
+
+*amarok-2.2.0 (02 Oct 2009)
+
+ 02 Oct 2009; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ +amarok-2.2.0.ebuild, metadata.xml:
+ Bumped amarok to version 2.2.0.
27 Sep 2009; Brent Baude <ranger@gentoo.org>
amarok-1.4.10_p20090130-r3.ebuild:
diff --git a/media-sound/amarok/amarok-2.2.0.ebuild b/media-sound/amarok/amarok-2.2.0.ebuild
new file mode 100644
index 000000000000..c64e3233ff9b
--- /dev/null
+++ b/media-sound/amarok/amarok-2.2.0.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-2.2.0.ebuild,v 1.1 2009/10/02 01:11:48 jmbsvicetto Exp $
+
+EAPI="2"
+
+# Translations are only in the tarballs, not the git repo
+if [[ ${PV} != *9999* ]]; then
+ KDE_LINGUAS="bg ca cs da de en_GB es et eu fi fr it ja km nb nds nl
+ pa pl pt pt_BR ru sl sr sr@latin sv th tr uk wa zh_TW"
+else
+ EGIT_REPO_URI="git://gitorious.org/${PN}/${PN}.git"
+ GIT_ECLASS="git"
+fi
+OPENGL_REQUIRED="optional"
+inherit kde4-base ${GIT_ECLASS}
+
+DESCRIPTION="Advanced audio player based on KDE framework."
+HOMEPAGE="http://amarok.kde.org/"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+else
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.bz2"
+fi
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="4"
+IUSE="cdda daap debug ipod lastfm mp3tunes mtp +semantic-desktop"
+
+# ipod requires gdk enabled and also gtk compiled in libgpod
+DEPEND="
+ >=app-misc/strigi-0.5.7
+ || (
+ >=dev-db/mysql-5.0.76-r1[embedded,-minimal]
+ >=dev-db/mysql-community-5.0.77-r1[embedded,-minimal]
+ )
+ >=media-libs/taglib-1.6
+ >=media-libs/taglib-extras-1.0.1
+ >=kde-base/kdelibs-${KDE_MINIMAL}[opengl?,semantic-desktop?]
+ sys-libs/zlib
+ >=x11-libs/qtscriptgenerator-0.1.0
+ cdda? (
+ >=kde-base/libkcddb-${KDE_MINIMAL}
+ >=kde-base/libkcompactdisc-${KDE_MINIMAL}
+ )
+ ipod? ( >=media-libs/libgpod-0.7.0[gtk] )
+ lastfm? ( >=media-libs/liblastfm-0.3.0 )
+ mp3tunes? (
+ dev-libs/glib:2
+ dev-libs/libxml2
+ dev-libs/openssl
+ net-libs/loudmouth
+ net-misc/curl
+ x11-libs/qt-core[glib]
+ )
+ mtp? ( >=media-libs/libmtp-0.3.0 )
+"
+RDEPEND="${DEPEND}
+ >=kde-base/phonon-kde-${KDE_MINIMAL}
+ >=media-sound/amarok-utils-${PV}
+ semantic-desktop? ( >=kde-base/nepomuk-${KDE_MINIMAL} )
+"
+
+PATCHES=( "${FILESDIR}/disable_bindings_test.patch" )
+
+# Only really required for live ebuild, to skip git_src_prepare
+src_prepare() {
+ kde4-base_src_prepare
+}
+
+src_configure() {
+ # Workaround for problems related to libmysqld.so and collection plugin not
+ # being found on some architectures when --as-needed is not used.
+ append-ldflags -Wl,--as-needed
+
+ mycmakeargs="${mycmakeargs}
+ -DWITH_PLAYER=ON
+ -DWITH_UTILITIES=OFF
+ -DWITH_Libgcrypt=OFF
+ $(cmake-utils_use_with ipod)
+ $(cmake-utils_use_with ipod Gdk)
+ $(cmake-utils_use_with lastfm LibLastFm)
+ $(cmake-utils_use_with mtp)
+ $(cmake-utils_use_with mp3tunes MP3Tunes)"
+# $(cmake-utils_use_with semantic-desktop Nepomuk)
+# $(cmake-utils_use_with semantic-desktop Soprano)"
+
+ kde4-base_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ if use daap; then
+ echo
+ elog "You have installed amarok with daap support."
+ elog "You may be interested in installing www-servers/mongrel as well."
+ echo
+ fi
+}
diff --git a/media-sound/amarok/metadata.xml b/media-sound/amarok/metadata.xml
index ae740bc9a15f..f4b3bbd66e93 100644
--- a/media-sound/amarok/metadata.xml
+++ b/media-sound/amarok/metadata.xml
@@ -9,13 +9,13 @@
<use>
<flag name="amazon">Enable support for downloading covers from amazon.com</flag>
<flag name="daap">
- Enable the scripts for music sharing through DAAP. This flag
- adds dependencies on <pkg>www-servers/mongrel</pkg> to allow
- sharing of the Amarok music collection through DAAP
- protocol. Please note that turning this flag off has no effect
- on DAAP browsing.
+ Enable the scripts for music sharing through DAAP. This flag adds
+ dependencies on <pkg>www-servers/mongrel</pkg> to allow sharing of
+ the Amarok music collection through DAAP protocol. Please note
+ that turning this flag off has no effect on DAAP browsing.
</flag>
<flag name="ifp">Enable support for iRiver devices access through libifp</flag>
+ <flag name="lastfm">Enable Last.fm streaming services support through <pkg>media-libs/liblastfm</pkg></flag>
<flag name="mp3tunes">Enable mp3tunes integration</flag>
<flag name="mp4">
Build the TagLib plugin for writing tags in Mp4 container files
@@ -35,10 +35,12 @@
<pkg>media-video/realplayer</pkg>. This is an alternative engine
to the xine one, which supports a different set of formats. Only
available for x86 architecture as it uses the binary version of
- RealPlayer. Plase note that by enabling this USE flag, the resulting
+ RealPlayer. Please note that by enabling this USE flag, the resulting
package will not be redistributable, as it links to the non-GPL compatible
RealPlayer.
</flag>
- <flag name="visualization">Support visualization plugins through <pkg>media-libs/libvisual</pkg></flag>
+ <flag name="visualization">
+ Support visualization plugins through <pkg>media-libs/libvisual</pkg>
+ </flag>
</use>
</pkgmetadata>