summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2010-02-19 16:58:53 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2010-02-19 16:58:53 +0000
commit4cdc86a19270f34fe44cc049b579b7c60b35acf7 (patch)
tree845921682e3185c5f760f6f541463030e9ebcb2a /media-sound/amarok
parentRev-bumped amarok-utils-2.2.2 to fix the deps and to ask for a quick stabiliz... (diff)
downloadgentoo-2-4cdc86a19270f34fe44cc049b579b7c60b35acf7.tar.gz
gentoo-2-4cdc86a19270f34fe44cc049b579b7c60b35acf7.tar.bz2
gentoo-2-4cdc86a19270f34fe44cc049b579b7c60b35acf7.zip
Rev-bumped amarok-2.2.2 to fix the deps and to ask for a quick stabilization.
Fixed strigi deps (bug 304883) - thanks to Samuli. Dropped the bindist use flag and added a hard dep on taglib[asf,mp4] (bug 299899) - thanks to Jeff Mitchell (jefferai). (Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/amarok')
-rw-r--r--media-sound/amarok/ChangeLog12
-rw-r--r--media-sound/amarok/amarok-2.2.2-r1.ebuild102
2 files changed, 113 insertions, 1 deletions
diff --git a/media-sound/amarok/ChangeLog b/media-sound/amarok/ChangeLog
index e0a1242f8652..2f2343fe3e85 100644
--- a/media-sound/amarok/ChangeLog
+++ b/media-sound/amarok/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for media-sound/amarok
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.357 2010/02/19 16:46:26 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.358 2010/02/19 16:58:53 jmbsvicetto Exp $
+
+*amarok-2.2.2-r1 (19 Feb 2010)
+
+ 19 Feb 2010; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ +amarok-2.2.2-r1.ebuild:
+ Rev-bumped amarok-2.2.2 to fix the deps and to ask for a quick
+ stabilization.
+ Fixed strigi deps (bug 304883) - thanks to Samuli.
+ Dropped the bindist use flag and added a hard dep on taglib[asf,mp4] (bug
+ 299899) - thanks to Jeff Mitchell (jefferai).
19 Feb 2010; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
-amarok-2.2.1.ebuild, -amarok-2.2.1-r1.ebuild, -amarok-2.2.1-r2.ebuild,
diff --git a/media-sound/amarok/amarok-2.2.2-r1.ebuild b/media-sound/amarok/amarok-2.2.2-r1.ebuild
new file mode 100644
index 000000000000..aa6e05e0685c
--- /dev/null
+++ b/media-sound/amarok/amarok-2.2.2-r1.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-2.2.2-r1.ebuild,v 1.1 2010/02/19 16:58:53 jmbsvicetto Exp $
+
+EAPI="2"
+
+# Translations are only in the tarballs, not the git repo
+if [[ ${PV} != *9999* ]]; then
+ KDE_LINGUAS="bg ca cs da de en_GB es et eu fi fr it ja km nb nds nl
+ pa pl pt pt_BR ru sl sr sr@latin sv th tr uk wa zh_TW"
+else
+ EGIT_REPO_URI="git://gitorious.org/${PN}/${PN}.git"
+ GIT_ECLASS="git"
+fi
+OPENGL_REQUIRED="optional"
+inherit kde4-base ${GIT_ECLASS}
+
+DESCRIPTION="Advanced audio player based on KDE framework."
+HOMEPAGE="http://amarok.kde.org/"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+else
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.bz2"
+fi
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="4"
+IUSE="cdda daap debug +embedded ipod lastfm mp3tunes mtp semantic-desktop"
+
+# ipod requires gdk enabled and also gtk compiled in libgpod
+DEPEND="
+ app-crypt/qca:2
+ >=app-misc/strigi-0.5.7[dbus,qt4]
+ || (
+ >=dev-db/mysql-5.0.76-r1[embedded?,-minimal]
+ >=dev-db/mysql-community-5.0.77-r1[embedded?,-minimal]
+ )
+ >=media-libs/taglib-1.6.1[asf,mp4]
+ >=media-libs/taglib-extras-1.0.1
+ >=kde-base/kdelibs-${KDE_MINIMAL}[opengl?,semantic-desktop?]
+ sys-libs/zlib
+ x11-libs/qt-script
+ >=x11-libs/qtscriptgenerator-0.1.0
+ cdda? (
+ >=kde-base/libkcddb-${KDE_MINIMAL}
+ >=kde-base/libkcompactdisc-${KDE_MINIMAL}
+ >=kde-base/kdemultimedia-kioslaves-${KDE_MINIMAL}
+ )
+ ipod? ( >=media-libs/libgpod-0.7.0[gtk] )
+ lastfm? ( >=media-libs/liblastfm-0.3.0 )
+ mp3tunes? (
+ dev-libs/glib:2
+ dev-libs/libxml2
+ dev-libs/openssl
+ net-libs/loudmouth
+ net-misc/curl
+ x11-libs/qt-core[glib]
+ )
+ mtp? ( >=media-libs/libmtp-0.3.0 )
+"
+RDEPEND="${DEPEND}
+ >=kde-base/phonon-kde-${KDE_MINIMAL}
+ >=media-sound/amarok-utils-${PV}
+ semantic-desktop? ( >=kde-base/nepomuk-${KDE_MINIMAL} )
+"
+
+PATCHES=( "${FILESDIR}/${P}-nodebug.patch" )
+
+# Only really required for live ebuild, to skip git_src_prepare
+src_prepare() {
+ kde4-base_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_PLAYER=ON
+ -DWITH_UTILITIES=OFF
+ -DWITH_Libgcrypt=OFF
+ $(cmake-utils_use embedded WITH_MYSQL_EMBEDDED)
+ $(cmake-utils_use_with ipod)
+ $(cmake-utils_use_with ipod Gdk)
+ $(cmake-utils_use_with lastfm LibLastFm)
+ $(cmake-utils_use_with mtp)
+ $(cmake-utils_use_with mp3tunes MP3Tunes)
+ )
+ # $(cmake-utils_use_with semantic-desktop Nepomuk)
+ # $(cmake-utils_use_with semantic-desktop Soprano)
+
+ kde4-base_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ if use daap; then
+ echo
+ elog "You have installed amarok with daap support."
+ elog "You may be interested in installing www-servers/mongrel as well."
+ echo
+ fi
+}