summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2010-01-08 15:50:10 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2010-01-08 15:50:10 +0000
commit9524edf0187cf16cda79edcd332b73f85ef739ff (patch)
tree06b812d0f4c3bebe2c2f34901ae9b5cbd6887468 /media-sound/amarok-utils
parentVersion bump (diff)
downloadgentoo-2-9524edf0187cf16cda79edcd332b73f85ef739ff.tar.gz
gentoo-2-9524edf0187cf16cda79edcd332b73f85ef739ff.tar.bz2
gentoo-2-9524edf0187cf16cda79edcd332b73f85ef739ff.zip
Bumped amarok-utils to 2.2.2 (should be out next Monday).
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/amarok-utils')
-rw-r--r--media-sound/amarok-utils/ChangeLog10
-rw-r--r--media-sound/amarok-utils/amarok-utils-2.2.2.ebuild65
2 files changed, 73 insertions, 2 deletions
diff --git a/media-sound/amarok-utils/ChangeLog b/media-sound/amarok-utils/ChangeLog
index 224bcd40c561..3cd79ba2dc1f 100644
--- a/media-sound/amarok-utils/ChangeLog
+++ b/media-sound/amarok-utils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/amarok-utils
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok-utils/ChangeLog,v 1.11 2009/12/16 00:40:09 tampakrap Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok-utils/ChangeLog,v 1.12 2010/01/08 15:50:10 jmbsvicetto Exp $
+
+*amarok-utils-2.2.2 (08 Jan 2010)
+
+ 08 Jan 2010; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ +amarok-utils-2.2.2.ebuild:
+ Bumped amarok-utils to 2.2.2 (should be out next Monday).
*amarok-utils-2.2.1.90 (16 Dec 2009)
diff --git a/media-sound/amarok-utils/amarok-utils-2.2.2.ebuild b/media-sound/amarok-utils/amarok-utils-2.2.2.ebuild
new file mode 100644
index 000000000000..f2b0c84f068a
--- /dev/null
+++ b/media-sound/amarok-utils/amarok-utils-2.2.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok-utils/amarok-utils-2.2.2.ebuild,v 1.1 2010/01/08 15:50:10 jmbsvicetto Exp $
+
+EAPI="2"
+
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS="git"
+ EGIT_PROJECT="amarok"
+ EGIT_REPO_URI="git://gitorious.org/amarok/amarok.git"
+fi
+
+inherit base cmake-utils ${GIT_ECLASS}
+
+MY_PN="amarok"
+
+DESCRIPTION="Various utility programs for Amarok."
+HOMEPAGE="http://amarok.kde.org/"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+else
+ SRC_URI="mirror://kde/unstable/${MY_PN}/${PV}/src/${MY_PN}-${PV}.tar.bz2"
+fi
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="4"
+IUSE="bindist debug"
+
+DEPEND="
+ >=media-libs/taglib-extras-1.0.1
+ >=x11-libs/qt-core-4.4:4
+ >=x11-libs/qt-dbus-4.4:4
+ bindist? ( >=media-libs/taglib-1.6.1[-asf,-mp4] )
+ !bindist? ( >=media-libs/taglib-1.6.1[asf,mp4] )
+"
+RDEPEND="${DEPEND}
+ !<media-sound/amarok-2.1.80:2
+ !<media-sound/amarok-2.1.80:${SLOT}
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+DOCS="TODO README ChangeLog AUTHORS"
+
+src_prepare() {
+ # Disable po processing
+ sed -e "s:include(MacroOptionalAddSubdirectory)::" \
+ -i "${S}/CMakeLists.txt" \
+ || die "Removing include of MacroOptionalAddSubdirectory failed."
+ sed -e "s:macro_optional_add_subdirectory( po )::" \
+ -i "${S}/CMakeLists.txt" \
+ || die "Removing include of MacroOptionalAddSubdirectory failed."
+
+ base_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_PLAYER=OFF
+ -DWITH_UTILITIES=ON
+ )
+
+ cmake-utils_src_configure
+}