summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-05-27 14:55:22 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-05-27 14:55:22 +0000
commit7e9e38a83b805c7b34a1213f4f67187b9adbf2e9 (patch)
treef388f9bd3c40e02ccc37e2239496652fbb8c8fa0 /media-sound/alsa-utils
parentrevbump; migrate -> distutils-r1, add missing test phase, drop old ebuilds (diff)
downloadgentoo-2-7e9e38a83b805c7b34a1213f4f67187b9adbf2e9.tar.gz
gentoo-2-7e9e38a83b805c7b34a1213f4f67187b9adbf2e9.tar.bz2
gentoo-2-7e9e38a83b805c7b34a1213f4f67187b9adbf2e9.zip
Include upstreamized patch for "hctl element search" wrt #468690 by William Throwe and Jaroslav Kysela
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'media-sound/alsa-utils')
-rw-r--r--media-sound/alsa-utils/ChangeLog10
-rw-r--r--media-sound/alsa-utils/alsa-utils-1.0.27.1-r1.ebuild79
-rw-r--r--media-sound/alsa-utils/files/alsa-utils-1.0.27.1-hctl_elem_search.patch25
3 files changed, 113 insertions, 1 deletions
diff --git a/media-sound/alsa-utils/ChangeLog b/media-sound/alsa-utils/ChangeLog
index 0c8c85ac4da5..ed90d0f4f1c7 100644
--- a/media-sound/alsa-utils/ChangeLog
+++ b/media-sound/alsa-utils/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-sound/alsa-utils
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.350 2013/05/27 13:59:35 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.351 2013/05/27 14:55:22 ssuominen Exp $
+
+*alsa-utils-1.0.27.1-r1 (27 May 2013)
+
+ 27 May 2013; Samuli Suominen <ssuominen@gentoo.org>
+ +alsa-utils-1.0.27.1-r1.ebuild,
+ +files/alsa-utils-1.0.27.1-hctl_elem_search.patch:
+ Include upstreamized patch for "hctl element search" wrt #468690 by William
+ Throwe and Jaroslav Kysela
*alsa-utils-1.0.27.1 (27 May 2013)
diff --git a/media-sound/alsa-utils/alsa-utils-1.0.27.1-r1.ebuild b/media-sound/alsa-utils/alsa-utils-1.0.27.1-r1.ebuild
new file mode 100644
index 000000000000..3b6c982a5d27
--- /dev/null
+++ b/media-sound/alsa-utils/alsa-utils-1.0.27.1-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/alsa-utils-1.0.27.1-r1.ebuild,v 1.1 2013/05/27 14:55:22 ssuominen Exp $
+
+EAPI=5
+inherit eutils systemd udev
+
+DESCRIPTION="Advanced Linux Sound Architecture Utils (alsactl, alsamixer, etc.)"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/utils/${P}.tar.bz2
+ mirror://alsaproject/driver/alsa-driver-1.0.25.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0.9"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="doc +libsamplerate +ncurses nls selinux"
+
+RDEPEND=">=media-libs/alsa-lib-1.0.27-r2
+ libsamplerate? ( media-libs/libsamplerate )
+ ncurses? ( >=sys-libs/ncurses-5.7-r7 )
+ selinux? ( sec-policy/selinux-alsa )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-text/xmlto )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-hctl_elem_search.patch
+ epatch_user
+}
+
+src_configure() {
+ local myconf
+ use doc || myconf='--disable-xmlto'
+
+ # --disable-alsaconf because it doesn't work with sys-apps/kmod wrt #456214
+ econf \
+ --disable-maintainer-mode \
+ $(use_enable libsamplerate alsaloop) \
+ $(use_enable nls) \
+ $(use_enable ncurses alsamixer) \
+ --disable-alsaconf \
+ "$(systemd_with_unitdir)" \
+ --with-udev-rules-dir="$(get_udevdir)"/rules.d \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc ChangeLog README TODO seq/*/README.*
+
+ newbin "${WORKDIR}"/alsa-driver-*/utils/alsa-info.sh alsa-info
+
+ newinitd "${FILESDIR}"/alsasound.initd-r5 alsasound
+ newconfd "${FILESDIR}"/alsasound.confd-r4 alsasound
+
+ insinto /etc/modprobe.d
+ newins "${FILESDIR}"/alsa-modules.conf-rc alsa.conf
+
+ keepdir /var/lib/alsa
+
+ # ALSA lib parser.c:1266:(uc_mgr_scan_master_configs) error: could not
+ # scan directory /usr/share/alsa/ucm: No such file or directory
+ # alsaucm: unable to obtain card list: No such file or directory
+ keepdir /usr/share/alsa/ucm
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog
+ elog "To take advantage of the init script, and automate the process of"
+ elog "saving and restoring sound-card mixer levels you should"
+ elog "add alsasound to the boot runlevel. You can do this as"
+ elog "root like so:"
+ elog "# rc-update add alsasound boot"
+ ewarn
+ ewarn "The ALSA core should be built into the kernel or loaded through other"
+ ewarn "means. There is no longer any modular auto(un)loading in alsa-utils."
+ fi
+}
diff --git a/media-sound/alsa-utils/files/alsa-utils-1.0.27.1-hctl_elem_search.patch b/media-sound/alsa-utils/files/alsa-utils-1.0.27.1-hctl_elem_search.patch
new file mode 100644
index 000000000000..6cff1d5576d7
--- /dev/null
+++ b/media-sound/alsa-utils/files/alsa-utils-1.0.27.1-hctl_elem_search.patch
@@ -0,0 +1,25 @@
+From d61924fd247c2cf0280391e076c439c9427732aa Mon Sep 17 00:00:00 2001
+From: Jaroslav Kysela <perex@perex.cz>
+Date: Mon, 27 May 2013 16:40:26 +0200
+Subject: [PATCH] amixer: Fix the hctl elem search bug
+
+Signed-off-by: Jaroslav Kysela <perex@perex.cz>
+---
+ amixer/amixer.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/amixer/amixer.c b/amixer/amixer.c
+index 2f1521b..92b0f83 100644
+--- a/amixer/amixer.c
++++ b/amixer/amixer.c
+@@ -1105,6 +1105,7 @@ static int cset(int argc, char *argv[], int roflag, int keep_handle)
+ }
+ return err;
+ }
++ snd_ctl_elem_info_get_id(info, id); /* FIXME: Remove it when hctl find works ok !!! */
+ if (!roflag) {
+ snd_ctl_elem_value_set_id(control, id);
+ if ((err = snd_ctl_elem_read(handle, control)) < 0) {
+--
+1.7.11.7
+