summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2010-01-07 17:16:00 +0000
committerSteve Dibb <beandog@gentoo.org>2010-01-07 17:16:00 +0000
commit2d0f9f85e070a2bd27dda596c35cb153eca2ba54 (patch)
treeb832196cc28b098cde586480a31945ac8c9c7dc5 /media-sound/alsa-utils
parentMask for removal. Migrate to dev-db/postgresql-{base,server} (diff)
downloadgentoo-2-2d0f9f85e070a2bd27dda596c35cb153eca2ba54.tar.gz
gentoo-2-2d0f9f85e070a2bd27dda596c35cb153eca2ba54.tar.bz2
gentoo-2-2d0f9f85e070a2bd27dda596c35cb153eca2ba54.zip
Version bump, bug 297304
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/alsa-utils')
-rw-r--r--media-sound/alsa-utils/ChangeLog10
-rw-r--r--media-sound/alsa-utils/alsa-utils-1.0.22.ebuild92
-rw-r--r--media-sound/alsa-utils/files/alsa-utils-1.0.22-modprobe.d.patch12
3 files changed, 112 insertions, 2 deletions
diff --git a/media-sound/alsa-utils/ChangeLog b/media-sound/alsa-utils/ChangeLog
index d408c0a6c15b..8bb0eda285b1 100644
--- a/media-sound/alsa-utils/ChangeLog
+++ b/media-sound/alsa-utils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/alsa-utils
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.284 2009/11/21 12:49:21 ayoy Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.285 2010/01/07 17:16:00 beandog Exp $
+
+*alsa-utils-1.0.22 (07 Jan 2010)
+
+ 07 Jan 2010; Steve Dibb <beandog@gentoo.org> +alsa-utils-1.0.22.ebuild,
+ +files/alsa-utils-1.0.22-modprobe.d.patch:
+ Version bump, bug 297304
*alsa-utils-1.0.21-r1 (21 Nov 2009)
diff --git a/media-sound/alsa-utils/alsa-utils-1.0.22.ebuild b/media-sound/alsa-utils/alsa-utils-1.0.22.ebuild
new file mode 100644
index 000000000000..c2600f46e46e
--- /dev/null
+++ b/media-sound/alsa-utils/alsa-utils-1.0.22.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/alsa-utils-1.0.22.ebuild,v 1.1 2010/01/07 17:16:00 beandog Exp $
+
+EAPI=2
+inherit eutils
+
+MY_P=${P/_rc/rc}
+
+DESCRIPTION="Advanced Linux Sound Architecture Utils (alsactl, alsamixer, etc.)"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/utils/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0.9"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="doc nls minimal"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ dev-util/dialog
+ >=media-libs/alsa-lib-${PV}
+ doc? ( app-text/xmlto )"
+RDEPEND=">=sys-libs/ncurses-5.1
+ dev-util/dialog
+ >=media-libs/alsa-lib-${PV}
+ virtual/modutils
+ !minimal? ( sys-apps/pciutils )"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ if [[ -e "${ROOT}etc/modules.d/alsa" ]]; then
+ eerror "Obsolete config /etc/modules.d/alsa found."
+ die "Move /etc/modules.d/alsa to /etc/modprobe.d/alsa.conf."
+ fi
+
+ if [[ -e "${ROOT}etc/modprobe.d/alsa" ]]; then
+ eerror "Obsolete config /etc/modprobe.d/alsa found."
+ die "Move /etc/modprobe.d/alsa to /etc/modprobe.d/alsa.conf."
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-modprobe.d.patch
+}
+
+src_configure() {
+ local myconf=""
+ use doc || myconf="--disable-xmlto"
+
+ econf ${myconf} \
+ $(use_enable nls)
+}
+
+src_install() {
+ local ALSA_UTILS_DOCS="ChangeLog README TODO
+ seq/aconnect/README.aconnect
+ seq/aseqnet/README.aseqnet"
+
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc ${ALSA_UTILS_DOCS} || die
+
+ newinitd "${FILESDIR}/alsasound.initd-r4" alsasound
+ newconfd "${FILESDIR}/alsasound.confd-r3" alsasound
+ insinto /etc/modprobe.d
+ newins "${FILESDIR}/alsa-modules.conf-rc" alsa.conf
+
+ keepdir /var/lib/alsa
+}
+
+pkg_postinst() {
+ echo
+ elog "To take advantage of the init script, and automate the process of"
+ elog "saving and restoring sound-card mixer levels you should"
+ elog "add alsasound to the boot runlevel. You can do this as"
+ elog "root like so:"
+ elog " # rc-update add alsasound boot"
+ echo
+ elog "The script will load ALSA modules, if you choose to use a modular"
+ elog "configuration. The Gentoo ALSA developers recommend you to build"
+ elog "your audio drivers into the kernel unless the device is hotpluggable"
+ elog "or you need to supply specific options (such as model= to HD Audio)."
+ echo
+ ewarn "Automated unloading of ALSA modules is deprecated and unsupported."
+ ewarn "Should you choose to use it, bug reports will not be accepted."
+ echo
+ if use minimal; then
+ ewarn "The minimal use flag disables the dependency on pciutils that"
+ ewarn "is needed by alsaconf at runtime."
+ fi
+}
diff --git a/media-sound/alsa-utils/files/alsa-utils-1.0.22-modprobe.d.patch b/media-sound/alsa-utils/files/alsa-utils-1.0.22-modprobe.d.patch
new file mode 100644
index 000000000000..cea272469dd9
--- /dev/null
+++ b/media-sound/alsa-utils/files/alsa-utils-1.0.22-modprobe.d.patch
@@ -0,0 +1,12 @@
+diff -ur alsa-utils-1.0.21.orig/alsaconf/alsaconf.in alsa-utils-1.0.21/alsaconf/alsaconf.in
+--- alsa-utils-1.0.21.orig/alsaconf/alsaconf.in 2009-05-06 10:07:24.000000000 +0300
++++ alsa-utils-1.0.21/alsaconf/alsaconf.in 2009-08-04 12:36:38.000000000 +0300
+@@ -301,7 +301,7 @@
+ fi
+ else
+ if [ "$distribution" = "gentoo" ]; then
+- cfgfile="/etc/modules.d/alsa"
++ cfgfile="/etc/modprobe.d/alsa.conf"
+ elif [ "$kernel" = "new" ]; then
+ cfgfile="/etc/modprobe.conf"
+ if [ -d /etc/modprobe.d ]; then