summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2008-05-15 18:03:00 +0000
committerSteve Dibb <beandog@gentoo.org>2008-05-15 18:03:00 +0000
commit10e829c96bf9d8a65fc3090ef507c75fa1cf9a11 (patch)
treea86e6d24de4a6ba3467882da83e46835197d2dbe /media-sound/alsa-utils
parentVersion bump (diff)
downloadgentoo-2-10e829c96bf9d8a65fc3090ef507c75fa1cf9a11.tar.gz
gentoo-2-10e829c96bf9d8a65fc3090ef507c75fa1cf9a11.tar.bz2
gentoo-2-10e829c96bf9d8a65fc3090ef507c75fa1cf9a11.zip
Install alsa file in modprobe.d, bug 213876
(Portage version: 2.1.5)
Diffstat (limited to 'media-sound/alsa-utils')
-rw-r--r--media-sound/alsa-utils/ChangeLog7
-rw-r--r--media-sound/alsa-utils/alsa-utils-1.0.16-r2.ebuild101
2 files changed, 107 insertions, 1 deletions
diff --git a/media-sound/alsa-utils/ChangeLog b/media-sound/alsa-utils/ChangeLog
index 3e82f45a3446..5dd854f40858 100644
--- a/media-sound/alsa-utils/ChangeLog
+++ b/media-sound/alsa-utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/alsa-utils
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.233 2008/05/13 15:24:43 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.234 2008/05/15 18:03:00 beandog Exp $
+
+*alsa-utils-1.0.16-r2 (15 May 2008)
+
+ 15 May 2008; Steve Dibb <beandog@gentoo.org> +alsa-utils-1.0.16-r2.ebuild:
+ Install alsa file in modprobe.d, bug 213876
*alsa-utils-1.0.16-r1 (13 May 2008)
diff --git a/media-sound/alsa-utils/alsa-utils-1.0.16-r2.ebuild b/media-sound/alsa-utils/alsa-utils-1.0.16-r2.ebuild
new file mode 100644
index 000000000000..d80733cd823f
--- /dev/null
+++ b/media-sound/alsa-utils/alsa-utils-1.0.16-r2.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/alsa-utils-1.0.16-r2.ebuild,v 1.1 2008/05/15 18:03:00 beandog Exp $
+
+WANT_AUTOMAKE="latest"
+WANT_AUTOCONF="latest"
+
+inherit eutils autotools
+
+MY_P="${P/_rc/rc}"
+
+DESCRIPTION="Advanced Linux Sound Architecture Utils (alsactl, alsamixer, etc.)"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/utils/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0.9"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="nls midi minimal"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ dev-util/dialog
+ >=media-libs/alsa-lib-${PV}"
+RDEPEND="${DEPEND}
+ virtual/modutils
+ !minimal? ( sys-apps/pciutils )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if use midi && ! built_with_use --missing true media-libs/alsa-lib midi; then
+ eerror ""
+ eerror "To be able to build alsa-utils with midi support you need"
+ eerror "to have built media-libs/alsa-lib with midi USE flag."
+ die "Missing midi USE flag on media-libs/alsa-lib"
+ fi
+
+ if use minimal; then
+ ewarn "Using the minimal flag will not build alsamixer."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-1.0.11_rc2-nls.patch"
+ epatch "${FILESDIR}/${PN}-1.0.11_rc5-alsaconf-redirect.patch"
+ epatch "${FILESDIR}/${PN}-1.0.14-alsaconf-modules-update.patch"
+ epatch "${FILESDIR}/${PN}-1.0.15_rc1-seq.patch"
+
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile() {
+ myconf=""
+ use minimal && myconf="${myconf} --disable-alsamixer"
+ econf $myconf \
+ $(use_enable nls) \
+ $(use_enable midi sequencer) \
+ || die "configure failed"
+
+ emake || die "make failed"
+}
+
+pkg_preinst() {
+ if [[ -a /etc/modules.d/alsa ]] && [[ ! -a /etc/modprobe.d/alsa ]]; then
+ elog "Moving old alsa configuration in modules.d to new"
+ elog "location in modprobe.d in /etc/"
+ mv /etc/modules.d/alsa /etc/modprobe.d/alsa
+ fi
+}
+
+src_install() {
+ local ALSA_UTILS_DOCS="ChangeLog README TODO
+ seq/aconnect/README.aconnect
+ seq/aseqnet/README.aseqnet"
+
+ emake DESTDIR="${D}" install || die "Installation Failed"
+
+ dodoc ${ALSA_UTILS_DOCS}
+ newdoc alsamixer/README README.alsamixer
+
+ newinitd "${FILESDIR}/alsasound.initd" alsasound
+ newconfd "${FILESDIR}/alsasound.confd" alsasound
+ insinto /etc/modprobe.d
+ newins "${FILESDIR}/alsa-modules.conf-rc" alsa
+
+ keepdir /var/lib/alsa
+}
+
+pkg_postinst() {
+ echo
+ elog "To take advantage of the init script, and automate the process of"
+ elog "loading and unloading the ALSA sound drivers as well as"
+ elog "storing and restoring sound-card mixer levels you should"
+ elog "add alsasound to the boot runlevel. You can do this as"
+ elog "root like so:"
+ elog " # rc-update add alsasound boot"
+ echo
+}