summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-11-16 19:59:34 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-11-16 19:59:34 +0000
commita8b48f961d497e11173978b4e848303689fbf19e (patch)
tree0058fe9b3164acac98c5cc56882509fe78b46599 /media-sound/alsa-utils/alsa-utils-1.0.10.ebuild
parentAdding initial deprecated notice. (diff)
downloadgentoo-2-a8b48f961d497e11173978b4e848303689fbf19e.tar.gz
gentoo-2-a8b48f961d497e11173978b4e848303689fbf19e.tar.bz2
gentoo-2-a8b48f961d497e11173978b4e848303689fbf19e.zip
Bump to latest upstream version.
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'media-sound/alsa-utils/alsa-utils-1.0.10.ebuild')
-rw-r--r--media-sound/alsa-utils/alsa-utils-1.0.10.ebuild76
1 files changed, 76 insertions, 0 deletions
diff --git a/media-sound/alsa-utils/alsa-utils-1.0.10.ebuild b/media-sound/alsa-utils/alsa-utils-1.0.10.ebuild
new file mode 100644
index 000000000000..09559703f948
--- /dev/null
+++ b/media-sound/alsa-utils/alsa-utils-1.0.10.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/alsa-utils-1.0.10.ebuild,v 1.1 2005/11/16 19:59:29 flameeyes Exp $
+
+inherit eutils flag-o-matic autotools
+
+MY_P="${P/_rc/rc}"
+
+DESCRIPTION="Advanced Linux Sound Architecture Utils (alsactl, alsamixer, etc.)"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/utils/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0.9"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86"
+IUSE="nls"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ dev-util/dialog
+ >=media-libs/alsa-lib-1.0.10_rc1"
+RDEPEND="${DEPEND}
+ sys-apps/pciutils"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ local ALSA_UTILS_DOCS="ChangeLog README TODO
+ seq/aconnect/README.aconnect
+ seq/aseqnet/README.aseqnet"
+
+ make DESTDIR="${D}" install || die "Installation Failed"
+
+ dodoc ${ALSA_UTILS_DOCS}
+ newdoc alsamixer/README README.alsamixer
+
+ newconfd ${FILESDIR}/alsasound.confd alsasound
+ insinto /etc/modules.d
+ newins ${FILESDIR}/alsa-modules.conf-rc alsa
+ newinitd ${FILESDIR}/alsasound-1.0.10_rc2 alsasound
+}
+
+pkg_postinst() {
+ echo
+ einfo "The alsasound initscript is now provided by alsa-utils"
+ einfo "instead of alsa-driver for compatibility with kernel-sources"
+ einfo "which provide ALSA internally."
+ echo
+ einfo "To take advantage of this, and automate the process of"
+ einfo "loading and unloading the ALSA sound drivers as well as"
+ einfo "storing and restoring sound-card mixer levels you should"
+ einfo "add alsasound to the boot runlevel. You can do this as"
+ einfo "root like so:"
+ einfo " # rc-update add alsasound boot"
+ echo
+ einfo "You will also need to edit the file /etc/modules.d/alsa"
+ einfo "and run modules-update. You can do this like so:"
+ einfo " # nano -w /etc/modules.d/alsa && modules-update"
+ echo
+
+ if use sparc; then
+ ewarn "Old versions of alsa-drivers had a broken snd-ioctl32 module"
+ ewarn "which causes sparc64 machines to lockup on such tasks as"
+ ewarn "changing the volume. Because of this, it is VERY important"
+ ewarn "that you do not use the snd-ioctl32 modules contained in"
+ ewarn "development-sources or <=gentoo-dev-sources-2.6.7-r14. Doing so"
+ ewarn "may result in an unbootable system if you start alsasound at boot."
+ fi
+}