summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2003-07-14 19:33:51 +0000
committerArcady Genkin <agenkin@gentoo.org>2003-07-14 19:33:51 +0000
commitfa0d30c54bf2804a09948be560240875e93d3a1f (patch)
tree513fe5e19ed0912350836cd6760a2edf91bf04be /media-sound/alsa-driver
parentPatch for SMP kernels. (diff)
downloadgentoo-2-fa0d30c54bf2804a09948be560240875e93d3a1f.tar.gz
gentoo-2-fa0d30c54bf2804a09948be560240875e93d3a1f.tar.bz2
gentoo-2-fa0d30c54bf2804a09948be560240875e93d3a1f.zip
Added a fix for compilation failures on SMP-enabled kernels.
Closes bug #24323.
Diffstat (limited to 'media-sound/alsa-driver')
-rw-r--r--media-sound/alsa-driver/ChangeLog8
-rw-r--r--media-sound/alsa-driver/alsa-driver-0.9.5-r1.ebuild105
-rw-r--r--media-sound/alsa-driver/files/digest-alsa-driver-0.9.5-r11
3 files changed, 113 insertions, 1 deletions
diff --git a/media-sound/alsa-driver/ChangeLog b/media-sound/alsa-driver/ChangeLog
index a0e749128222..48138353ca82 100644
--- a/media-sound/alsa-driver/ChangeLog
+++ b/media-sound/alsa-driver/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for media-sound/alsa-driver
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.43 2003/07/11 20:02:11 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.44 2003/07/14 19:33:51 agenkin Exp $
05 Jun 2003; Brandon Low <lostlogic@gentoo.org> alsa-driver-0.9.4-r1.ebuild:
Make the USE=oss actually do something
@@ -8,6 +8,12 @@
05 Jun 2003; Daniel Ahlberg <aliz@gentoo.org> alsa-driver-0.9.4.ebuild :
Switched to mirror://alsaproject in SRC_URI.
+*alsa-driver-0.9.5-r1 (11 Jul 2003)
+
+ 11 Jul 2003; Arcady Genkin <agenkin@gentoo.org> :
+ Added a fix for compilation failures on SMP-enabled kernels.
+ Closes bug #24323.
+
*alsa-driver-0.9.5 (11 Jul 2003)
11 Jul 2003; Arcady Genkin <agenkin@gentoo.org> :
diff --git a/media-sound/alsa-driver/alsa-driver-0.9.5-r1.ebuild b/media-sound/alsa-driver/alsa-driver-0.9.5-r1.ebuild
new file mode 100644
index 000000000000..aed63e5d5c38
--- /dev/null
+++ b/media-sound/alsa-driver/alsa-driver-0.9.5-r1.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-0.9.5-r1.ebuild,v 1.1 2003/07/14 19:33:51 agenkin Exp $
+
+DESCRIPTION="Advanced Linux Sound Architecture kernel modules"
+HOMEPAGE="http://www.alsa-project.org/"
+LICENSE="GPL-2 LGPL-2.1"
+
+# By default, drivers for all supported cards will be compiled.
+# If you want to only compile for specific card(s), set ALSA_CARDS
+# environment to a space-separated list of drivers that you want to build.
+# For example:
+#
+# env ALSA_CARDS='emu10k1 intel8x0 ens1370' emerge alsa-driver
+#
+[ x"${ALSA_CARDS}" = x ] && ALSA_CARDS=all
+
+IUSE="oss"
+
+# Need the baselayout 1.7.9 or newer for the init script to work correctly.
+DEPEND="sys-devel/autoconf
+ virtual/glibc
+ >=sys-apps/portage-1.9.10
+ >=sys-apps/baselayout-1.7.9"
+PROVIDE="virtual/alsa"
+
+SLOT="0.9"
+KEYWORDS="~x86 ~ppc"
+
+SRC_URI="mirror://alsaproject/driver/${P}.tar.bz2"
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # Some *broken* Gentoo packages install stuff in /etc/rc.d/init.d
+ # instead of /etc/init.d. However, this causes alsa's installer
+ # to do the same foolish thing. This *hack* inibits the problem.
+ # I filed a bug report about this with the ALSA people:
+ # http://sourceforge.net/tracker/?func=detail&aid=551668&group_id=27464&atid=390601
+ # Arcady Genkin <agenkin@thpoon.com>
+ sed -e 's:/etc/rc.d/init.d:/etc/init.d:' < Makefile > Makefile.hacked \
+ || die
+ mv Makefile.hacked Makefile
+
+ # Fix for compilation problems with SMP-enabled kernels.
+ # Bug #24323.
+ patch -p1 < ${FILESDIR}/${P}-ak4117-fix.patch || die
+
+}
+
+
+src_compile() {
+ # Portage should determine the version of the kernel sources
+ check_KV
+
+ myconf=""
+ use oss && myconf="$myconf --with-oss=yes" || \
+ myconf="$myconf --with-oss=no"
+
+ ./configure \
+ $myconf \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --with-kernel="${ROOT}usr/src/linux" \
+ --with-isapnp=yes \
+ --with-sequencer=yes \
+ --with-cards="${ALSA_CARDS}" \
+ || die "./configure failed"
+
+ emake || die "Parallel Make Failed"
+}
+
+
+src_install() {
+ dodir /usr/include/sound
+ dodir /etc/init.d
+ make DESTDIR=${D} install || die
+
+ dodoc CARDS-STATUS COPYING FAQ INSTALL README WARNING TODO doc/*
+
+ insinto /etc/modules.d
+ newins ${FILESDIR}/alsa-modules.conf-rc alsa
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/alsasound
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" = / ]
+ then
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+ fi
+
+ einfo
+ einfo "You need to edit file /etc/modules.d/alsa according to your"
+ einfo "hardware configuration."
+ einfo
+ einfo "If you are going to be using the 'alsasound' init script, make sure"
+ einfo "that you add it to the 'boot' runlevel (not 'default')."
+ einfo
+ einfo "Also, remember that all mixer channels will be MUTED by default."
+ einfo "Use 'alsamixer' program to unmute them."
+ einfo
+}
+
diff --git a/media-sound/alsa-driver/files/digest-alsa-driver-0.9.5-r1 b/media-sound/alsa-driver/files/digest-alsa-driver-0.9.5-r1
new file mode 100644
index 000000000000..5e58e3e679ec
--- /dev/null
+++ b/media-sound/alsa-driver/files/digest-alsa-driver-0.9.5-r1
@@ -0,0 +1 @@
+MD5 0584a0bb49a8ac13c49cc3571b654f26 alsa-driver-0.9.5.tar.bz2 1547980