summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2006-05-14 12:45:28 +0000
committerMichael Januszewski <spock@gentoo.org>2006-05-14 12:45:28 +0000
commit5a0ae43100416de2e345bd4c323dc3109f4089ec (patch)
treebd47cfcddf844ba09b0b68821ccea0810dfe71d1 /media-sound/adplay
parentFixed inherit eutils. (diff)
downloadgentoo-2-5a0ae43100416de2e345bd4c323dc3109f4089ec.tar.gz
gentoo-2-5a0ae43100416de2e345bd4c323dc3109f4089ec.tar.bz2
gentoo-2-5a0ae43100416de2e345bd4c323dc3109f4089ec.zip
Added a patch that fixes the adplug header files for libbinio 1.4+.
(Portage version: 2.1_pre10-r5)
Diffstat (limited to 'media-sound/adplay')
-rw-r--r--media-sound/adplay/ChangeLog9
-rw-r--r--media-sound/adplay/adplay-1.4-r2.ebuild41
-rw-r--r--media-sound/adplay/files/adplay-1.4-libbinio.patch26
-rw-r--r--media-sound/adplay/files/digest-adplay-1.42
-rw-r--r--media-sound/adplay/files/digest-adplay-1.4-r12
-rw-r--r--media-sound/adplay/files/digest-adplay-1.4-r23
6 files changed, 82 insertions, 1 deletions
diff --git a/media-sound/adplay/ChangeLog b/media-sound/adplay/ChangeLog
index 6bc6e8a41754..ed594a024bd9 100644
--- a/media-sound/adplay/ChangeLog
+++ b/media-sound/adplay/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/adplay
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/adplay/ChangeLog,v 1.6 2006/01/07 17:40:29 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/adplay/ChangeLog,v 1.7 2006/05/14 12:45:28 spock Exp $
+
+*adplay-1.4-r2 (14 May 2006)
+
+ 14 May 2006; Michał Januszewski <spock@gentoo.org>
+ +files/adplay-1.4-libbinio.patch, +adplay-1.4-r2.ebuild:
+ Added a patch that fixes the adplug header files for libbinio 1.4+ (bug
+ #133239, thanks to Stian Skjelstad).
*adplay-1.4-r1 (07 Jan 2006)
diff --git a/media-sound/adplay/adplay-1.4-r2.ebuild b/media-sound/adplay/adplay-1.4-r2.ebuild
new file mode 100644
index 000000000000..36551884fbf2
--- /dev/null
+++ b/media-sound/adplay/adplay-1.4-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/adplay/adplay-1.4-r2.ebuild,v 1.1 2006/05/14 12:45:28 spock Exp $
+
+inherit eutils
+
+IUSE="oss esd sdl"
+
+DESCRIPTION="A console player for AdLib music"
+HOMEPAGE="http://adplug.sourceforge.net/"
+SRC_URI="mirror://sourceforge/adplug/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND=">=media-libs/adplug-1.4.1-r2"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-libbinio.patch
+}
+
+src_compile() {
+ local myconf
+
+ use oss || myconf="${myconf} --disable-output-oss"
+ use esd || myconf="${myconf} --disable-output-esound"
+ use sdl || myconf="${myconf} --disable-output-sdl"
+
+ # A simple hack to make adplay work with libbinio 1.4+
+ export CXXFLAGS="${CXXFLAGS} -I/usr/include/libbinio"
+
+ econf ${myconf} || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+}
diff --git a/media-sound/adplay/files/adplay-1.4-libbinio.patch b/media-sound/adplay/files/adplay-1.4-libbinio.patch
new file mode 100644
index 000000000000..127e541c0557
--- /dev/null
+++ b/media-sound/adplay/files/adplay-1.4-libbinio.patch
@@ -0,0 +1,26 @@
+diff -ur adplay-1.4/src/disk.cc adplay-1.4-r2/src/disk.cc
+--- adplay-1.4/src/disk.cc 2004-05-13 11:50:47.000000000 +0200
++++ adplay-1.4-r2/src/disk.cc 2006-05-14 05:50:22.000000000 +0200
+@@ -21,8 +21,8 @@
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <string.h>
+-#include <binwrap.h>
+-#include <binfile.h>
++#include <libbinio/binwrap.h>
++#include <libbinio/binfile.h>
+
+ #include "defines.h"
+ #include "disk.h"
+diff -ur adplay-1.4/src/disk.h adplay-1.4-r2/src/disk.h
+--- adplay-1.4/src/disk.h 2004-05-13 11:50:47.000000000 +0200
++++ adplay-1.4-r2/src/disk.h 2006-05-14 05:49:40.000000000 +0200
+@@ -20,7 +20,7 @@
+ #ifndef H_DISK
+ #define H_DISK
+
+-#include <binio.h>
++#include <libbinio/binio.h>
+
+ #include "output.h"
+
diff --git a/media-sound/adplay/files/digest-adplay-1.4 b/media-sound/adplay/files/digest-adplay-1.4
index 2e4d5602c5fb..abfe11e1397b 100644
--- a/media-sound/adplay/files/digest-adplay-1.4
+++ b/media-sound/adplay/files/digest-adplay-1.4
@@ -1 +1,3 @@
MD5 d656103e456a244f8e279dd78fa327e0 adplay-1.4.tar.bz2 243047
+RMD160 6301b79ea9869f58fdc77feda8b4103780518b79 adplay-1.4.tar.bz2 243047
+SHA256 83fe50f7cd511d18e90f95168b26504143d0063c0bfb48a9a9be19357ce8890a adplay-1.4.tar.bz2 243047
diff --git a/media-sound/adplay/files/digest-adplay-1.4-r1 b/media-sound/adplay/files/digest-adplay-1.4-r1
index 2e4d5602c5fb..abfe11e1397b 100644
--- a/media-sound/adplay/files/digest-adplay-1.4-r1
+++ b/media-sound/adplay/files/digest-adplay-1.4-r1
@@ -1 +1,3 @@
MD5 d656103e456a244f8e279dd78fa327e0 adplay-1.4.tar.bz2 243047
+RMD160 6301b79ea9869f58fdc77feda8b4103780518b79 adplay-1.4.tar.bz2 243047
+SHA256 83fe50f7cd511d18e90f95168b26504143d0063c0bfb48a9a9be19357ce8890a adplay-1.4.tar.bz2 243047
diff --git a/media-sound/adplay/files/digest-adplay-1.4-r2 b/media-sound/adplay/files/digest-adplay-1.4-r2
new file mode 100644
index 000000000000..abfe11e1397b
--- /dev/null
+++ b/media-sound/adplay/files/digest-adplay-1.4-r2
@@ -0,0 +1,3 @@
+MD5 d656103e456a244f8e279dd78fa327e0 adplay-1.4.tar.bz2 243047
+RMD160 6301b79ea9869f58fdc77feda8b4103780518b79 adplay-1.4.tar.bz2 243047
+SHA256 83fe50f7cd511d18e90f95168b26504143d0063c0bfb48a9a9be19357ce8890a adplay-1.4.tar.bz2 243047