summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-04-16 09:14:45 +0000
committerTim Harder <radhermit@gentoo.org>2013-04-16 09:14:45 +0000
commitf673afa9ec9e69e5e201ed7bee535f2bc5b92810 (patch)
treeb99bd4d151eee0ffe7dbc35d3c46d7d0ecfd1175 /media-sound/abcmidi
parentVersion bump. (diff)
downloadgentoo-2-f673afa9ec9e69e5e201ed7bee535f2bc5b92810.tar.gz
gentoo-2-f673afa9ec9e69e5e201ed7bee535f2bc5b92810.tar.bz2
gentoo-2-f673afa9ec9e69e5e201ed7bee535f2bc5b92810.zip
Version bump.
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'media-sound/abcmidi')
-rw-r--r--media-sound/abcmidi/ChangeLog7
-rw-r--r--media-sound/abcmidi/abcmidi-2013.04.15.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/media-sound/abcmidi/ChangeLog b/media-sound/abcmidi/ChangeLog
index 9aaa30bbef01..7d37df6e08e0 100644
--- a/media-sound/abcmidi/ChangeLog
+++ b/media-sound/abcmidi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/abcmidi
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/abcmidi/ChangeLog,v 1.32 2013/04/01 07:45:58 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/abcmidi/ChangeLog,v 1.33 2013/04/16 09:14:45 radhermit Exp $
+
+*abcmidi-2013.04.15 (16 Apr 2013)
+
+ 16 Apr 2013; Tim Harder <radhermit@gentoo.org> +abcmidi-2013.04.15.ebuild:
+ Version bump.
*abcmidi-2013.03.26 (01 Apr 2013)
diff --git a/media-sound/abcmidi/abcmidi-2013.04.15.ebuild b/media-sound/abcmidi/abcmidi-2013.04.15.ebuild
new file mode 100644
index 000000000000..87f138dd90c3
--- /dev/null
+++ b/media-sound/abcmidi/abcmidi-2013.04.15.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/abcmidi/abcmidi-2013.04.15.ebuild,v 1.1 2013/04/16 09:14:45 radhermit Exp $
+
+EAPI=5
+
+inherit eutils versionator autotools
+
+MY_P="abcMIDI-$(replace_all_version_separators '-')"
+DESCRIPTION="Programs for processing ABC music notation files"
+HOMEPAGE="http://abc.sourceforge.net/abcMIDI/"
+SRC_URI="http://ifdo.pugmarks.com/~seymour/runabc/${MY_P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2011.10.19-install.patch
+ rm configure makefile || die
+ sed -i -e "s:-O2::" configure.ac || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ dodoc doc/{AUTHORS,CHANGES,abcguide.txt,abcmatch.txt,history.txt,readme.txt,yapshelp.txt}
+
+ if use examples ; then
+ docinto examples
+ dodoc samples/*.abc
+ fi
+}