summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-11-26 01:43:14 +0000
committerTim Harder <radhermit@gentoo.org>2011-11-26 01:43:14 +0000
commita0eed1e0998ec08fe2731761423dc291e8338d14 (patch)
treed08277a4ab39ee3364467c6cc18838ccdd409133 /media-sound/abcmidi
parentPython-related improvements by Ian Delaney. Bug 324393. (diff)
downloadgentoo-2-a0eed1e0998ec08fe2731761423dc291e8338d14.tar.gz
gentoo-2-a0eed1e0998ec08fe2731761423dc291e8338d14.tar.bz2
gentoo-2-a0eed1e0998ec08fe2731761423dc291e8338d14.zip
Version bump.
(Portage version: 2.2.0_alpha77/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/abcmidi')
-rw-r--r--media-sound/abcmidi/ChangeLog7
-rw-r--r--media-sound/abcmidi/abcmidi-2011.11.18.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/media-sound/abcmidi/ChangeLog b/media-sound/abcmidi/ChangeLog
index 8a3e1407be32..fd48b96cf4e0 100644
--- a/media-sound/abcmidi/ChangeLog
+++ b/media-sound/abcmidi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/abcmidi
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/abcmidi/ChangeLog,v 1.2 2011/10/21 20:18:20 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/abcmidi/ChangeLog,v 1.3 2011/11/26 01:43:14 radhermit Exp $
+
+*abcmidi-2011.11.18 (26 Nov 2011)
+
+ 26 Nov 2011; Tim Harder <radhermit@gentoo.org> +abcmidi-2011.11.18.ebuild:
+ Version bump.
21 Oct 2011; Tim Harder <radhermit@gentoo.org> abcmidi-2011.10.19.ebuild:
Remove unneeded docdir setting.
diff --git a/media-sound/abcmidi/abcmidi-2011.11.18.ebuild b/media-sound/abcmidi/abcmidi-2011.11.18.ebuild
new file mode 100644
index 000000000000..263a1bd026c4
--- /dev/null
+++ b/media-sound/abcmidi/abcmidi-2011.11.18.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/abcmidi/abcmidi-2011.11.18.ebuild,v 1.1 2011/11/26 01:43:14 radhermit Exp $
+
+EAPI="4"
+
+inherit eutils versionator autotools
+
+MY_P="abcMIDI-$(replace_all_version_separators '-')"
+DESCRIPTION="Programs for processing ABC music notation files"
+HOMEPAGE="http://abc.sourceforge.net/abcMIDI/"
+SRC_URI="http://ifdo.pugmarks.com/~seymour/runabc/${MY_P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2011.10.19-install.patch
+ rm makefile || die
+ sed -i -e "s:-O2::" configure.ac || die
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc doc/{AUTHORS,CHANGES,abcguide.txt,abcmatch.txt,history.txt,readme.txt,yapshelp.txt}
+
+ if use examples ; then
+ docinto examples
+ dodoc samples/*.abc
+ fi
+}