summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2013-12-25 13:26:27 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2013-12-25 13:26:27 +0000
commitfe10ceb92ea4eddab52ac889ab908ed67613fffb (patch)
tree3f6ca1055f7ee825c9ec83dfc8f3417e8747f545 /media-radio
parentMask USE=frost for net-p2p/fms, currently broken with >=net-libs/polarssl-1.3.0 (diff)
downloadgentoo-2-fe10ceb92ea4eddab52ac889ab908ed67613fffb.tar.gz
gentoo-2-fe10ceb92ea4eddab52ac889ab908ed67613fffb.tar.bz2
gentoo-2-fe10ceb92ea4eddab52ac889ab908ed67613fffb.zip
Version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x762053D5)
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/unixcw/ChangeLog7
-rw-r--r--media-radio/unixcw/unixcw-3.3.0.ebuild72
2 files changed, 78 insertions, 1 deletions
diff --git a/media-radio/unixcw/ChangeLog b/media-radio/unixcw/ChangeLog
index 64ebf190c47a..c14f6492e083 100644
--- a/media-radio/unixcw/ChangeLog
+++ b/media-radio/unixcw/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-radio/unixcw
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/unixcw/ChangeLog,v 1.11 2013/03/02 21:52:16 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-radio/unixcw/ChangeLog,v 1.12 2013/12/25 13:26:27 tomjbe Exp $
+
+*unixcw-3.3.0 (25 Dec 2013)
+
+ 25 Dec 2013; Thomas Beierlein <tomjbe@gentoo.org> +unixcw-3.3.0.ebuild:
+ Version bump
02 Mar 2013; Markos Chandras <hwoarang@gentoo.org> unixcw-2.3-r6.ebuild,
unixcw-3.0.2.ebuild, unixcw-3.1.1.ebuild, unixcw-3.2.0.ebuild:
diff --git a/media-radio/unixcw/unixcw-3.3.0.ebuild b/media-radio/unixcw/unixcw-3.3.0.ebuild
new file mode 100644
index 000000000000..5f8e4aba953e
--- /dev/null
+++ b/media-radio/unixcw/unixcw-3.3.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-radio/unixcw/unixcw-3.3.0.ebuild,v 1.1 2013/12/25 13:26:27 tomjbe Exp $
+
+EAPI=4
+
+inherit autotools eutils flag-o-matic multilib
+
+DESCRIPTION="A package of programs that fit together to form a morse code tutor program."
+HOMEPAGE="http://unixcw.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="alsa ncurses pulseaudio suid qt4"
+
+RDEPEND="ncurses? ( sys-libs/ncurses )
+ qt4? ( dev-qt/qtgui:4[qt3support] )
+ alsa? ( media-libs/alsa-lib )
+ pulseaudio? ( media-sound/pulseaudio )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/libtool
+ !<=app-misc/cw-1.0.16-r1"
+
+src_prepare() {
+ append-cflags -std=gnu99
+ # add path to qt4 libs
+ sed -i -e "s#LDADD = -L#LDADD = -L/usr/$(get_libdir)/qt4 -L#g" \
+ src/xcwcp/Makefile.am
+ eautoreconf
+}
+
+src_configure() {
+ econf --libdir=/usr/$(get_libdir) \
+ $(use_enable pulseaudio ) \
+ $(use_enable alsa ) \
+ $(use_enable ncurses cwcp ) \
+ $(use_enable qt4 xcwcp )
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ prune_libtool_files
+ dodoc ChangeLog NEWS README
+ if ! use suid ; then
+ fperms 711 /usr/bin/cw
+ if use ncurses ; then
+ fperms 711 /usr/bin/cwcp
+ fi
+ if use qt4 ; then
+ fperms 711 /usr/bin/xcwcp
+ fi
+ fi
+}
+
+pkg_postinst() {
+ if use suid ; then
+ ewarn "You have choosen to install 'cw', 'cwcp' and 'xcwcp' setuid"
+ ewarn "by setting USE=suid."
+ ewarn "Be aware that this is a security risk and not recommended."
+ ewarn ""
+ ewarn "These files do only need root access if you want to use the"
+ ewarn "PC speaker for morse sidetone output. You can alternativly"
+ ewarn "drop USE=suid and use sudo."
+ else
+ elog "Be aware that 'cw', 'cwcp' and 'xcwcp' needs root access if"
+ elog "you want to use the PC speaker for morse sidetone output."
+ elog "You can call the programs via sudo for that (see 'man sudo')."
+ fi
+}