summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2011-02-25 18:06:13 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2011-02-25 18:06:13 +0000
commit990426c4566ebcf6ac11a0289729c7b32b31e327 (patch)
treefaeeae7626e47effb2236c73854373e44bb33052 /media-radio
parentremoved jpeg, libpng deps (diff)
downloadgentoo-2-990426c4566ebcf6ac11a0289729c7b32b31e327.tar.gz
gentoo-2-990426c4566ebcf6ac11a0289729c7b32b31e327.tar.bz2
gentoo-2-990426c4566ebcf6ac11a0289729c7b32b31e327.zip
Version bump.
(Portage version: 2.1.9.41/cvs/Linux x86_64)
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/tucnak2/ChangeLog10
-rw-r--r--media-radio/tucnak2/files/tucnak2-2.39-doc.diff19
-rw-r--r--media-radio/tucnak2/tucnak2-2.39.ebuild65
3 files changed, 92 insertions, 2 deletions
diff --git a/media-radio/tucnak2/ChangeLog b/media-radio/tucnak2/ChangeLog
index 3c913cb5b5df..5896d3c7a525 100644
--- a/media-radio/tucnak2/ChangeLog
+++ b/media-radio/tucnak2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-radio/tucnak2
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/tucnak2/ChangeLog,v 1.26 2010/12/20 13:38:34 c1pher Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-radio/tucnak2/ChangeLog,v 1.27 2011/02/25 18:06:13 tomjbe Exp $
+
+*tucnak2-2.39 (25 Feb 2011)
+
+ 25 Feb 2011; Thomas Beierlein <tomjbe@gentoo.org> +tucnak2-2.39.ebuild,
+ +files/tucnak2-2.39-doc.diff:
+ Version bump.
20 Dec 2010; Dane Smith <c1pher@gentoo.org> tucnak2-2.37.ebuild:
x86 stable wrt bug 349092.
diff --git a/media-radio/tucnak2/files/tucnak2-2.39-doc.diff b/media-radio/tucnak2/files/tucnak2-2.39-doc.diff
new file mode 100644
index 000000000000..1e53f0b633f2
--- /dev/null
+++ b/media-radio/tucnak2/files/tucnak2-2.39-doc.diff
@@ -0,0 +1,19 @@
+--- Makefile.am.orig 2011-02-25 18:29:32.000000000 +0100
++++ Makefile.am 2011-02-25 18:29:52.000000000 +0100
+@@ -1,15 +1,11 @@
+ datarootdir = @datarootdir@
+
+-SUBDIRS=data doc intl pkg share src win32
++SUBDIRS=data intl pkg share src win32
+
+ MAINTAINERCLEANFILES = aclocal.m4 config.h.in configure Makefile.in stamp-h.in
+
+ EXTRA_DIST = COPYING INSTALL leaks rebuild debian/* eee.sh
+
+-docsdir = $(datadir)/tucnak2/doc
+-
+-docs_DATA = AUTHORS ChangeLog TODO
+-
+ stamp = `date +%Y%m%d_%H%M%S`
+
+ distd: dist
diff --git a/media-radio/tucnak2/tucnak2-2.39.ebuild b/media-radio/tucnak2/tucnak2-2.39.ebuild
new file mode 100644
index 000000000000..28c5d0c5cbb3
--- /dev/null
+++ b/media-radio/tucnak2/tucnak2-2.39.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-radio/tucnak2/tucnak2-2.39.ebuild,v 1.1 2011/02/25 18:06:13 tomjbe Exp $
+
+EAPI=2
+inherit eutils autotools
+
+DESCRIPTION="Amateur Radio VHF Contest Logbook"
+HOMEPAGE="http://tucnak.nagano.cz"
+SRC_URI="http://tucnak.nagano.cz/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa fftw ftdi gpm hamlib suid"
+
+RDEPEND=">=dev-libs/glib-2
+ media-libs/libsndfile
+ >=media-libs/libsdl-1.2
+ alsa? ( media-libs/alsa-lib )
+ fftw? ( sci-libs/fftw:3.0 )
+ ftdi? ( dev-embedded/libftdi )
+ gpm? ( sys-libs/gpm )
+ hamlib? ( media-libs/hamlib )
+ >=media-libs/libpng-1.2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-2.39-doc.diff" \
+ "${FILESDIR}/${PN}-2.32-appname.diff"
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with alsa) $(use_with ftdi) \
+ $(use_with gpm) $(use_with hamlib) \
+ $(use_with fftw fftw3) --with-sdl
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ doman debian/tucnak2.1 || die "doman failed"
+ dodoc AUTHORS ChangeLog TODO doc/NAVOD.pdf || die "dodoc failed"
+ if use suid ; then
+ fperms 4711 /usr/bin/soundwrapper || die "fperms failed"
+ fi
+}
+
+pkg_postinst() {
+ elog "In order to use sound with tucnak2 add yourself to the 'audio' group"
+ elog "and to key your rig via the parport add yourself to the 'lp' group"
+ elog ""
+ elog "tucnak2 can be used with the following additional packages:"
+ elog " media-radio/cwdaemon : Morse output via code cwdaemon"
+ elog " (No need to recompile)"
+ if use suid ; then
+ ewarn "You have choosen to install the little helper program 'soundwrapper'"
+ ewarn "setuid by setting USE=suid. That helper is only needed if you"
+ ewarn "want to use morse sidetone output via the PC speaker."
+ ewarn ""
+ ewarn "While the helper should be safe by design be aware that setting"
+ ewarn "any program setuid is a security risk."
+ fi
+}