summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2010-11-21 08:23:02 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2010-11-21 08:23:02 +0000
commit6cb393f8ab003b74caae5d5c60848fd1b99d8280 (patch)
tree99d9faf83f1ab9d868400a7ef80e6071706c24f9 /media-radio
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-6cb393f8ab003b74caae5d5c60848fd1b99d8280.tar.gz
gentoo-2-6cb393f8ab003b74caae5d5c60848fd1b99d8280.tar.bz2
gentoo-2-6cb393f8ab003b74caae5d5c60848fd1b99d8280.zip
Version bump.
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/xastir/ChangeLog8
-rw-r--r--media-radio/xastir/files/xastir-2.0.0-Destdir.diff24
-rw-r--r--media-radio/xastir/xastir-2.0.0.ebuild79
3 files changed, 110 insertions, 1 deletions
diff --git a/media-radio/xastir/ChangeLog b/media-radio/xastir/ChangeLog
index 8aedadc83bf2..aaa8e6a34df7 100644
--- a/media-radio/xastir/ChangeLog
+++ b/media-radio/xastir/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-radio/xastir
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/xastir/ChangeLog,v 1.15 2010/10/10 18:43:46 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-radio/xastir/ChangeLog,v 1.16 2010/11/21 08:23:01 tomjbe Exp $
+
+*xastir-2.0.0 (21 Nov 2010)
+
+ 21 Nov 2010; Thomas Beierlein <tomjbe@gentoo.org> +xastir-2.0.0.ebuild,
+ +files/xastir-2.0.0-Destdir.diff:
+ Version bump.
10 Oct 2010; Ulrich Mueller <ulm@gentoo.org> xastir-1.9.8.ebuild,
xastir-1.9.8-r1.ebuild:
diff --git a/media-radio/xastir/files/xastir-2.0.0-Destdir.diff b/media-radio/xastir/files/xastir-2.0.0-Destdir.diff
new file mode 100644
index 000000000000..0d65c9e1a864
--- /dev/null
+++ b/media-radio/xastir/files/xastir-2.0.0-Destdir.diff
@@ -0,0 +1,24 @@
+--- config/Makefile.am.orig 2008-06-12 21:30:44.000000000 +0200
++++ config/Makefile.am 2009-06-06 18:03:32.000000000 +0200
+@@ -93,5 +93,5 @@
+ config_DATA = ${EXTRA_DIST}
+
+ install-exec-hook:
+- rm -f \$(configdir)/nwsfz_ddmmyy.dbfawk
++ rm -f $(DESTDIR)$(configdir)/nwsfz_ddmmyy.dbfawk
+
+--- Makefile.am.old 2010-11-19 06:06:16.000000000 +0000
++++ Makefile.am 2010-11-19 06:07:34.000000000 +0000
+@@ -72,10 +72,10 @@
+ # documentation is FHS compliant.
+
+ install-exec-hook:
+- -rm -rf ${pkgdatadir}/doc
++ -rm -rf ${DESTDIR}${pkgdatadir}/doc
+
+ install-data-hook:
+- cd $(mapdir) && \
++ cd ${DESTDIR}$(mapdir) && \
+ rm -f CC_OpenStreetMap.png && \
+ $(LN_S) CC_OpenStreetMap_logo.png CC_OpenStreetMap.png
+
diff --git a/media-radio/xastir/xastir-2.0.0.ebuild b/media-radio/xastir/xastir-2.0.0.ebuild
new file mode 100644
index 000000000000..5d4bae198117
--- /dev/null
+++ b/media-radio/xastir/xastir-2.0.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-radio/xastir/xastir-2.0.0.ebuild,v 1.1 2010/11/21 08:23:01 tomjbe Exp $
+
+EAPI=2
+inherit autotools eutils multilib
+
+DESCRIPTION="X Amateur Station Tracking and Information Reporting"
+HOMEPAGE="http://xastir.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="festival gdal geotiff"
+
+DEPEND=">=x11-libs/openmotif-2.3:0
+ x11-libs/libXpm
+ x11-apps/xfontsel
+ dev-libs/libpcre
+ net-misc/curl
+ sys-libs/db
+ sci-libs/shapelib
+ media-gfx/imagemagick
+ geotiff? ( sci-libs/proj
+ sci-libs/libgeotiff
+ media-libs/tiff )
+ gdal? ( sci-libs/gdal )
+ festival? ( app-accessibility/festival )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # fix hardcoded /usr/local paths in scripts
+ epatch "${FILESDIR}"/${PN}-1.9.8-scripts.diff
+ # and patch libdir
+ for f in scripts/permutations.pl scripts/test_coord.pl \
+ scripts/toporama250k.pl scripts/toporama50k.pl; do
+ sed -i -e "s:/usr/lib:/usr/$(get_libdir):g" "${f}" \
+ || die "sed failed on ${f}"
+ done
+
+ # fix __FORTIFY_SOURCE warning (bug #337365)
+ epatch "${FILESDIR}"/${PN}-1.9.8-fortify.diff
+
+ # fix for DESTDIR
+ epatch "${FILESDIR}"/${P}-Destdir.diff
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --without-graphicsmagick \
+ --with-pcre \
+ --with-shapelib \
+ --with-dbfawk \
+ --without-ax25 \
+ --without-gpsman \
+ --with-imagemagick \
+ $(use_with geotiff libproj) \
+ $(use_with geotiff) \
+ $(use_with gdal) \
+ $(use_with festival)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ rm -rf "${D}"/usr/share/doc/${PN}
+ dodoc AUTHORS ChangeLog FAQ README README.Contributing \
+ README.Getting-Started README.MAPS || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog "Kernel mode AX.25 and GPSman library not supported."
+ elog
+ elog "Remember you have to be root to add addditional scripts,"
+ elog "maps and other configuration data under /usr/share/xastir"
+ elog "and /usr/$(get_libdir)/xastir."
+}