summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2005-03-12 19:51:29 +0000
committerRyan Phillips <rphillips@gentoo.org>2005-03-12 19:51:29 +0000
commit4774fa7c317982e9ddf2fff03ce4e994e13edbda (patch)
treeb7131504da67883ab933c5b5e235cf4696087c0a /media-radio
parentadded libglade to DEPEND (diff)
downloadgentoo-2-4774fa7c317982e9ddf2fff03ce4e994e13edbda.tar.gz
gentoo-2-4774fa7c317982e9ddf2fff03ce4e994e13edbda.tar.bz2
gentoo-2-4774fa7c317982e9ddf2fff03ce4e994e13edbda.zip
fixes #84205 and missing header on 2.6 kernels
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/ax25-tools/ChangeLog9
-rw-r--r--media-radio/ax25-tools/ax25-tools-0.0.8-r1.ebuild11
-rw-r--r--media-radio/ax25-tools/files/ax25-tools-soundmodem.patch118
3 files changed, 134 insertions, 4 deletions
diff --git a/media-radio/ax25-tools/ChangeLog b/media-radio/ax25-tools/ChangeLog
index 63b99398efa8..62059043c4f3 100644
--- a/media-radio/ax25-tools/ChangeLog
+++ b/media-radio/ax25-tools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-radio/ax25-tools
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/ax25-tools/ChangeLog,v 1.4 2004/10/18 12:28:25 dholm Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-radio/ax25-tools/ChangeLog,v 1.5 2005/03/12 19:51:29 rphillips Exp $
+
+ 12 Mar 2005; <rphillips@gentoo.org> +files/ax25-tools-soundmodem.patch,
+ ax25-tools-0.0.8-r1.ebuild:
+ Added patch for 2.6 kernels due to the fact they are missing
+ soundmodem.h
18 Oct 2004; David Holm <dholm@gentoo.org> ax25-tools-0.0.8-r1.ebuild:
Added to ~ppc.
diff --git a/media-radio/ax25-tools/ax25-tools-0.0.8-r1.ebuild b/media-radio/ax25-tools/ax25-tools-0.0.8-r1.ebuild
index 3e3478ff5d28..6c361c8d280a 100644
--- a/media-radio/ax25-tools/ax25-tools-0.0.8-r1.ebuild
+++ b/media-radio/ax25-tools/ax25-tools-0.0.8-r1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/ax25-tools/ax25-tools-0.0.8-r1.ebuild,v 1.6 2004/10/18 12:28:25 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-radio/ax25-tools/ax25-tools-0.0.8-r1.ebuild,v 1.7 2005/03/12 19:51:29 rphillips Exp $
+
+inherit eutils check-kernel
DESCRIPTION="Basic AX.25 (Amateur Radio) administrative tools and daemons"
HOMEPAGE="http://ax25.sourceforge.net/"
@@ -19,6 +21,11 @@ DEPEND="virtual/libc
src_compile() {
# If X is disabled, do not build smdiag
local COMPFLAGS=""
+
+ if is_2_6_kernel ; then
+ epatch ${FILESDIR}/ax25-tools-soundmodem.patch
+ fi
+
use X || COMPFLAGS="--without-x"
econf ${COMPFLAGS} || die
emake || die
diff --git a/media-radio/ax25-tools/files/ax25-tools-soundmodem.patch b/media-radio/ax25-tools/files/ax25-tools-soundmodem.patch
new file mode 100644
index 000000000000..8b28d2868fa3
--- /dev/null
+++ b/media-radio/ax25-tools/files/ax25-tools-soundmodem.patch
@@ -0,0 +1,118 @@
+Submitted By: Jeremy Utley <jeremy@linuxfromscratch.org>
+Date: 2004-09-25
+Initial package Version: 0.0.8
+Upstream Status: Not Submitted (Hack)
+Origin: Ported from Debian ax25-utils-0.0.8-5 Diff
+Description: This unmaintained package has a problem compiling on a system
+based from the linux-libc-headers, since the soundmodem driver and it's
+associated header file has been removed from kernel 2.6. This patch places the
+soundmodem.h header file into the source package itself, allowing proper
+compilation. This is a hack solution, the better solution would be to remove
+any references to the header from the source.
+
+diff -Naur ax25-tools-0.0.8/hdlcutil/hdrvcomm.h ax25-tools-0.0.8-new/hdlcutil/hdrvcomm.h
+--- ax25-tools-0.0.8/hdlcutil/hdrvcomm.h 2001-04-10 02:10:48.000000000 +0000
++++ ax25-tools-0.0.8-new/hdlcutil/hdrvcomm.h 2004-09-26 04:46:53.390747547 +0000
+@@ -42,7 +42,7 @@
+
+ #ifdef HDRVC_KERNEL
+ #include <linux/hdlcdrv.h>
+-#include <linux/soundmodem.h>
++#include "soundmodem.h"
+ #include <linux/baycom.h>
+ #endif /* HDRVC_KERNEL */
+
+diff -Naur ax25-tools-0.0.8/hdlcutil/soundmodem.h ax25-tools-0.0.8-new/hdlcutil/soundmodem.h
+--- ax25-tools-0.0.8/hdlcutil/soundmodem.h 1970-01-01 00:00:00.000000000 +0000
++++ ax25-tools-0.0.8-new/hdlcutil/soundmodem.h 2004-09-26 04:46:53.392747063 +0000
+@@ -0,0 +1,90 @@
++/*
++ * The Linux soundcard driver for 1200 baud and 9600 baud packet radio
++ * (C) 1996-1998 by Thomas Sailer, HB9JNX/AE4WA
++ */
++
++#ifndef _SOUNDMODEM_H
++#define _SOUNDMODEM_H
++
++/* -------------------------------------------------------------------- */
++/*
++ * structs for the IOCTL commands
++ */
++
++struct sm_debug_data {
++ unsigned int int_rate;
++ unsigned int mod_cycles;
++ unsigned int demod_cycles;
++ unsigned int dma_residue;
++};
++
++struct sm_diag_data {
++ unsigned int mode;
++ unsigned int flags;
++ unsigned int samplesperbit;
++ unsigned int datalen;
++ short *data;
++};
++
++struct sm_mixer_data {
++ unsigned int mixer_type;
++ unsigned int sample_rate;
++ unsigned int bit_rate;
++ unsigned int reg;
++ unsigned int data;
++};
++
++struct sm_config {
++ int hardware;
++ int mode;
++};
++
++struct sm_ioctl {
++ int cmd;
++ union {
++ struct sm_config cfg;
++ struct sm_diag_data diag;
++ struct sm_mixer_data mix;
++ struct sm_debug_data dbg;
++ } data;
++};
++
++/* -------------------------------------------------------------------- */
++
++/*
++ * diagnose modes
++ */
++#define SM_DIAGMODE_OFF 0
++#define SM_DIAGMODE_INPUT 1
++#define SM_DIAGMODE_DEMOD 2
++#define SM_DIAGMODE_CONSTELLATION 3
++
++/*
++ * diagnose flags
++ */
++#define SM_DIAGFLAG_DCDGATE (1<<0)
++#define SM_DIAGFLAG_VALID (1<<1)
++
++/*
++ * mixer types
++ */
++#define SM_MIXER_INVALID 0
++#define SM_MIXER_AD1848 0x10
++#define SM_MIXER_CRYSTAL 0x11
++#define SM_MIXER_CT1335 0x20
++#define SM_MIXER_CT1345 0x21
++#define SM_MIXER_CT1745 0x22
++
++/*
++ * ioctl values
++ */
++#define SMCTL_DIAGNOSE 0x82
++#define SMCTL_GETMIXER 0x83
++#define SMCTL_SETMIXER 0x84
++#define SMCTL_GETDEBUG 0x85
++
++/* -------------------------------------------------------------------- */
++
++#endif /* _SOUNDMODEM_H */
++
++/* --------------------------------------------------------------------- */