summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2013-06-16 09:42:59 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2013-06-16 09:42:59 +0000
commit05a59a6b91422a119c8d90350fec9039f2cc6b68 (patch)
tree800aeab9d481dbc7e8d7f1fe89b9a17e066f39cf /media-radio
parentCleanup due #122207 (diff)
downloadgentoo-2-05a59a6b91422a119c8d90350fec9039f2cc6b68.tar.gz
gentoo-2-05a59a6b91422a119c8d90350fec9039f2cc6b68.tar.bz2
gentoo-2-05a59a6b91422a119c8d90350fec9039f2cc6b68.zip
Version bump
(Portage version: 2.1.12.4/cvs/Linux x86_64, signed Manifest commit with key 0x762053D5)
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/svxlink/ChangeLog7
-rw-r--r--media-radio/svxlink/svxlink-13.06.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/media-radio/svxlink/ChangeLog b/media-radio/svxlink/ChangeLog
index 7ab4d41bce6d..276cdf986f1d 100644
--- a/media-radio/svxlink/ChangeLog
+++ b/media-radio/svxlink/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-radio/svxlink
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/svxlink/ChangeLog,v 1.23 2013/05/10 17:13:20 tomjbe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-radio/svxlink/ChangeLog,v 1.24 2013/06/16 09:42:59 tomjbe Exp $
+
+*svxlink-13.06 (16 Jun 2013)
+
+ 16 Jun 2013; Thomas Beierlein <tomjbe@gentoo.org> +svxlink-13.06.ebuild:
+ Version bump
*svxlink-13.03 (10 May 2013)
diff --git a/media-radio/svxlink/svxlink-13.06.ebuild b/media-radio/svxlink/svxlink-13.06.ebuild
new file mode 100644
index 000000000000..f928c65d2612
--- /dev/null
+++ b/media-radio/svxlink/svxlink-13.06.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-radio/svxlink/svxlink-13.06.ebuild,v 1.1 2013/06/16 09:42:59 tomjbe Exp $
+
+EAPI=4
+inherit eutils multilib qt4-r2 user
+
+DESCRIPTION="Multi Purpose Voice Services System, including Qtel for EchoLink"
+HOMEPAGE="http://svxlink.sourceforge.net/"
+SRC_URI="mirror://sourceforge/svxlink/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/tcl
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ media-libs/alsa-lib
+ media-sound/gsm
+ dev-libs/libgcrypt
+ media-libs/speex
+ dev-libs/libsigc++:2
+ dev-libs/popt"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+pkg_setup() {
+ enewgroup svxlink
+ enewuser svxlink -1 -1 -1 svxlink
+}
+
+src_prepare() {
+ sed -i -e "s:/lib:/$(get_libdir):g" makefile.cfg || die
+ sed -i -e "s:/etc/udev:/lib/udev:" svxlink/scripts/Makefile.default || die
+ # fix underlinking
+ sed -i -e "s:lgsm:lgsm -lspeex:" qtel/Makefile.default || die
+}
+
+src_install() {
+ default
+
+ fowners -R svxlink.svxlink /var/spool/svxlink
+ # adapt to gentoo init system
+ rm -R "${D}"/etc/sysconfig || die
+ newinitd "${FILESDIR}"/remotetrx.init remotetrx
+ newinitd "${FILESDIR}"/svxlink.init svxlink
+ newconfd "${FILESDIR}"/remotetrx.rc remotetrx
+ newconfd "${FILESDIR}"/svxlink.rc svxlink
+}