summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-08-26 14:15:05 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-08-26 14:15:05 +0000
commit429d3be4f2c728d308640a1fd417f22e2151c2f1 (patch)
tree7717943049ec0d68a18c589070bad974d824ce65 /media-radio/xwxapt
parentrevbump -> EAPI 5, add test invocation (diff)
downloadgentoo-2-429d3be4f2c728d308640a1fd417f22e2151c2f1.tar.gz
gentoo-2-429d3be4f2c728d308640a1fd417f22e2151c2f1.tar.bz2
gentoo-2-429d3be4f2c728d308640a1fd417f22e2151c2f1.zip
Bump
(Portage version: 2.2.1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'media-radio/xwxapt')
-rw-r--r--media-radio/xwxapt/ChangeLog10
-rw-r--r--media-radio/xwxapt/xwxapt-2.2.ebuild43
2 files changed, 50 insertions, 3 deletions
diff --git a/media-radio/xwxapt/ChangeLog b/media-radio/xwxapt/ChangeLog
index cab1a5effe42..82c83d905c1a 100644
--- a/media-radio/xwxapt/ChangeLog
+++ b/media-radio/xwxapt/ChangeLog
@@ -1,10 +1,14 @@
# ChangeLog for media-radio/xwxapt
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/xwxapt/ChangeLog,v 1.1 2012/11/02 18:31:25 tomjbe Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-radio/xwxapt/ChangeLog,v 1.2 2013/08/26 14:15:05 patrick Exp $
+
+*xwxapt-2.2 (26 Aug 2013)
+
+ 26 Aug 2013; Patrick Lauer <patrick@gentoo.org> +xwxapt-2.2.ebuild:
+ Bump
*xwxapt-2.1 (02 Nov 2012)
02 Nov 2012; Thomas Beierlein <tomjbe@gentoo.org> +xwxapt-2.1.ebuild,
+metadata.xml:
Moved from sunrise (bug #237460). Version bump
-
diff --git a/media-radio/xwxapt/xwxapt-2.2.ebuild b/media-radio/xwxapt/xwxapt-2.2.ebuild
new file mode 100644
index 000000000000..6cd7955ea313
--- /dev/null
+++ b/media-radio/xwxapt/xwxapt-2.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-radio/xwxapt/xwxapt-2.2.ebuild,v 1.1 2013/08/26 14:15:05 patrick Exp $
+
+EAPI=4
+
+inherit autotools
+
+DESCRIPTION="GTK+ linux weather satellite APT image decoder software"
+HOMEPAGE="http://5b4az.chronos.org.uk/pages/apt.html"
+SRC_URI="http://5b4az.chronos.org.uk/pkg/apt/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/alsa-lib
+ dev-libs/glib:2
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ # create missing mkinstalldir and prepare package
+ glib-gettextize --force --copy || die "gettextize failed"
+ eautoreconf
+}
+
+src_install() {
+ default
+ dohtml doc/xwxapt.html
+ insinto /usr/share/${PN}
+ doins xwxapt/xwxaptrc
+ dodir /usr/share/${PN}/images /usr/share/${PN}/records
+}
+
+pkg_postinst() {
+ einfo "You must copy the /usr/share/xwxapt directory into your home directory"
+ einfo "and configure the contained xwxaptrc file before starting the program"
+}