summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-07-22 11:07:29 +0000
committerMichał Górny <mgorny@gentoo.org>2013-07-22 11:07:29 +0000
commit50e25193c00eb4589597c964173631592ce1ff0c (patch)
tree45b119fbfc39fb8c83d11fab6e68ac582e7cf638 /media-radio/radiotray
parentReorder Qt dependencies. (diff)
downloadgentoo-2-50e25193c00eb4589597c964173631592ce1ff0c.tar.gz
gentoo-2-50e25193c00eb4589597c964173631592ce1ff0c.tar.bz2
gentoo-2-50e25193c00eb4589597c964173631592ce1ff0c.zip
Convert to distutils-r1, bug #477722.
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'media-radio/radiotray')
-rw-r--r--media-radio/radiotray/ChangeLog10
-rw-r--r--media-radio/radiotray/radiotray-0.7.3-r2.ebuild (renamed from media-radio/radiotray/radiotray-0.7.3-r1.ebuild)26
-rw-r--r--media-radio/radiotray/radiotray-9999.ebuild32
3 files changed, 38 insertions, 30 deletions
diff --git a/media-radio/radiotray/ChangeLog b/media-radio/radiotray/ChangeLog
index 64c35412e113..45f3c4970654 100644
--- a/media-radio/radiotray/ChangeLog
+++ b/media-radio/radiotray/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-radio/radiotray
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/radiotray/ChangeLog,v 1.29 2012/12/27 19:01:32 ottxor Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-radio/radiotray/ChangeLog,v 1.30 2013/07/22 11:07:29 mgorny Exp $
+
+*radiotray-0.7.3-r2 (22 Jul 2013)
+
+ 22 Jul 2013; Michał Górny <mgorny@gentoo.org> +radiotray-0.7.3-r2.ebuild,
+ -radiotray-0.7.3-r1.ebuild, radiotray-9999.ebuild:
+ Convert to distutils-r1, bug #477722.
27 Dec 2012; Christoph Junghans <ottxor@gentoo.org> radiotray-9999.ebuild:
mercurial.eclass respects now
diff --git a/media-radio/radiotray/radiotray-0.7.3-r1.ebuild b/media-radio/radiotray/radiotray-0.7.3-r2.ebuild
index 52dc1c522c32..d23b995772c5 100644
--- a/media-radio/radiotray/radiotray-0.7.3-r1.ebuild
+++ b/media-radio/radiotray/radiotray-0.7.3-r2.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/radiotray/radiotray-0.7.3-r1.ebuild,v 1.4 2012/12/02 16:57:22 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-radio/radiotray/radiotray-0.7.3-r2.ebuild,v 1.1 2013/07/22 11:07:29 mgorny Exp $
-EAPI=4
+EAPI=5
-PYTHON_COMPAT='python2_6 python2_7'
-inherit base python-distutils-ng
+PYTHON_COMPAT=( python2_6 python2_7 )
+inherit distutils-r1
DESCRIPTION="Online radio streaming player"
HOMEPAGE="http://radiotray.sourceforge.net/"
@@ -16,13 +16,13 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND="dev-python/dbus-python
- dev-python/gst-python:0.10
- dev-python/pygtk
- dev-python/lxml
- dev-python/pyxdg
- dev-python/pygobject:2
- dev-python/notify-python
+RDEPEND="dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/gst-python:0.10[${PYTHON_USEDEP}]
+ dev-python/pygtk[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ dev-python/notify-python[${PYTHON_USEDEP}]
media-libs/gst-plugins-good:0.10
media-libs/gst-plugins-ugly:0.10
media-plugins/gst-plugins-alsa:0.10
@@ -33,4 +33,4 @@ RDEPEND="dev-python/dbus-python
media-plugins/gst-plugins-soup:0.10
media-plugins/gst-plugins-vorbis:0.10"
-DEPEND="dev-python/pyxdg"
+DEPEND="dev-python/pyxdg[${PYTHON_USEDEP}]"
diff --git a/media-radio/radiotray/radiotray-9999.ebuild b/media-radio/radiotray/radiotray-9999.ebuild
index 3ab16f01fd4c..2d88b453deea 100644
--- a/media-radio/radiotray/radiotray-9999.ebuild
+++ b/media-radio/radiotray/radiotray-9999.ebuild
@@ -1,11 +1,13 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/radiotray/radiotray-9999.ebuild,v 1.8 2012/12/27 19:01:32 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-radio/radiotray/radiotray-9999.ebuild,v 1.9 2013/07/22 11:07:29 mgorny Exp $
-EAPI=4
-PYTHON_COMPAT='python2_6 python2_7'
+EAPI=5
+PYTHON_COMPAT=( python2_6 python2_7 )
-inherit mercurial python-distutils-ng
+DISTUTILS_NO_PARALLEL_BUILD=1
+
+inherit distutils-r1 mercurial
DESCRIPTION="Online radio streaming player"
HOMEPAGE="http://radiotray.sourceforge.net/"
@@ -24,12 +26,12 @@ for x in ${LANGS}; do
IUSE="${IUSE} linguas_${x}"
done
-RDEPEND="dev-python/gst-python:0.10
- dev-python/pygtk
- dev-python/lxml
- dev-python/pyxdg
- dev-python/pygobject:2
- dev-python/notify-python
+RDEPEND="dev-python/gst-python:0.10[${PYTHON_USEDEP}]
+ dev-python/pygtk[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ dev-python/notify-python[${PYTHON_USEDEP}]
media-libs/gst-plugins-good:0.10
media-libs/gst-plugins-ugly:0.10
media-plugins/gst-plugins-alsa:0.10
@@ -42,15 +44,15 @@ RDEPEND="dev-python/gst-python:0.10
DEPEND="${RDEPEND}"
-DOCS="AUTHORS CONTRIBUTORS NEWS README"
+DOCS=( AUTHORS CONTRIBUTORS NEWS README )
-src_prepare() {
- python_convert_shebangs -r 2 .
- distutils_src_prepare
+python_prepare_all() {
# remove LINUGAS file so we can create our
rm "${S}"/po/LINGUAS
for x in ${LANGS}; do
use "linguas_${x}" && echo "${x}" >> "${S}"/po/LINGUAS
! use "linguas_${x}" && rm "${S}"/po/${x}.po
done
+
+ distutils-r1_python_prepare_all
}