summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2003-07-31 19:59:40 +0000
committerRyan Phillips <rphillips@gentoo.org>2003-07-31 19:59:40 +0000
commitfa762d7911ab21ff734f8a8d0bbccd4bb8741092 (patch)
tree1afd873bb0a12ba813a4ca961bef784b4f8d3383 /media-radio/ax25-apps/ax25-apps-0.0.6-r1.ebuild
parentAdded Samuel Greenfeld's changes. #23931 (diff)
downloadgentoo-2-fa762d7911ab21ff734f8a8d0bbccd4bb8741092.tar.gz
gentoo-2-fa762d7911ab21ff734f8a8d0bbccd4bb8741092.tar.bz2
gentoo-2-fa762d7911ab21ff734f8a8d0bbccd4bb8741092.zip
Samuel Greenfeld's fixes were added. #23897
Diffstat (limited to 'media-radio/ax25-apps/ax25-apps-0.0.6-r1.ebuild')
-rw-r--r--media-radio/ax25-apps/ax25-apps-0.0.6-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-radio/ax25-apps/ax25-apps-0.0.6-r1.ebuild b/media-radio/ax25-apps/ax25-apps-0.0.6-r1.ebuild
new file mode 100644
index 000000000000..8a969876e67a
--- /dev/null
+++ b/media-radio/ax25-apps/ax25-apps-0.0.6-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-radio/ax25-apps/ax25-apps-0.0.6-r1.ebuild,v 1.1 2003/07/31 19:59:40 rphillips Exp $
+
+DESCRIPTION="Basic AX.25 (Amateur Radio) user tools, additional daemons"
+HOMEPAGE="http://ax25.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ax25/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="virtual/glibc
+ >=dev-libs/libax25-0.0.7"
+
+src_install() {
+ make DESTDIR=${D} install installconf || die
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/ax25ipd.rc ax25ipd
+ newexe ${FILESDIR}/ax25mond.rc ax25mond
+ newexe ${FILESDIR}/ax25rtd.rc ax25rtd
+
+ # Make the documentation installation more Gentoo-like
+ rm -rf ${D}/usr/share/doc/ax25-apps
+ dodoc AUTHORS COPYING NEWS README ax25ipd/COPYING.ax25ipd \
+ ax25ipd/README.ax25ipd ax25rtd/README.ax25rtd \
+ ax25ipd/HISTORY.ax25ipd ax25rtd/TODO.ax25rtd
+
+ # FIXME: Configuration protect logic for the ax25rtd cache
+ # or move these files
+ # Moving might require changes to ax25rtd/ax25rtctl
+ insinto /var/lib/ax25/ax25rtd
+ newins ${FILESDIR}/ax25rtd.blank ax25_route
+ newins ${FILESDIR}/ax25rtd.blank ip_route
+
+}