summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Raghavan <ford_prefect@gentoo.org>2011-11-04 06:21:44 +0000
committerArun Raghavan <ford_prefect@gentoo.org>2011-11-04 06:21:44 +0000
commitf97bdb66e55dfec2cc4369d9a51c929b2c0ead67 (patch)
treeabbcf0527d00dda8645521e49b8a7cb77c342954 /media-plugins
parentAdd new gnome-3.2 documentation build tools from the gnome overlay. (diff)
downloadgentoo-2-f97bdb66e55dfec2cc4369d9a51c929b2c0ead67.tar.gz
gentoo-2-f97bdb66e55dfec2cc4369d9a51c929b2c0ead67.tar.bz2
gentoo-2-f97bdb66e55dfec2cc4369d9a51c929b2c0ead67.zip
Bump to 0.10.13. Switches internal libav to 0.7.2 and adds a bunch of other fixes.
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/gst-plugins-ffmpeg/ChangeLog9
-rw-r--r--media-plugins/gst-plugins-ffmpeg/gst-plugins-ffmpeg-0.10.13.ebuild44
2 files changed, 52 insertions, 1 deletions
diff --git a/media-plugins/gst-plugins-ffmpeg/ChangeLog b/media-plugins/gst-plugins-ffmpeg/ChangeLog
index cac95a0a9932..ec35ca825205 100644
--- a/media-plugins/gst-plugins-ffmpeg/ChangeLog
+++ b/media-plugins/gst-plugins-ffmpeg/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-plugins/gst-plugins-ffmpeg
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-ffmpeg/ChangeLog,v 1.130 2011/08/10 23:48:31 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-ffmpeg/ChangeLog,v 1.131 2011/11/04 06:21:44 ford_prefect Exp $
+
+*gst-plugins-ffmpeg-0.10.13 (04 Nov 2011)
+
+ 04 Nov 2011; Arun Raghavan <ford_prefect@gentoo.org>
+ +gst-plugins-ffmpeg-0.10.13.ebuild:
+ Bump to 0.10.13. Switches internal libav to 0.7.2 and adds a bunch of other
+ fixes.
*gst-plugins-ffmpeg-0.10.12 (10 Aug 2011)
diff --git a/media-plugins/gst-plugins-ffmpeg/gst-plugins-ffmpeg-0.10.13.ebuild b/media-plugins/gst-plugins-ffmpeg/gst-plugins-ffmpeg-0.10.13.ebuild
new file mode 100644
index 000000000000..c93732d18243
--- /dev/null
+++ b/media-plugins/gst-plugins-ffmpeg/gst-plugins-ffmpeg-0.10.13.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-ffmpeg/gst-plugins-ffmpeg-0.10.13.ebuild,v 1.1 2011/11/04 06:21:44 ford_prefect Exp $
+
+EAPI=1
+
+inherit flag-o-matic eutils base
+
+PD=${FILESDIR}/${PV}
+MY_PN=${PN/-plugins}
+MY_P=${MY_PN}-${PV}
+
+# Create a major/minor combo for SLOT
+PVP=(${PV//[-\._]/ })
+SLOT=${PVP[0]}.${PVP[1]}
+#SLOT=0.10
+
+DESCRIPTION="FFmpeg based gstreamer plugin"
+HOMEPAGE="http://gstreamer.freedesktop.org/modules/gst-ffmpeg.html"
+SRC_URI="http://gstreamer.freedesktop.org/src/${MY_PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="+orc"
+
+S=${WORKDIR}/${MY_P}
+
+RDEPEND=">=media-libs/gstreamer-0.10.31
+ >=media-libs/gst-plugins-base-0.10.31
+ orc? ( >=dev-lang/orc-0.4.6 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ append-flags -fno-strict-aliasing
+
+ econf $(use_enable orc)
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}