summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-09-13 23:07:16 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-09-13 23:07:16 +0000
commitc257679bcdb787e4e8be5e424b983706aa3e4198 (patch)
treedae71348faba64868c50f925cb66cc5d39c65d8d /media-plugins
parentPruned old versions, fixing bug #237441. (diff)
downloadgentoo-2-c257679bcdb787e4e8be5e424b983706aa3e4198.tar.gz
gentoo-2-c257679bcdb787e4e8be5e424b983706aa3e4198.tar.bz2
gentoo-2-c257679bcdb787e4e8be5e424b983706aa3e4198.zip
Version bump and include patch to support Audacious 1.5.
(Portage version: 2.2_rc8/cvs/Linux 2.6.27-rc6 x86_64)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/audacious-g15-spectrum/ChangeLog9
-rw-r--r--media-plugins/audacious-g15-spectrum/audacious-g15-spectrum-2.5.5.ebuild38
-rw-r--r--media-plugins/audacious-g15-spectrum/files/audacious-g15-spectrum-2.5.5-audacious-1.5.patch101
3 files changed, 147 insertions, 1 deletions
diff --git a/media-plugins/audacious-g15-spectrum/ChangeLog b/media-plugins/audacious-g15-spectrum/ChangeLog
index 18a48a9ac2e2..a899440f4f01 100644
--- a/media-plugins/audacious-g15-spectrum/ChangeLog
+++ b/media-plugins/audacious-g15-spectrum/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-plugins/audacious-g15-spectrum
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/audacious-g15-spectrum/ChangeLog,v 1.7 2008/01/18 11:56:42 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/audacious-g15-spectrum/ChangeLog,v 1.8 2008/09/13 23:07:11 robbat2 Exp $
+
+*audacious-g15-spectrum-2.5.5 (13 Sep 2008)
+
+ 13 Sep 2008; Robin H. Johnson <robbat2@gentoo.org>
+ +files/audacious-g15-spectrum-2.5.5-audacious-1.5.patch,
+ +audacious-g15-spectrum-2.5.5.ebuild:
+ Version bump and include patch to support Audacious 1.5.
31 Dec 2007; Markus Ullmann <jokey@gentoo.org>
+files/audacious-g15-spectrum-2.5.2-audacious-1.4.patch,
diff --git a/media-plugins/audacious-g15-spectrum/audacious-g15-spectrum-2.5.5.ebuild b/media-plugins/audacious-g15-spectrum/audacious-g15-spectrum-2.5.5.ebuild
new file mode 100644
index 000000000000..4c00aeef6041
--- /dev/null
+++ b/media-plugins/audacious-g15-spectrum/audacious-g15-spectrum-2.5.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/audacious-g15-spectrum/audacious-g15-spectrum-2.5.5.ebuild,v 1.1 2008/09/13 23:07:11 robbat2 Exp $
+
+inherit eutils versionator
+
+MY_PN="g15daemon-audacious"
+DESCRIPTION="Audacious Spectrum plugin to G15daemon"
+HOMEPAGE="http://g15daemon.sourceforge.net/"
+SRC_URI="mirror://sourceforge/g15daemon/${MY_PN}-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND=">=app-misc/g15daemon-1.9.0
+ dev-libs/libg15
+ >=dev-libs/libg15render-1.2
+ >=media-sound/audacious-1.5
+ >=x11-libs/gtk+-2.6.0
+ dev-libs/glib
+ x11-libs/pango"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-audacious-1.5.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS README
+}
diff --git a/media-plugins/audacious-g15-spectrum/files/audacious-g15-spectrum-2.5.5-audacious-1.5.patch b/media-plugins/audacious-g15-spectrum/files/audacious-g15-spectrum-2.5.5-audacious-1.5.patch
new file mode 100644
index 000000000000..3f07d28b8678
--- /dev/null
+++ b/media-plugins/audacious-g15-spectrum/files/audacious-g15-spectrum-2.5.5-audacious-1.5.patch
@@ -0,0 +1,101 @@
+As of Audacious-1.5, the old bmp_cfg* functions all have new names, leading to
+undefined symbols or compile failures.
+
+Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
+
+diff -Nuar --exclude '*~' g15daemon-audacious-2.5.5.orig/g15daemon_audacious_spectrum.c g15daemon-audacious-2.5.5/g15daemon_audacious_spectrum.c
+--- g15daemon-audacious-2.5.5.orig/g15daemon_audacious_spectrum.c 2008-05-24 05:58:01.000000000 -0700
++++ g15daemon-audacious-2.5.5/g15daemon_audacious_spectrum.c 2008-09-13 15:50:50.635729491 -0700
+@@ -287,28 +287,28 @@
+ {
+ ConfigDb *cfg;
+
+- cfg = bmp_cfg_db_open();
++ cfg = aud_cfg_db_open();
+ pthread_mutex_lock (&g15buf_mutex);
+ if (cfg)
+ {
+- bmp_cfg_db_get_int(cfg, "G15Daemon Spectrum", "visualisation_type", (int*)&vis_type);
+- bmp_cfg_db_get_float(cfg, "G15Daemon Spectrum", "linearity", (float*)&linearity);
+- bmp_cfg_db_get_int(cfg, "G15Daemon Spectrum", "amplification", (int*)&amplification);
+- bmp_cfg_db_get_int(cfg, "G15Daemon Spectrum", "bars_limit", (int*)&limit);
+- bmp_cfg_db_get_int(cfg, "G15Daemon Spectrum", "num_bars", (int*)&num_bars);
+- bmp_cfg_db_get_int(cfg, "G15Daemon Spectrum", "enable_peak", (int*)&enable_peak);
+- bmp_cfg_db_get_int(cfg, "G15Daemon Spectrum", "detached_peak", (int*)&detached_peak);
+- bmp_cfg_db_get_int(cfg, "G15Daemon Spectrum", "line_mode", (int*)&line_mode);
+- bmp_cfg_db_get_int(cfg, "G15Daemon Spectrum", "analog_mode", (int*)&analog_mode);
+- bmp_cfg_db_get_int(cfg, "G15Daemon Spectrum", "analog_step", (int*)&analog_step);
+- bmp_cfg_db_get_int(cfg, "G15Daemon Spectrum", "enable_keybindings", (int*)&enable_keybindings);
+- bmp_cfg_db_get_int(cfg, "G15Daemon Spectrum", "show_title", (int*)&show_title);
+- bmp_cfg_db_get_int(cfg, "G15Daemon Spectrum", "show_pbar", (int*)&show_pbar);
+- bmp_cfg_db_get_int(cfg, "G15Daemon Spectrum", "show_time", (int*)&show_time);
+- bmp_cfg_db_get_int(cfg, "G15Daemon Spectrum", "rownum", (int*)&rownum);
+- bmp_cfg_db_get_int(cfg, "G15Daemon Spectrum", "title_overlay", (int*)&title_overlay);
++ aud_cfg_db_get_int(cfg, "G15Daemon Spectrum", "visualisation_type", (int*)&vis_type);
++ aud_cfg_db_get_float(cfg, "G15Daemon Spectrum", "linearity", (float*)&linearity);
++ aud_cfg_db_get_int(cfg, "G15Daemon Spectrum", "amplification", (int*)&amplification);
++ aud_cfg_db_get_int(cfg, "G15Daemon Spectrum", "bars_limit", (int*)&limit);
++ aud_cfg_db_get_int(cfg, "G15Daemon Spectrum", "num_bars", (int*)&num_bars);
++ aud_cfg_db_get_int(cfg, "G15Daemon Spectrum", "enable_peak", (int*)&enable_peak);
++ aud_cfg_db_get_int(cfg, "G15Daemon Spectrum", "detached_peak", (int*)&detached_peak);
++ aud_cfg_db_get_int(cfg, "G15Daemon Spectrum", "line_mode", (int*)&line_mode);
++ aud_cfg_db_get_int(cfg, "G15Daemon Spectrum", "analog_mode", (int*)&analog_mode);
++ aud_cfg_db_get_int(cfg, "G15Daemon Spectrum", "analog_step", (int*)&analog_step);
++ aud_cfg_db_get_int(cfg, "G15Daemon Spectrum", "enable_keybindings", (int*)&enable_keybindings);
++ aud_cfg_db_get_int(cfg, "G15Daemon Spectrum", "show_title", (int*)&show_title);
++ aud_cfg_db_get_int(cfg, "G15Daemon Spectrum", "show_pbar", (int*)&show_pbar);
++ aud_cfg_db_get_int(cfg, "G15Daemon Spectrum", "show_time", (int*)&show_time);
++ aud_cfg_db_get_int(cfg, "G15Daemon Spectrum", "rownum", (int*)&rownum);
++ aud_cfg_db_get_int(cfg, "G15Daemon Spectrum", "title_overlay", (int*)&title_overlay);
+
+- bmp_cfg_db_close(cfg);
++ aud_cfg_db_close(cfg);
+
+ }
+ /* check conf integrity */
+@@ -351,27 +351,27 @@
+ {
+ ConfigDb *cfg;
+
+- cfg = bmp_cfg_db_open();
++ cfg = aud_cfg_db_open();
+
+ if (cfg)
+ {
+- bmp_cfg_db_set_int(cfg, "G15Daemon Spectrum", "visualisation_type", vis_type);
+- bmp_cfg_db_set_float(cfg, "G15Daemon Spectrum", "linearity", linearity);
+- bmp_cfg_db_set_int(cfg, "G15Daemon Spectrum", "amplification", amplification);
+- bmp_cfg_db_set_int(cfg, "G15Daemon Spectrum", "bars_limit", limit);
+- bmp_cfg_db_set_int(cfg, "G15Daemon Spectrum", "num_bars", num_bars);
+- bmp_cfg_db_set_int(cfg, "G15Daemon Spectrum", "enable_peak", enable_peak);
+- bmp_cfg_db_set_int(cfg, "G15Daemon Spectrum", "detached_peak", detached_peak);
+- bmp_cfg_db_set_int(cfg, "G15Daemon Spectrum", "analog_mode", analog_mode);
+- bmp_cfg_db_set_int(cfg, "G15Daemon Spectrum", "line_mode", line_mode);
+- bmp_cfg_db_set_int(cfg, "G15Daemon Spectrum", "analog_step", analog_step);
+- bmp_cfg_db_set_int(cfg, "G15Daemon Spectrum", "enable_keybindings", enable_keybindings);
+- bmp_cfg_db_set_int(cfg, "G15Daemon Spectrum", "show_title", show_title);
+- bmp_cfg_db_set_int(cfg, "G15Daemon Spectrum", "show_pbar", show_pbar);
+- bmp_cfg_db_set_int(cfg, "G15Daemon Spectrum", "show_time", show_time);
+- bmp_cfg_db_set_int(cfg, "G15Daemon Spectrum", "rownum", rownum);
+- bmp_cfg_db_set_int(cfg, "G15Daemon Spectrum", "title_overlay", title_overlay);
+- bmp_cfg_db_close(cfg);
++ aud_cfg_db_set_int(cfg, "G15Daemon Spectrum", "visualisation_type", vis_type);
++ aud_cfg_db_set_float(cfg, "G15Daemon Spectrum", "linearity", linearity);
++ aud_cfg_db_set_int(cfg, "G15Daemon Spectrum", "amplification", amplification);
++ aud_cfg_db_set_int(cfg, "G15Daemon Spectrum", "bars_limit", limit);
++ aud_cfg_db_set_int(cfg, "G15Daemon Spectrum", "num_bars", num_bars);
++ aud_cfg_db_set_int(cfg, "G15Daemon Spectrum", "enable_peak", enable_peak);
++ aud_cfg_db_set_int(cfg, "G15Daemon Spectrum", "detached_peak", detached_peak);
++ aud_cfg_db_set_int(cfg, "G15Daemon Spectrum", "analog_mode", analog_mode);
++ aud_cfg_db_set_int(cfg, "G15Daemon Spectrum", "line_mode", line_mode);
++ aud_cfg_db_set_int(cfg, "G15Daemon Spectrum", "analog_step", analog_step);
++ aud_cfg_db_set_int(cfg, "G15Daemon Spectrum", "enable_keybindings", enable_keybindings);
++ aud_cfg_db_set_int(cfg, "G15Daemon Spectrum", "show_title", show_title);
++ aud_cfg_db_set_int(cfg, "G15Daemon Spectrum", "show_pbar", show_pbar);
++ aud_cfg_db_set_int(cfg, "G15Daemon Spectrum", "show_time", show_time);
++ aud_cfg_db_set_int(cfg, "G15Daemon Spectrum", "rownum", rownum);
++ aud_cfg_db_set_int(cfg, "G15Daemon Spectrum", "title_overlay", title_overlay);
++ aud_cfg_db_close(cfg);
+ }
+
+ }